URWPGSim2D.Common Namespace

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
URWPGSim2D.Common Namespace
Send Feedback
水中机器人水球比赛仿真器（Underwater Robot Water Polo Game Simulator 2D）的核心组件，包括仿真机器鱼、仿真环境（仿真场地、仿真水球、仿真障碍物、仿真通道等）、仿真使命三大核心模型及其它相关定义和功能。

Classes

 | Class | Description
Public class | Ball | 仿真水球类
Public class | BallSettingComboControls | 服务端Fish设置界面BallSetting块控件组合类
Public class | Channel | 仿真通道类
Public class | CollisionDetection | 碰撞检测计算静态类
Public class | CollisionModelPolygon | 碰撞检测多边形模型类
Public class | DrawHelper | 仿真场地中圆形和方形对象绘制静态类
Public class | Field | 仿真比赛场地数据类
Public class | FishSettingComboControls | 服务端Fish设置界面FishSetting块控件组合类
Public class | Mission | 仿真使命（比赛或实验项目）基类，所有具体使命（比赛或实验项目）使用的使命类必须继承该类
Public class | MissionCommonPara | 仿真使命（比赛或实验项目）公共参数类型结构体
Public class | MyMission | 与使命相关各对象的引用
Public class | RectangularDynamic | 仿真场地中方形动态对象基类
Public class | RectangularObstacle | 仿真方形静态障碍物类
Public class | RectangularStatic | 仿真场地中方形静态对象基类
Public class | RoboFish | 仿真机器鱼基类，所有具体使命（比赛或实验项目）使用的仿真机器鱼类必须继承该类
Public class | RoundedDynamic | 仿真场地中圆形动态对象基类
Public class | RoundedObstacle | 仿真圆形静态障碍物类
Public class | RoundedStatic | 仿真场地中圆形静态对象基类
Public class | SimEnvironment | 仿真环境基类，所有具体使命（比赛或实验项目）使用的环境类必须继承该类
Public class | SysConfig | 系统参数配置xml文件处理类 by chenwei 20101106
Public class | Team<(Of <(<'TFish>)>)> | 仿真比赛队伍数据类
Public class | TeamCommonPara | 仿真机器鱼队伍公共参数类
Public class | UrwpgSimHelper | URWPGSim项目需要用到的辅助功能静态类

Structures

 | Structure | Description
Public structure | CollisionDetectionResult | 碰撞检测结果参数结构体
Public structure | Decision | 仿真机器鱼运动决策数据结构体

Interfaces

 | Interface | Description
Public interface | IMission | 仿真使命（比赛或实验项目）接口，仿真使命基类实现此接口
Public interface | IRoboFish | 仿真机器鱼行为接口，仿真机器鱼基类实现此接口
Public interface | ISimEnvironment | 仿真环境接口，仿真环境基类实现此接口

Enumerations

 | Enumeration | Description
Public enumeration | CollisionType | 仿真进程中可能发生的对象间碰撞类型枚举
Public enumeration | Field..::..GoalBlockType | 球门块方向类型，TYPE11/TYPE12分别表示直角弯钩里侧沿逆时针/顺时针方向
Public enumeration | HalfCourt | 场地左右半场类型枚举

有关这个主题的评论请发邮件到 bug report

Copyright @ PKU&HNIU


Ball Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball Class
Members See Also Send Feedback
仿真水球类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class Ball : RoundedDynamic, ICloneable, IDssSerializable
Visual Basic
<SerializableAttribute> _
Public Class Ball _
    Inherits RoundedDynamic _
    Implements ICloneable, IDssSerializable
Visual C++
[SerializableAttribute]
public ref class Ball : public RoundedDynamic,
    ICloneable, IDssSerializable

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..RoundedDynamic
URWPGSim2D.Common..::..Ball

See Also

Ball Members
URWPGSim2D.Common Namespace


Ball Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball Members
Ball Class Constructors Methods Fields See Also Send Feedback

The Ball type exposes the following members.

Constructors

 | Name | Description
Public method | Ball()()()() | 构造函数
Public method | Ball(Int32, Color) | 带参数构造函数

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本 (Overrides RoundedDynamic..::..Clone()()()().)
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象 (Overrides RoundedDynamic..::..CopyTo(IDssSerializable).)
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象 (Overrides RoundedDynamic..::..Deserialize(BinaryReader).)
Public method | Draw | 将当前对象绘制到GDI+绘图对象上 (Inherited from RoundedDynamic.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ResetSomeLocomotionPara | 重置仿真水球的部分运动学参数，用于重新初始化使命清除上一次运行结束时保存的值 (Inherited from RoundedDynamic.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象 (Overrides RoundedDynamic..::..Serialize(BinaryWriter).)
Public method | SetBall | 从配置文件中读取可配置参数
Public method | SetRoundedDynamic | 设置默认参数 (Inherited from RoundedDynamic.)
Public method | ToString | (Inherited from Object.)
Public method | UpdateBallLocomotionPara | 根据仿真周期毫秒数更新仿真水球运动学参数包括中心点位置坐标/速度值/速度方向/角速度值

Fields

 | Name | Description
Public field | AngularVelocityRadPs | 当前角速度值，单位弧度每秒rad/s (Inherited from RoundedDynamic.)
Public field | BorderWidthPix | 边框宽度，单位像素 (Inherited from RoundedDynamic.)
Public field | Collision | 当前碰撞状态 (Inherited from RoundedDynamic.)
Public field | ColorBorder | 边框颜色 (Inherited from RoundedDynamic.)
Public field | ColorFilled | 填充颜色 (Inherited from RoundedDynamic.)
Public field | PositionMm | 当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0 (Inherited from RoundedDynamic.)
Public field | PreAngularVelocityRadPs | 当前角速度值备份，单位弧度每秒rad/s (Inherited from RoundedDynamic.)
Public field | PreCollision | 当前碰撞状态备份 (Inherited from RoundedDynamic.)
Public field | PrePositionMm | 当前中心点坐标备份，各维坐标单位毫米mm，2D版本中Y坐标固定为0 (Inherited from RoundedDynamic.)
Public field | PreVelocityDirectionRad | 当前速度方向备份，单位弧度rad，值域[-PI, PI) (Inherited from RoundedDynamic.)
Public field | PreVelocityMmPs | 当前速度值备份，单位毫米每秒mm/s (Inherited from RoundedDynamic.)
Public field | RadiusMm | 半径（**设置**），单位毫米 (Inherited from RoundedDynamic.)
Public field | TrajectoryPoints | 仿真机器鱼绘制轨迹用的点列表
Public field | VelocityDirectionRad | 当前速度方向，单位弧度rad，值域[-PI, PI) (Inherited from RoundedDynamic.)
Public field | VelocityMmPs | 当前速度值，单位毫米每秒mm/s (Inherited from RoundedDynamic.)

See Also

Ball Class


Ball Constructor

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball Constructor
Ball Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Ball()()()() | 构造函数
Public method | Ball(Int32, Color) | 带参数构造函数

See Also

Ball Class
Ball Members


Ball Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball Constructor
Ball Class See Also Send Feedback
构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Ball()
Visual Basic
Public Sub New
Visual C++
public:
Ball()

See Also

Ball Class
Ball Overload


Ball Constructor (Int32, Color)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball Constructor (Int32, Color)
Ball Class See Also Send Feedback
带参数构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Ball(
    int radiusMm,
    Color color
)
Visual Basic
Public Sub New ( _
    radiusMm As Integer, _
    color As Color _
)
Visual C++
public:
Ball(
    int radiusMm,
    Color color
)

Parameters

radiusMm
Type: System..::..Int32
仿真水球半径
color
Type: System.Drawing..::..Color
仿真水球颜色

See Also

Ball Class
Ball Overload


Ball Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball Fields
Ball Class See Also Send Feedback

The Ball type exposes the following members.

Fields

 | Name | Description
Public field | AngularVelocityRadPs | 当前角速度值，单位弧度每秒rad/s (Inherited from RoundedDynamic.)
Public field | BorderWidthPix | 边框宽度，单位像素 (Inherited from RoundedDynamic.)
Public field | Collision | 当前碰撞状态 (Inherited from RoundedDynamic.)
Public field | ColorBorder | 边框颜色 (Inherited from RoundedDynamic.)
Public field | ColorFilled | 填充颜色 (Inherited from RoundedDynamic.)
Public field | PositionMm | 当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0 (Inherited from RoundedDynamic.)
Public field | PreAngularVelocityRadPs | 当前角速度值备份，单位弧度每秒rad/s (Inherited from RoundedDynamic.)
Public field | PreCollision | 当前碰撞状态备份 (Inherited from RoundedDynamic.)
Public field | PrePositionMm | 当前中心点坐标备份，各维坐标单位毫米mm，2D版本中Y坐标固定为0 (Inherited from RoundedDynamic.)
Public field | PreVelocityDirectionRad | 当前速度方向备份，单位弧度rad，值域[-PI, PI) (Inherited from RoundedDynamic.)
Public field | PreVelocityMmPs | 当前速度值备份，单位毫米每秒mm/s (Inherited from RoundedDynamic.)
Public field | RadiusMm | 半径（**设置**），单位毫米 (Inherited from RoundedDynamic.)
Public field | TrajectoryPoints | 仿真机器鱼绘制轨迹用的点列表
Public field | VelocityDirectionRad | 当前速度方向，单位弧度rad，值域[-PI, PI) (Inherited from RoundedDynamic.)
Public field | VelocityMmPs | 当前速度值，单位毫米每秒mm/s (Inherited from RoundedDynamic.)

See Also

Ball Class


TrajectoryPoints Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball..::..TrajectoryPoints Field
Ball Class See Also Send Feedback
仿真机器鱼绘制轨迹用的点列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Point> TrajectoryPoints
Visual Basic
Public TrajectoryPoints As List(Of Point)
Visual C++
public:
List<Point>^ TrajectoryPoints

See Also

Ball Class


Ball Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball Methods
Ball Class See Also Send Feedback

The Ball type exposes the following members.

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本 (Overrides RoundedDynamic..::..Clone()()()().)
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象 (Overrides RoundedDynamic..::..CopyTo(IDssSerializable).)
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象 (Overrides RoundedDynamic..::..Deserialize(BinaryReader).)
Public method | Draw | 将当前对象绘制到GDI+绘图对象上 (Inherited from RoundedDynamic.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ResetSomeLocomotionPara | 重置仿真水球的部分运动学参数，用于重新初始化使命清除上一次运行结束时保存的值 (Inherited from RoundedDynamic.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象 (Overrides RoundedDynamic..::..Serialize(BinaryWriter).)
Public method | SetBall | 从配置文件中读取可配置参数
Public method | SetRoundedDynamic | 设置默认参数 (Inherited from RoundedDynamic.)
Public method | ToString | (Inherited from Object.)
Public method | UpdateBallLocomotionPara | 根据仿真周期毫秒数更新仿真水球运动学参数包括中心点位置坐标/速度值/速度方向/角速度值

See Also

Ball Class


Clone Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball..::..Clone Method
Ball Class See Also Send Feedback
实现Clone接口的方法，拷贝一份当前对象的副本

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

当前对象的副本

Implements

ICloneable..::..Clone()()()()
IDssSerializableClone()()()()
ICloneable..::..Clone()()()()
IDssSerializableClone()()()()

See Also

Ball Class


CopyTo Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball..::..CopyTo Method
Ball Class See Also Send Feedback
实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override void CopyTo(
    IDssSerializable target
)
Visual Basic
Public Overrides Sub CopyTo ( _
    target As IDssSerializable _
)
Visual C++
public:
virtual void CopyTo(
    IDssSerializable^ target
) override

Parameters

target
Type: IDssSerializable
当前对象拷贝到的目标对象

Implements

IDssSerializableCopyTo(IDssSerializable)
IDssSerializableCopyTo(IDssSerializable)

See Also

Ball Class


Deserialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball..::..Deserialize Method
Ball Class See Also Send Feedback
实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override Object Deserialize(
    BinaryReader reader
)
Visual Basic
Public Overrides Function Deserialize ( _
    reader As BinaryReader _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    BinaryReader^ reader
) override

Parameters

reader
Type: System.IO..::..BinaryReader
反序列化操作的来源对象

Return Value

反序列化得到的当前类型对象

Implements

IDssSerializableDeserialize(BinaryReader)
IDssSerializableDeserialize(BinaryReader)

See Also

Ball Class


Serialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball..::..Serialize Method
Ball Class See Also Send Feedback
实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override void Serialize(
    BinaryWriter writer
)
Visual Basic
Public Overrides Sub Serialize ( _
    writer As BinaryWriter _
)
Visual C++
public:
virtual void Serialize(
    BinaryWriter^ writer
) override

Parameters

writer
Type: System.IO..::..BinaryWriter
当前对象序列化到的目标对象

Implements

IDssSerializableSerialize(BinaryWriter)
IDssSerializableSerialize(BinaryWriter)

See Also

Ball Class


SetBall Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball..::..SetBall Method
Ball Class See Also Send Feedback
从配置文件中读取可配置参数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void SetBall()
Visual Basic
Public Sub SetBall
Visual C++
public:
void SetBall()

See Also

Ball Class


UpdateBallLocomotionPara Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Ball..::..UpdateBallLocomotionPara Method
Ball Class See Also Send Feedback
根据仿真周期毫秒数更新仿真水球运动学参数包括中心点位置坐标/速度值/速度方向/角速度值

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void UpdateBallLocomotionPara(
    int timeIntervalMs
)
Visual Basic
Public Sub UpdateBallLocomotionPara ( _
    timeIntervalMs As Integer _
)
Visual C++
public:
void UpdateBallLocomotionPara(
    int timeIntervalMs
)

Parameters

timeIntervalMs
Type: System..::..Int32
仿真周期毫秒数

See Also

Ball Class


BallSettingComboControls Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
BallSettingComboControls Class
Members See Also Send Feedback
服务端Fish设置界面BallSetting块控件组合类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public class BallSettingComboControls
Visual Basic
Public Class BallSettingComboControls
Visual C++
public ref class BallSettingComboControls

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..BallSettingComboControls

See Also

BallSettingComboControls Members


BallSettingComboControls Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
BallSettingComboControls Members
BallSettingComboControls Class Constructors Methods Fields See Also Send Feedback

The BallSettingComboControls type exposes the following members.

Constructors

 | Name | Description
Public method | BallSettingComboControls | 带参数构造函数 根据仿真水球编号（从0开始）和当前仿真使命中仿真水球数量构造仿真水球设置对象

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SetBallInfoToUi | 将当前仿真水球对象详细信息设置到相应界面控件中
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | BallId | 当前组合控件所代表仿真水球的编号（0,1...)
Public field | BtnColor | 仿真水球填充色选择按钮控件
Public field | GrpContainer | 分组容器控件
Public field | TxtPositionMmX | 仿真水球位置坐标X分量显示控件
Public field | TxtPositionMmZ | 仿真水球位置坐标Z分量显示控件
Public field | TxtRadiusMm | 仿真水球半径值显示控件

See Also

BallSettingComboControls Class


BallSettingComboControls Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
BallSettingComboControls Constructor
BallSettingComboControls Class See Also Send Feedback
带参数构造函数 根据仿真水球编号（从0开始）和当前仿真使命中仿真水球数量构造仿真水球设置对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public BallSettingComboControls(
    int ballId,
    int balls
)
Visual Basic
Public Sub New ( _
    ballId As Integer, _
    balls As Integer _
)
Visual C++
public:
BallSettingComboControls(
    int ballId,
    int balls
)

Parameters

ballId
Type: System..::..Int32
仿真水球编号（从0开始）
balls
Type: System..::..Int32
当前仿真使命中仿真水球数量

See Also

BallSettingComboControls Class


BallSettingComboControls Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
BallSettingComboControls Fields
BallSettingComboControls Class See Also Send Feedback

The BallSettingComboControls type exposes the following members.

Fields

 | Name | Description
Public field | BallId | 当前组合控件所代表仿真水球的编号（0,1...)
Public field | BtnColor | 仿真水球填充色选择按钮控件
Public field | GrpContainer | 分组容器控件
Public field | TxtPositionMmX | 仿真水球位置坐标X分量显示控件
Public field | TxtPositionMmZ | 仿真水球位置坐标Z分量显示控件
Public field | TxtRadiusMm | 仿真水球半径值显示控件

See Also

BallSettingComboControls Class


BallId Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
BallSettingComboControls..::..BallId Field
BallSettingComboControls Class See Also Send Feedback
当前组合控件所代表仿真水球的编号（0,1...)

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int BallId
Visual Basic
Public BallId As Integer
Visual C++
public:
int BallId

See Also

BallSettingComboControls Class


BtnColor Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
BallSettingComboControls..::..BtnColor Field
BallSettingComboControls Class See Also Send Feedback
仿真水球填充色选择按钮控件

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Button BtnColor
Visual Basic
Public BtnColor As Button
Visual C++
public:
Button^ BtnColor

See Also

BallSettingComboControls Class


GrpContainer Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
BallSettingComboControls..::..GrpContainer Field
BallSettingComboControls Class See Also Send Feedback
分组容器控件

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public GroupBox GrpContainer
Visual Basic
Public GrpContainer As GroupBox
Visual C++
public:
GroupBox^ GrpContainer

See Also

BallSettingComboControls Class


TxtPositionMmX Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
BallSettingComboControls..::..TxtPositionMmX Field
BallSettingComboControls Class See Also Send Feedback
仿真水球位置坐标X分量显示控件

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public TextBox TxtPositionMmX
Visual Basic
Public TxtPositionMmX As TextBox
Visual C++
public:
TextBox^ TxtPositionMmX

See Also

BallSettingComboControls Class


TxtPositionMmZ Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
BallSettingComboControls..::..TxtPositionMmZ Field
BallSettingComboControls Class See Also Send Feedback
仿真水球位置坐标Z分量显示控件

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public TextBox TxtPositionMmZ
Visual Basic
Public TxtPositionMmZ As TextBox
Visual C++
public:
TextBox^ TxtPositionMmZ

See Also

BallSettingComboControls Class


TxtRadiusMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
BallSettingComboControls..::..TxtRadiusMm Field
BallSettingComboControls Class See Also Send Feedback
仿真水球半径值显示控件

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public TextBox TxtRadiusMm
Visual Basic
Public TxtRadiusMm As TextBox
Visual C++
public:
TextBox^ TxtRadiusMm

See Also

BallSettingComboControls Class


BallSettingComboControls Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
BallSettingComboControls Methods
BallSettingComboControls Class See Also Send Feedback

The BallSettingComboControls type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SetBallInfoToUi | 将当前仿真水球对象详细信息设置到相应界面控件中
Public method | ToString | (Inherited from Object.)

See Also

BallSettingComboControls Class


SetBallInfoToUi Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
BallSettingComboControls..::..SetBallInfoToUi Method
BallSettingComboControls Class See Also Send Feedback
将当前仿真水球对象详细信息设置到相应界面控件中

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void SetBallInfoToUi()
Visual Basic
Public Sub SetBallInfoToUi
Visual C++
public:
void SetBallInfoToUi()

See Also

BallSettingComboControls Class


Channel Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel Class
Members See Also Send Feedback
仿真通道类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class Channel : RectangularStatic, ICloneable,
    IDssSerializable
Visual Basic
<SerializableAttribute> _
Public Class Channel _
    Inherits RectangularStatic _
    Implements ICloneable, IDssSerializable
Visual C++
[SerializableAttribute]
public ref class Channel : public RectangularStatic,
    ICloneable, IDssSerializable

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..RectangularStatic
URWPGSim2D.Common..::..Channel

See Also

Channel Members


Channel Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel Members
Channel Class Constructors Methods Fields See Also Send Feedback

The Channel type exposes the following members.

Constructors

 | Name | Description
Public method | Channel()()()() | 默认构造函数
Public method | Channel(String, Vector3, Color, Int32, Int32, Single) | 带参数构造函数
Public method | Channel(String, Vector3, Color, Color, Int32, Int32, Single) | 带参数构造函数
Public method | Channel(String, Vector3, Color, Color, Int32, Int32, Int32, Single) | 带参数构造函数

Methods

 | Name | Description
Protected method | CalculateCollisionDetectionParas | 计算碰撞检测参数，由各继承类构造函数调用 (Inherited from RectangularStatic.)
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本 (Overrides RectangularStatic..::..Clone()()()().)
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象 (Overrides RectangularStatic..::..CopyTo(IDssSerializable).)
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象 (Overrides RectangularStatic..::..Deserialize(BinaryReader).)
Public method | Draw | 将当前对象绘制到GDI+绘图对象上 (Inherited from RectangularStatic.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象 (Overrides RectangularStatic..::..Serialize(BinaryWriter).)
Public method | SetRectangularStatic | 设置默认参数 (Inherited from RectangularStatic.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | BorderWidthPix | 边框宽度，单位像素 (Inherited from RectangularStatic.)
Public field | CircumcircleRadiusMm | 外接圆半径（**根据长度宽度计算**），单位毫米 (Inherited from RectangularStatic.)
Public field | ColorBorder | 边框颜色 (Inherited from RectangularStatic.)
Public field | ColorFilled | 填充颜色 (Inherited from RectangularStatic.)
Public field | DirectionRad | 方向（**设置**），单位弧度 (Inherited from RectangularStatic.)
Public field | LengthDirectionRad | 当前长度（Length）方向，单位弧度rad (Inherited from RectangularStatic.)
Public field | LengthMm | 长度（**设置**），单位毫米 (Inherited from RectangularStatic.)
Public field | Name | 名称
Public field | PolygonVertices | 矩形4个顶点列表，4个元素依次为左上/右上/右下/左下，各顶点各维坐标单位毫米 (Inherited from RectangularStatic.)
Public field | PositionMm | 当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0 (Inherited from RectangularStatic.)
Public field | WidthMm | 宽度（**设置**），单位毫米 (Inherited from RectangularStatic.)

See Also

Channel Class


Channel Constructor

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel Constructor
Channel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Channel()()()() | 默认构造函数
Public method | Channel(String, Vector3, Color, Int32, Int32, Single) | 带参数构造函数
Public method | Channel(String, Vector3, Color, Color, Int32, Int32, Single) | 带参数构造函数
Public method | Channel(String, Vector3, Color, Color, Int32, Int32, Int32, Single) | 带参数构造函数

See Also

Channel Class
Channel Members


Channel Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel Constructor
Channel Class See Also Send Feedback
默认构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Channel()
Visual Basic
Public Sub New
Visual C++
public:
Channel()

See Also

Channel Class
Channel Overload


Channel Constructor (String, , Color, Int32, Int32, Single)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel Constructor (String, , Color, Int32, Int32, Single)
Channel Class See Also Send Feedback
带参数构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Channel(
    string strName,
    Vector3 positionMm,
    Color color,
    int lengthMm,
    int widthMm,
    float directionDeg
)
Visual Basic
Public Sub New ( _
    strName As String, _
    positionMm As Vector3, _
    color As Color, _
    lengthMm As Integer, _
    widthMm As Integer, _
    directionDeg As Single _
)
Visual C++
public:
Channel(
    String^ strName,
    Vector3 positionMm,
    Color color,
    int lengthMm,
    int widthMm,
    float directionDeg
)

Parameters

strName
Type: System..::..String
仿真通道名称
positionMm
Type: Vector3
仿真通道中心点位置（在场地坐标系中，以毫米为单位）
color
Type: System.Drawing..::..Color
仿真通道颜色
lengthMm
Type: System..::..Int32
仿真通道长度（以毫米为单位）
widthMm
Type: System..::..Int32
仿真通道宽度（以毫米为单位）
directionDeg
Type: System..::..Single
仿真通道方向（在场地坐标系中，以弧度为单位）

See Also

Channel Class
Channel Overload


Channel Constructor (String, , Color, Color, Int32, Int32, Single)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel Constructor (String, , Color, Color, Int32, Int32, Single)
Channel Class See Also Send Feedback
带参数构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Channel(
    string strName,
    Vector3 positionMm,
    Color colorBorder,
    Color colorFilled,
    int lengthMm,
    int widthMm,
    float directionDeg
)
Visual Basic
Public Sub New ( _
    strName As String, _
    positionMm As Vector3, _
    colorBorder As Color, _
    colorFilled As Color, _
    lengthMm As Integer, _
    widthMm As Integer, _
    directionDeg As Single _
)
Visual C++
public:
Channel(
    String^ strName,
    Vector3 positionMm,
    Color colorBorder,
    Color colorFilled,
    int lengthMm,
    int widthMm,
    float directionDeg
)

Parameters

strName
Type: System..::..String
仿真通道名称
positionMm
Type: Vector3
仿真通道中心点位置（在场地坐标系中，以毫米为单位）
colorBorder
Type: System.Drawing..::..Color
仿真通道轮廓颜色
colorFilled
Type: System.Drawing..::..Color
仿真通道填充颜色
lengthMm
Type: System..::..Int32
仿真通道长度（以毫米为单位）
widthMm
Type: System..::..Int32
仿真通道宽度（以毫米为单位）
directionDeg
Type: System..::..Single
仿真通道方向（在场地坐标系中，以弧度为单位）

See Also

Channel Class
Channel Overload


Channel Constructor (String, , Color, Color, Int32, Int32, Int32, Single)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel Constructor (String, , Color, Color, Int32, Int32, Int32, Single)
Channel Class See Also Send Feedback
带参数构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Channel(
    string strName,
    Vector3 positionMm,
    Color colorBorder,
    Color colorFilled,
    int borderWithPix,
    int lengthMm,
    int widthMm,
    float directionDeg
)
Visual Basic
Public Sub New ( _
    strName As String, _
    positionMm As Vector3, _
    colorBorder As Color, _
    colorFilled As Color, _
    borderWithPix As Integer, _
    lengthMm As Integer, _
    widthMm As Integer, _
    directionDeg As Single _
)
Visual C++
public:
Channel(
    String^ strName,
    Vector3 positionMm,
    Color colorBorder,
    Color colorFilled,
    int borderWithPix,
    int lengthMm,
    int widthMm,
    float directionDeg
)

Parameters

strName
Type: System..::..String
仿真通道名称
positionMm
Type: Vector3
仿真通道中心点位置（在场地坐标系中，以毫米为单位）
colorBorder
Type: System.Drawing..::..Color
仿真通道轮廓颜色
colorFilled
Type: System.Drawing..::..Color
仿真通道填充颜色
borderWithPix
Type: System..::..Int32
仿真通道轮廓像素宽度
lengthMm
Type: System..::..Int32
仿真通道长度（以毫米为单位）
widthMm
Type: System..::..Int32
仿真通道宽度（以毫米为单位）
directionDeg
Type: System..::..Single
仿真通道方向（在场地坐标系中，以弧度为单位）

See Also

Channel Class
Channel Overload


Channel Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel Fields
Channel Class See Also Send Feedback

The Channel type exposes the following members.

Fields

 | Name | Description
Public field | BorderWidthPix | 边框宽度，单位像素 (Inherited from RectangularStatic.)
Public field | CircumcircleRadiusMm | 外接圆半径（**根据长度宽度计算**），单位毫米 (Inherited from RectangularStatic.)
Public field | ColorBorder | 边框颜色 (Inherited from RectangularStatic.)
Public field | ColorFilled | 填充颜色 (Inherited from RectangularStatic.)
Public field | DirectionRad | 方向（**设置**），单位弧度 (Inherited from RectangularStatic.)
Public field | LengthDirectionRad | 当前长度（Length）方向，单位弧度rad (Inherited from RectangularStatic.)
Public field | LengthMm | 长度（**设置**），单位毫米 (Inherited from RectangularStatic.)
Public field | Name | 名称
Public field | PolygonVertices | 矩形4个顶点列表，4个元素依次为左上/右上/右下/左下，各顶点各维坐标单位毫米 (Inherited from RectangularStatic.)
Public field | PositionMm | 当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0 (Inherited from RectangularStatic.)
Public field | WidthMm | 宽度（**设置**），单位毫米 (Inherited from RectangularStatic.)

See Also

Channel Class


Name Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel..::..Name Field
Channel Class See Also Send Feedback
名称

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public string Name
Visual Basic
Public Name As String
Visual C++
public:
String^ Name

See Also

Channel Class


Channel Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel Methods
Channel Class See Also Send Feedback

The Channel type exposes the following members.

Methods

 | Name | Description
Protected method | CalculateCollisionDetectionParas | 计算碰撞检测参数，由各继承类构造函数调用 (Inherited from RectangularStatic.)
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本 (Overrides RectangularStatic..::..Clone()()()().)
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象 (Overrides RectangularStatic..::..CopyTo(IDssSerializable).)
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象 (Overrides RectangularStatic..::..Deserialize(BinaryReader).)
Public method | Draw | 将当前对象绘制到GDI+绘图对象上 (Inherited from RectangularStatic.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象 (Overrides RectangularStatic..::..Serialize(BinaryWriter).)
Public method | SetRectangularStatic | 设置默认参数 (Inherited from RectangularStatic.)
Public method | ToString | (Inherited from Object.)

See Also

Channel Class


Clone Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel..::..Clone Method
Channel Class See Also Send Feedback
实现Clone接口的方法，拷贝一份当前对象的副本

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

当前对象的副本

Implements

ICloneable..::..Clone()()()()
IDssSerializableClone()()()()
ICloneable..::..Clone()()()()
IDssSerializableClone()()()()

See Also

Channel Class


CopyTo Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel..::..CopyTo Method
Channel Class See Also Send Feedback
实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override void CopyTo(
    IDssSerializable target
)
Visual Basic
Public Overrides Sub CopyTo ( _
    target As IDssSerializable _
)
Visual C++
public:
virtual void CopyTo(
    IDssSerializable^ target
) override

Parameters

target
Type: IDssSerializable
当前对象拷贝到的目标对象

Implements

IDssSerializableCopyTo(IDssSerializable)
IDssSerializableCopyTo(IDssSerializable)

See Also

Channel Class


Deserialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel..::..Deserialize Method
Channel Class See Also Send Feedback
实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override Object Deserialize(
    BinaryReader reader
)
Visual Basic
Public Overrides Function Deserialize ( _
    reader As BinaryReader _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    BinaryReader^ reader
) override

Parameters

reader
Type: System.IO..::..BinaryReader
反序列化操作的来源对象

Return Value

反序列化得到的当前类型对象

Implements

IDssSerializableDeserialize(BinaryReader)
IDssSerializableDeserialize(BinaryReader)

See Also

Channel Class


Serialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Channel..::..Serialize Method
Channel Class See Also Send Feedback
实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override void Serialize(
    BinaryWriter writer
)
Visual Basic
Public Overrides Sub Serialize ( _
    writer As BinaryWriter _
)
Visual C++
public:
virtual void Serialize(
    BinaryWriter^ writer
) override

Parameters

writer
Type: System.IO..::..BinaryWriter
当前对象序列化到的目标对象

Implements

IDssSerializableSerialize(BinaryWriter)
IDssSerializableSerialize(BinaryWriter)

See Also

Channel Class


CollisionDetection Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection Class
Members See Also Send Feedback
碰撞检测计算静态类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static class CollisionDetection
Visual Basic
Public NotInheritable Class CollisionDetection
Visual C++
public ref class CollisionDetection abstract sealed

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..CollisionDetection

See Also

CollisionDetection Members


CollisionDetection Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection Members
CollisionDetection Class Methods See Also Send Feedback

The CollisionDetection type exposes the following members.

Methods

Name | Description
CollisionBetweenPolygonAndCircle | 对一个多边形和一个圆形模型进行碰撞检测，返回碰撞检测结果参数结构体
CollisionBetweenPolygonAndRoundedObstacle | 对一个多边形和一个圆形障碍物进行碰撞检测，返回碰撞检测结果参数结构体
CollisionBetweenTwoCircles | 检测两圆形对象的碰撞情况,设定第一个圆恒为动态的
CollisionBetweenTwoPolygons | 对两个多边形模型进行碰撞检测，这里设第1个多边形是动态对象的模型，返回碰撞检测结果参数结构体
DetectCollisionBetweenBallAndBorder | 检测仿真水球和仿真场地边界及球门块碰撞情况
DetectCollisionBetweenBallAndObstacle(Ball%, RectangularObstacle) | 检测球和方形障碍物之间的碰撞情况
DetectCollisionBetweenBallAndObstacle(Ball%, RoundedObstacle) | 检测球和圆形障碍物之间的碰撞情况
DetectCollisionBetweenFishAndBall | 检测仿真机器鱼和仿真水球的碰撞情况
DetectCollisionBetweenFishAndBorder | 检测仿真鱼和仿真场地边界及球门块碰撞情况
DetectCollisionBetweenFishAndObstacle(RoboFish%, RectangularObstacle) | 检测鱼和方形障碍物之间的碰撞情况
DetectCollisionBetweenFishAndObstacle(RoboFish%, RoundedObstacle) | 检测鱼和圆形障碍物之间的碰撞情况
DetectCollisionBetweenTwoBalls | 检测两球之间的碰撞情况
DetectCollisionBetweenTwoFishes | 检测两条仿真机器鱼之间碰撞情况

See Also

CollisionDetection Class


CollisionDetection Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection Methods
CollisionDetection Class See Also Send Feedback

The CollisionDetection type exposes the following members.

Methods

Name | Description
CollisionBetweenPolygonAndCircle | 对一个多边形和一个圆形模型进行碰撞检测，返回碰撞检测结果参数结构体
CollisionBetweenPolygonAndRoundedObstacle | 对一个多边形和一个圆形障碍物进行碰撞检测，返回碰撞检测结果参数结构体
CollisionBetweenTwoCircles | 检测两圆形对象的碰撞情况,设定第一个圆恒为动态的
CollisionBetweenTwoPolygons | 对两个多边形模型进行碰撞检测，这里设第1个多边形是动态对象的模型，返回碰撞检测结果参数结构体
DetectCollisionBetweenBallAndBorder | 检测仿真水球和仿真场地边界及球门块碰撞情况
DetectCollisionBetweenBallAndObstacle(Ball%, RectangularObstacle) | 检测球和方形障碍物之间的碰撞情况
DetectCollisionBetweenBallAndObstacle(Ball%, RoundedObstacle) | 检测球和圆形障碍物之间的碰撞情况
DetectCollisionBetweenFishAndBall | 检测仿真机器鱼和仿真水球的碰撞情况
DetectCollisionBetweenFishAndBorder | 检测仿真鱼和仿真场地边界及球门块碰撞情况
DetectCollisionBetweenFishAndObstacle(RoboFish%, RectangularObstacle) | 检测鱼和方形障碍物之间的碰撞情况
DetectCollisionBetweenFishAndObstacle(RoboFish%, RoundedObstacle) | 检测鱼和圆形障碍物之间的碰撞情况
DetectCollisionBetweenTwoBalls | 检测两球之间的碰撞情况
DetectCollisionBetweenTwoFishes | 检测两条仿真机器鱼之间碰撞情况

See Also

CollisionDetection Class


CollisionBetweenPolygonAndCircle Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..CollisionBetweenPolygonAndCircle Method
CollisionDetection Class See Also Send Feedback
对一个多边形和一个圆形模型进行碰撞检测，返回碰撞检测结果参数结构体

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static CollisionDetectionResult CollisionBetweenPolygonAndCircle(
    CollisionModelPolygon polygon,
    Ball ball,
    bool staticStatus
)
Visual Basic
Public Shared Function CollisionBetweenPolygonAndCircle ( _
    polygon As CollisionModelPolygon, _
    ball As Ball, _
    staticStatus As Boolean _
) As CollisionDetectionResult
Visual C++
public:
static CollisionDetectionResult CollisionBetweenPolygonAndCircle(
    CollisionModelPolygon^ polygon,
    Ball^ ball,
    bool staticStatus
)

Parameters

polygon
Type: URWPGSim2D.Common..::..CollisionModelPolygon
待测多边形的模型对象
ball
Type: URWPGSim2D.Common..::..Ball
待测球的模型对象
staticStatus
Type: System..::..Boolean
待测多边形的状态为静态或是动态

Return Value

返回碰撞检测结果结构体

See Also

CollisionDetection Class


CollisionBetweenPolygonAndRoundedObstacle Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..CollisionBetweenPolygonAndRoundedObstacle Method
CollisionDetection Class See Also Send Feedback
对一个多边形和一个圆形障碍物进行碰撞检测，返回碰撞检测结果参数结构体

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static CollisionDetectionResult CollisionBetweenPolygonAndRoundedObstacle(
    CollisionModelPolygon polygon,
    RoundedObstacle roundedObstacle
)
Visual Basic
Public Shared Function CollisionBetweenPolygonAndRoundedObstacle ( _
    polygon As CollisionModelPolygon, _
    roundedObstacle As RoundedObstacle _
) As CollisionDetectionResult
Visual C++
public:
static CollisionDetectionResult CollisionBetweenPolygonAndRoundedObstacle(
    CollisionModelPolygon^ polygon,
    RoundedObstacle^ roundedObstacle
)

Parameters

polygon
Type: URWPGSim2D.Common..::..CollisionModelPolygon
待测多边形的模型对象
roundedObstacle
Type: URWPGSim2D.Common..::..RoundedObstacle
待测圆形障碍物的模型对象

Return Value

返回碰撞检测结果结构体

See Also

CollisionDetection Class


CollisionBetweenTwoCircles Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..CollisionBetweenTwoCircles Method
CollisionDetection Class See Also Send Feedback
检测两圆形对象的碰撞情况,设定第一个圆恒为动态的

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static CollisionDetectionResult CollisionBetweenTwoCircles(
    Vector3 center1,
    int radius1,
    Vector3 center2,
    int radius2
)
Visual Basic
Public Shared Function CollisionBetweenTwoCircles ( _
    center1 As Vector3, _
    radius1 As Integer, _
    center2 As Vector3, _
    radius2 As Integer _
) As CollisionDetectionResult
Visual C++
public:
static CollisionDetectionResult CollisionBetweenTwoCircles(
    Vector3 center1,
    int radius1,
    Vector3 center2,
    int radius2
)

Parameters

center1
Type: Vector3
待测第一个圆的圆心点
radius1
Type: System..::..Int32
待测第一个圆的半径
center2
Type: Vector3
待测第二个圆的圆心点
radius2
Type: System..::..Int32
待测第二个圆的半径

Return Value

返回碰撞检测结果结构体

See Also

CollisionDetection Class


CollisionBetweenTwoPolygons Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..CollisionBetweenTwoPolygons Method
CollisionDetection Class See Also Send Feedback
对两个多边形模型进行碰撞检测，这里设第1个多边形是动态对象的模型，返回碰撞检测结果参数结构体

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static CollisionDetectionResult CollisionBetweenTwoPolygons(
    CollisionModelPolygon polygonA,
    CollisionModelPolygon polygonB,
    bool staticStatus
)
Visual Basic
Public Shared Function CollisionBetweenTwoPolygons ( _
    polygonA As CollisionModelPolygon, _
    polygonB As CollisionModelPolygon, _
    staticStatus As Boolean _
) As CollisionDetectionResult
Visual C++
public:
static CollisionDetectionResult CollisionBetweenTwoPolygons(
    CollisionModelPolygon^ polygonA,
    CollisionModelPolygon^ polygonB,
    bool staticStatus
)

Parameters

polygonA
Type: URWPGSim2D.Common..::..CollisionModelPolygon
待检测的第1个多边形模型对象
polygonB
Type: URWPGSim2D.Common..::..CollisionModelPolygon
待检测的第2个多边形模型对象
staticStatus
Type: System..::..Boolean
第2个多边形是否是静态对象的模型

Return Value

碰撞检测结果参数结构体

See Also

CollisionDetection Class


DetectCollisionBetweenBallAndBorder Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..DetectCollisionBetweenBallAndBorder Method
CollisionDetection Class See Also Send Feedback
检测仿真水球和仿真场地边界及球门块碰撞情况

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static CollisionDetectionResult DetectCollisionBetweenBallAndBorder(
    ref Ball ball,
    Field field
)
Visual Basic
Public Shared Function DetectCollisionBetweenBallAndBorder ( _
    ByRef ball As Ball, _
    field As Field _
) As CollisionDetectionResult
Visual C++
public:
static CollisionDetectionResult DetectCollisionBetweenBallAndBorder(
    Ball^% ball,
    Field^ field
)

Parameters

ball
Type: URWPGSim2D.Common..::..Ball %
待检测的仿真水球对象引用
field
Type: URWPGSim2D.Common..::..Field
待检测仿真场地Field对象，用到四个球门块的顶点坐标列表和四个边界坐标值

Return Value

碰撞检测结果参数结构体包括是否碰撞/碰撞作用面中的法向/碰撞作用点坐标

See Also

CollisionDetection Class


DetectCollisionBetweenBallAndObstacle Method

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..DetectCollisionBetweenBallAndObstacle Method
CollisionDetection Class See Also Send Feedback

Overload List

Name | Description
DetectCollisionBetweenBallAndObstacle(Ball%, RectangularObstacle) | 检测球和方形障碍物之间的碰撞情况
DetectCollisionBetweenBallAndObstacle(Ball%, RoundedObstacle) | 检测球和圆形障碍物之间的碰撞情况

See Also

CollisionDetection Class
CollisionDetection Members


DetectCollisionBetweenBallAndObstacle Method (Ball, RectangularObstacle)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..DetectCollisionBetweenBallAndObstacle Method (Ball%, RectangularObstacle)
CollisionDetection Class See Also Send Feedback
检测球和方形障碍物之间的碰撞情况

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static CollisionDetectionResult DetectCollisionBetweenBallAndObstacle(
    ref Ball ball,
    RectangularObstacle rectangularObstacle
)
Visual Basic
Public Shared Function DetectCollisionBetweenBallAndObstacle ( _
    ByRef ball As Ball, _
    rectangularObstacle As RectangularObstacle _
) As CollisionDetectionResult
Visual C++
public:
static CollisionDetectionResult DetectCollisionBetweenBallAndObstacle(
    Ball^% ball,
    RectangularObstacle^ rectangularObstacle
)

Parameters

ball
Type: URWPGSim2D.Common..::..Ball %
待测球的模型对象
rectangularObstacle
Type: URWPGSim2D.Common..::..RectangularObstacle
待测方形障碍物的模型对象

Return Value

返回碰撞检测结果结构体

See Also

CollisionDetection Class
DetectCollisionBetweenBallAndObstacle Overload


DetectCollisionBetweenBallAndObstacle Method (Ball, RoundedObstacle)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..DetectCollisionBetweenBallAndObstacle Method (Ball%, RoundedObstacle)
CollisionDetection Class See Also Send Feedback
检测球和圆形障碍物之间的碰撞情况

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static CollisionDetectionResult DetectCollisionBetweenBallAndObstacle(
    ref Ball ball,
    RoundedObstacle roundedObstacle
)
Visual Basic
Public Shared Function DetectCollisionBetweenBallAndObstacle ( _
    ByRef ball As Ball, _
    roundedObstacle As RoundedObstacle _
) As CollisionDetectionResult
Visual C++
public:
static CollisionDetectionResult DetectCollisionBetweenBallAndObstacle(
    Ball^% ball,
    RoundedObstacle^ roundedObstacle
)

Parameters

ball
Type: URWPGSim2D.Common..::..Ball %
待测球的模型对象
roundedObstacle
Type: URWPGSim2D.Common..::..RoundedObstacle
待测圆形障碍物的模型对象

Return Value

返回碰撞检测结果结构体

See Also

CollisionDetection Class
DetectCollisionBetweenBallAndObstacle Overload


DetectCollisionBetweenFishAndBall Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..DetectCollisionBetweenFishAndBall Method
CollisionDetection Class See Also Send Feedback
检测仿真机器鱼和仿真水球的碰撞情况

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static CollisionDetectionResult DetectCollisionBetweenFishAndBall(
    ref RoboFish fish,
    ref Ball ball
)
Visual Basic
Public Shared Function DetectCollisionBetweenFishAndBall ( _
    ByRef fish As RoboFish, _
    ByRef ball As Ball _
) As CollisionDetectionResult
Visual C++
public:
static CollisionDetectionResult DetectCollisionBetweenFishAndBall(
    RoboFish^% fish,
    Ball^% ball
)

Parameters

fish
Type: URWPGSim2D.Common..::..RoboFish %
待检测的仿真机器鱼对象引用
ball
Type: URWPGSim2D.Common..::..Ball %
待检测的仿真水球对象引用

Return Value

碰撞检测结果参数结构体包括是否碰撞/碰撞作用面中的法向/碰撞作用点坐标

See Also

CollisionDetection Class


DetectCollisionBetweenFishAndBorder Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..DetectCollisionBetweenFishAndBorder Method
CollisionDetection Class See Also Send Feedback
检测仿真鱼和仿真场地边界及球门块碰撞情况

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static CollisionDetectionResult DetectCollisionBetweenFishAndBorder(
    ref RoboFish fish,
    Field field
)
Visual Basic
Public Shared Function DetectCollisionBetweenFishAndBorder ( _
    ByRef fish As RoboFish, _
    field As Field _
) As CollisionDetectionResult
Visual C++
public:
static CollisionDetectionResult DetectCollisionBetweenFishAndBorder(
    RoboFish^% fish,
    Field^ field
)

Parameters

fish
Type: URWPGSim2D.Common..::..RoboFish %
待检测的仿真机器鱼对象引用
field
Type: URWPGSim2D.Common..::..Field
待检测仿真场地Field对象，用到四个球门块的顶点坐标列表和四个边界坐标值

Return Value

碰撞检测结果参数结构体包括是否碰撞/碰撞作用面中的法向/碰撞作用点坐标

See Also

CollisionDetection Class


DetectCollisionBetweenFishAndObstacle Method

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..DetectCollisionBetweenFishAndObstacle Method
CollisionDetection Class See Also Send Feedback

Overload List

Name | Description
DetectCollisionBetweenFishAndObstacle(RoboFish%, RectangularObstacle) | 检测鱼和方形障碍物之间的碰撞情况
DetectCollisionBetweenFishAndObstacle(RoboFish%, RoundedObstacle) | 检测鱼和圆形障碍物之间的碰撞情况

See Also

CollisionDetection Class
CollisionDetection Members


DetectCollisionBetweenFishAndObstacle Method (RoboFish, RectangularObstacle)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..DetectCollisionBetweenFishAndObstacle Method (RoboFish%, RectangularObstacle)
CollisionDetection Class See Also Send Feedback
检测鱼和方形障碍物之间的碰撞情况

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static CollisionDetectionResult DetectCollisionBetweenFishAndObstacle(
    ref RoboFish fish,
    RectangularObstacle rectangularObstacle
)
Visual Basic
Public Shared Function DetectCollisionBetweenFishAndObstacle ( _
    ByRef fish As RoboFish, _
    rectangularObstacle As RectangularObstacle _
) As CollisionDetectionResult
Visual C++
public:
static CollisionDetectionResult DetectCollisionBetweenFishAndObstacle(
    RoboFish^% fish,
    RectangularObstacle^ rectangularObstacle
)

Parameters

fish
Type: URWPGSim2D.Common..::..RoboFish %
待测鱼的模型对象
rectangularObstacle
Type: URWPGSim2D.Common..::..RectangularObstacle
待测方形障碍物的模型对象

Return Value

返回碰撞检测结果结构体

See Also

CollisionDetection Class
DetectCollisionBetweenFishAndObstacle Overload


DetectCollisionBetweenFishAndObstacle Method (RoboFish, RoundedObstacle)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..DetectCollisionBetweenFishAndObstacle Method (RoboFish%, RoundedObstacle)
CollisionDetection Class See Also Send Feedback
检测鱼和圆形障碍物之间的碰撞情况

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static CollisionDetectionResult DetectCollisionBetweenFishAndObstacle(
    ref RoboFish fish,
    RoundedObstacle roundedObstacle
)
Visual Basic
Public Shared Function DetectCollisionBetweenFishAndObstacle ( _
    ByRef fish As RoboFish, _
    roundedObstacle As RoundedObstacle _
) As CollisionDetectionResult
Visual C++
public:
static CollisionDetectionResult DetectCollisionBetweenFishAndObstacle(
    RoboFish^% fish,
    RoundedObstacle^ roundedObstacle
)

Parameters

fish
Type: URWPGSim2D.Common..::..RoboFish %
待测鱼的模型对象
roundedObstacle
Type: URWPGSim2D.Common..::..RoundedObstacle
待测圆形障碍物的模型对象

Return Value

返回碰撞检测结果结构体

See Also

CollisionDetection Class
DetectCollisionBetweenFishAndObstacle Overload


DetectCollisionBetweenTwoBalls Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..DetectCollisionBetweenTwoBalls Method
CollisionDetection Class See Also Send Feedback
检测两球之间的碰撞情况

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static CollisionDetectionResult DetectCollisionBetweenTwoBalls(
    ref Ball ballA,
    ref Ball ballB
)
Visual Basic
Public Shared Function DetectCollisionBetweenTwoBalls ( _
    ByRef ballA As Ball, _
    ByRef ballB As Ball _
) As CollisionDetectionResult
Visual C++
public:
static CollisionDetectionResult DetectCollisionBetweenTwoBalls(
    Ball^% ballA,
    Ball^% ballB
)

Parameters

ballA
Type: URWPGSim2D.Common..::..Ball %
待测第一个球的模型对象
ballB
Type: URWPGSim2D.Common..::..Ball %
待测第二个球的模型对象

Return Value

返回碰撞检测结果结构体

See Also

CollisionDetection Class


DetectCollisionBetweenTwoFishes Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetection..::..DetectCollisionBetweenTwoFishes Method
CollisionDetection Class See Also Send Feedback
检测两条仿真机器鱼之间碰撞情况

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static CollisionDetectionResult DetectCollisionBetweenTwoFishes(
    ref RoboFish fish1,
    ref RoboFish fish2
)
Visual Basic
Public Shared Function DetectCollisionBetweenTwoFishes ( _
    ByRef fish1 As RoboFish, _
    ByRef fish2 As RoboFish _
) As CollisionDetectionResult
Visual C++
public:
static CollisionDetectionResult DetectCollisionBetweenTwoFishes(
    RoboFish^% fish1,
    RoboFish^% fish2
)

Parameters

fish1
Type: URWPGSim2D.Common..::..RoboFish %
待检测的第1条仿真机器鱼对象引用
fish2
Type: URWPGSim2D.Common..::..RoboFish %
待检测的第2条仿真机器鱼对象引用

Return Value

碰撞检测结果参数结构体包括是否碰撞/碰撞作用面中的法向/碰撞作用点坐标

See Also

CollisionDetection Class


CollisionDetectionResult Structure

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetectionResult Structure
Members See Also Send Feedback
碰撞检测结果参数结构体

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public struct CollisionDetectionResult
Visual Basic
Public Structure CollisionDetectionResult
Visual C++
public value class CollisionDetectionResult

See Also

CollisionDetectionResult Members


CollisionDetectionResult Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetectionResult Members
CollisionDetectionResult Structure Methods Fields See Also Send Feedback

The CollisionDetectionResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | ActionPoint | 碰撞作用点
Public field | Intersect | 定义两多边形是否相交
Public field | MinimumTranslationVector | 两相撞物体，重叠的矢量
Public field | NormalAxis | 碰撞作用面中的法线方向

See Also

CollisionDetectionResult Structure


CollisionDetectionResult Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetectionResult Fields
CollisionDetectionResult Structure See Also Send Feedback

The CollisionDetectionResult type exposes the following members.

Fields

 | Name | Description
Public field | ActionPoint | 碰撞作用点
Public field | Intersect | 定义两多边形是否相交
Public field | MinimumTranslationVector | 两相撞物体，重叠的矢量
Public field | NormalAxis | 碰撞作用面中的法线方向

See Also

CollisionDetectionResult Structure


ActionPoint Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetectionResult..::..ActionPoint Field
CollisionDetectionResult Structure See Also Send Feedback
碰撞作用点

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 ActionPoint
Visual Basic
Public ActionPoint As Vector3
Visual C++
public:
Vector3 ActionPoint

See Also

CollisionDetectionResult Structure


Intersect Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetectionResult..::..Intersect Field
CollisionDetectionResult Structure See Also Send Feedback
定义两多边形是否相交

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public bool Intersect
Visual Basic
Public Intersect As Boolean
Visual C++
public:
bool Intersect

See Also

CollisionDetectionResult Structure


MinimumTranslationVector Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetectionResult..::..MinimumTranslationVector Field
CollisionDetectionResult Structure See Also Send Feedback
两相撞物体，重叠的矢量

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 MinimumTranslationVector
Visual Basic
Public MinimumTranslationVector As Vector3
Visual C++
public:
Vector3 MinimumTranslationVector

See Also

CollisionDetectionResult Structure


NormalAxis Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetectionResult..::..NormalAxis Field
CollisionDetectionResult Structure See Also Send Feedback
碰撞作用面中的法线方向

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 NormalAxis
Visual Basic
Public NormalAxis As Vector3
Visual C++
public:
Vector3 NormalAxis

See Also

CollisionDetectionResult Structure


CollisionDetectionResult Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionDetectionResult Methods
CollisionDetectionResult Structure See Also Send Feedback

The CollisionDetectionResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

CollisionDetectionResult Structure


CollisionModelPolygon Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionModelPolygon Class
Members See Also Send Feedback
碰撞检测多边形模型类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public class CollisionModelPolygon
Visual Basic
Public Class CollisionModelPolygon
Visual C++
public ref class CollisionModelPolygon

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..CollisionModelPolygon

See Also

CollisionModelPolygon Members


CollisionModelPolygon Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionModelPolygon Members
CollisionModelPolygon Class Constructors Methods Properties See Also Send Feedback

The CollisionModelPolygon type exposes the following members.

Constructors

 | Name | Description
Public method | CollisionModelPolygon | 带参数构造函数

Methods

 | Name | Description
Public method | BuildEdges | 根据多边形的顶点列表建立边向量列表
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Offset(Vector3) | 将当前对象代表的多边形模型平移一个xna.Vector3类型的向量三个分量距离（可正可负）
Public method | Offset(Single, Single, Single) | 将当前对象代表的多边形模型在X/Y/Z方向分别平移x/y/z距离（可正可负）
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Center | 多边形的质心
Public property | Edges | 多边形的边向量列表
Public property | Points | 多边形的顶点列表

See Also

CollisionModelPolygon Class


CollisionModelPolygon Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionModelPolygon Constructor
CollisionModelPolygon Class See Also Send Feedback
带参数构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public CollisionModelPolygon(
    List<Vector3> vertices
)
Visual Basic
Public Sub New ( _
    vertices As List(Of Vector3) _
)
Visual C++
public:
CollisionModelPolygon(
    List<Vector3>^ vertices
)

Parameters

vertices
Type: System.Collections.Generic..::..List <(Of <(<'Vector3>)>)>
多边形模型顶点列表，顶点为xna.Vector3类型

See Also

CollisionModelPolygon Class


CollisionModelPolygon Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionModelPolygon Methods
CollisionModelPolygon Class See Also Send Feedback

The CollisionModelPolygon type exposes the following members.

Methods

 | Name | Description
Public method | BuildEdges | 根据多边形的顶点列表建立边向量列表
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Offset(Vector3) | 将当前对象代表的多边形模型平移一个xna.Vector3类型的向量三个分量距离（可正可负）
Public method | Offset(Single, Single, Single) | 将当前对象代表的多边形模型在X/Y/Z方向分别平移x/y/z距离（可正可负）
Public method | ToString | (Inherited from Object.)

See Also

CollisionModelPolygon Class


BuildEdges Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionModelPolygon..::..BuildEdges Method
CollisionModelPolygon Class See Also Send Feedback
根据多边形的顶点列表建立边向量列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void BuildEdges()
Visual Basic
Public Sub BuildEdges
Visual C++
public:
void BuildEdges()

See Also

CollisionModelPolygon Class


Offset Method

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionModelPolygon..::..Offset Method
CollisionModelPolygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Offset(Vector3) | 将当前对象代表的多边形模型平移一个xna.Vector3类型的向量三个分量距离（可正可负）
Public method | Offset(Single, Single, Single) | 将当前对象代表的多边形模型在X/Y/Z方向分别平移x/y/z距离（可正可负）

See Also

CollisionModelPolygon Class
CollisionModelPolygon Members


Offset Method ()

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionModelPolygon..::..Offset Method ()
CollisionModelPolygon Class See Also Send Feedback
将当前对象代表的多边形模型平移一个xna.Vector3类型的向量三个分量距离（可正可负）

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void Offset(
    Vector3 v
)
Visual Basic
Public Sub Offset ( _
    v As Vector3 _
)
Visual C++
public:
void Offset(
    Vector3 v
)

Parameters

v
Type: Vector3

[Missing <param name="v"/> documentation for "M:URWPGSim2D.Common.CollisionModelPolygon.Offset(Microsoft.Xna.Framework.Vector3)"]

See Also

CollisionModelPolygon Class
Offset Overload


Offset Method (Single, Single, Single)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionModelPolygon..::..Offset Method (Single, Single, Single)
CollisionModelPolygon Class See Also Send Feedback
将当前对象代表的多边形模型在X/Y/Z方向分别平移x/y/z距离（可正可负）

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void Offset(
    float x,
    float y,
    float z
)
Visual Basic
Public Sub Offset ( _
    x As Single, _
    y As Single, _
    z As Single _
)
Visual C++
public:
void Offset(
    float x,
    float y,
    float z
)

Parameters

x
Type: System..::..Single
X方向平移的距离（可正可负）
y
Type: System..::..Single
Y方向平移的距离（可正可负）
z
Type: System..::..Single
Z方向平移的距离（可正可负）

See Also

CollisionModelPolygon Class
Offset Overload


CollisionModelPolygon Properties

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionModelPolygon Properties
CollisionModelPolygon Class See Also Send Feedback

The CollisionModelPolygon type exposes the following members.

Properties

 | Name | Description
Public property | Center | 多边形的质心
Public property | Edges | 多边形的边向量列表
Public property | Points | 多边形的顶点列表

See Also

CollisionModelPolygon Class


Center Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionModelPolygon..::..Center Property
CollisionModelPolygon Class See Also Send Feedback
多边形的质心

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 Center { get; }
Visual Basic
Public ReadOnly Property Center As Vector3
    Get
Visual C++
public:
property Vector3 Center {
    Vector3 get ();
}

See Also

CollisionModelPolygon Class


Edges Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionModelPolygon..::..Edges Property
CollisionModelPolygon Class See Also Send Feedback
多边形的边向量列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> Edges { get; }
Visual Basic
Public ReadOnly Property Edges As List(Of Vector3)
    Get
Visual C++
public:
property List<Vector3>^ Edges {
    List<Vector3>^ get ();
}

See Also

CollisionModelPolygon Class


Points Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionModelPolygon..::..Points Property
CollisionModelPolygon Class See Also Send Feedback
多边形的顶点列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> Points { get; }
Visual Basic
Public ReadOnly Property Points As List(Of Vector3)
    Get
Visual C++
public:
property List<Vector3>^ Points {
    List<Vector3>^ get ();
}

See Also

CollisionModelPolygon Class


CollisionType Enumeration

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
CollisionType Enumeration
See Also Send Feedback
仿真进程中可能发生的对象间碰撞类型枚举

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public enum CollisionType
Visual Basic
Public Enumeration CollisionType
Visual C++
public enum class CollisionType

Members

Member name | Value | Description
NONE | 0 | 无碰撞
FISH_FISH | 1 | 仿真机器鱼之间碰撞
FISH_BALL | 2 | 仿真机器鱼和仿真水球碰撞
FISH_POOL | 3 | 仿真机器鱼和仿真水池池壁碰撞
FISH_OBSTACLE | 4 | 仿真机器鱼和仿真静态障碍物碰撞
FISH_CHANNEL | 5 | 仿真机器鱼和仿真通道碰撞
BALL_POOL | 6 | 仿真水球和仿真水池池壁碰撞
BALL_OBSTACLE | 7 | 仿真水球和仿真静态障碍物碰撞
BALL_CHANNEL | 8 | 仿真水球和仿真通道碰撞

See Also

URWPGSim2D.Common Namespace

有关这个主题的评论请发邮件到 bug report

Copyright @ PKU&HNIU


Decision Structure

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Decision Structure
Members See Also Send Feedback
仿真机器鱼运动决策数据结构体

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public struct Decision
Visual Basic
<SerializableAttribute> _
Public Structure Decision
Visual C++
[SerializableAttribute]
public value class Decision

See Also

Decision Members


Decision Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Decision Members
Decision Structure Methods Fields See Also Send Feedback

The Decision type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | TCode | 决策结果的转弯档位，取值范围{0,1,...,15}，0左转最急，7直游，15右转最急
Public field | VCode | 决策结果的速度档位，取值范围{0,1,...,15}，0最慢，15最快

See Also

Decision Structure


Decision Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Decision Fields
Decision Structure See Also Send Feedback

The Decision type exposes the following members.

Fields

 | Name | Description
Public field | TCode | 决策结果的转弯档位，取值范围{0,1,...,15}，0左转最急，7直游，15右转最急
Public field | VCode | 决策结果的速度档位，取值范围{0,1,...,15}，0最慢，15最快

See Also

Decision Structure


TCode Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Decision..::..TCode Field
Decision Structure See Also Send Feedback
决策结果的转弯档位，取值范围{0,1,...,15}，0左转最急，7直游，15右转最急

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int TCode
Visual Basic
Public TCode As Integer
Visual C++
public:
int TCode

See Also

Decision Structure


VCode Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Decision..::..VCode Field
Decision Structure See Also Send Feedback
决策结果的速度档位，取值范围{0,1,...,15}，0最慢，15最快

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int VCode
Visual Basic
Public VCode As Integer
Visual C++
public:
int VCode

See Also

Decision Structure


Decision Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Decision Methods
Decision Structure See Also Send Feedback

The Decision type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

Decision Structure


DrawHelper Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
DrawHelper Class
Members See Also Send Feedback
仿真场地中圆形和方形对象绘制静态类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static class DrawHelper
Visual Basic
Public NotInheritable Class DrawHelper
Visual C++
public ref class DrawHelper abstract sealed

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..DrawHelper

See Also

DrawHelper Members


DrawHelper Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
DrawHelper Members
DrawHelper Class Methods See Also Send Feedback

The DrawHelper type exposes the following members.

Methods

Name | Description
DrawEllipse | 绘制仿真场地中圆形对象到GDI+绘图对象上
DrawRectangle | 绘制仿真场地中方形对象到GDI+绘图对象上

See Also

DrawHelper Class


DrawHelper Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
DrawHelper Methods
DrawHelper Class See Also Send Feedback

The DrawHelper type exposes the following members.

Methods

Name | Description
DrawEllipse | 绘制仿真场地中圆形对象到GDI+绘图对象上
DrawRectangle | 绘制仿真场地中方形对象到GDI+绘图对象上

See Also

DrawHelper Class


DrawEllipse Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
DrawHelper..::..DrawEllipse Method
DrawHelper Class See Also Send Feedback
绘制仿真场地中圆形对象到GDI+绘图对象上

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static void DrawEllipse(
    ref Graphics g,
    Vector3 positionMm,
    int radiusMm,
    int borderWithPix,
    Color colorBorder,
    Color colorFilled
)
Visual Basic
Public Shared Sub DrawEllipse ( _
    ByRef g As Graphics, _
    positionMm As Vector3, _
    radiusMm As Integer, _
    borderWithPix As Integer, _
    colorBorder As Color, _
    colorFilled As Color _
)
Visual C++
public:
static void DrawEllipse(
    Graphics^% g,
    Vector3 positionMm,
    int radiusMm,
    int borderWithPix,
    Color colorBorder,
    Color colorFilled
)

Parameters

g
Type: System.Drawing..::..Graphics %
来自与绘图容器PictureBox等尺寸的Bitmap的GDI+绘图对象
positionMm
Type: Vector3
待绘制对象中心点在场地坐标系中的坐标，各维单位毫米
radiusMm
Type: System..::..Int32
待绘制对象半径，单位毫米
borderWithPix
Type: System..::..Int32
待绘制对象边框宽度，单位像素
colorBorder
Type: System.Drawing..::..Color
待绘制对象边框颜色
colorFilled
Type: System.Drawing..::..Color
待绘制对象填充颜色

See Also

DrawHelper Class


DrawRectangle Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
DrawHelper..::..DrawRectangle Method
DrawHelper Class See Also Send Feedback
绘制仿真场地中方形对象到GDI+绘图对象上

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static void DrawRectangle(
    ref Graphics g,
    Vector3 positionMm,
    float directionRad,
    int lengthMm,
    int widthMm,
    int borderWithPix,
    Color colorBorder,
    Color colorFilled
)
Visual Basic
Public Shared Sub DrawRectangle ( _
    ByRef g As Graphics, _
    positionMm As Vector3, _
    directionRad As Single, _
    lengthMm As Integer, _
    widthMm As Integer, _
    borderWithPix As Integer, _
    colorBorder As Color, _
    colorFilled As Color _
)
Visual C++
public:
static void DrawRectangle(
    Graphics^% g,
    Vector3 positionMm,
    float directionRad,
    int lengthMm,
    int widthMm,
    int borderWithPix,
    Color colorBorder,
    Color colorFilled
)

Parameters

g
Type: System.Drawing..::..Graphics %
来自与绘图容器PictureBox等尺寸的Bitmap的GDI+绘图对象
positionMm
Type: Vector3
待绘制对象中心点在场地坐标系中的坐标，各维单位毫米
directionRad
Type: System..::..Single
待绘制对象长度方向，单位弧度
lengthMm
Type: System..::..Int32
待绘制对象长度，单位毫米
widthMm
Type: System..::..Int32
待绘制对象宽度，单位毫米
borderWithPix
Type: System..::..Int32
待绘制对象边框宽度，单位像素
colorBorder
Type: System.Drawing..::..Color
待绘制对象边框颜色
colorFilled
Type: System.Drawing..::..Color
待绘制对象填充颜色

See Also

DrawHelper Class


Field Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field Class
Members See Also Send Feedback
仿真比赛场地数据类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class Field
Visual Basic
<SerializableAttribute> _
Public Class Field
Visual C++
[SerializableAttribute]
public ref class Field

Remarks

无get和set以外实现逻辑的数据成员可使用自动实现的属性， 需要在Dss Service之间传递的属性均置以Attribute[DataMember]

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..Field

See Also

Field Members


Field Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field Members
Field Class Methods Fields Properties See Also Send Feedback

The Field type exposes the following members.

Methods

 | Name | Description
Public method | Draw | 将仿真比赛场地绘制到Bitmap对象上并返回该对象
Public method | DrawGoal | 绘制球门块 weiqingdan 20101116
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Instance | 创建或获取该类的唯一实例
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MmToPix(Vector3) | 将以毫米为单位的三维矢量转换成绘图容器PictureBox中以像素为单位的三维矢量，Y值置为0
Public method | MmToPix(Point) | 将以毫米为单位的二维点转换成绘图容器PictureBox中以像素为单位的二维点
Public method | MmToPix(Rectangle) | 将以毫米为坐标单位的矩形对象转换成绘图容器PictureBox中以像素为坐标单位的矩形对象
Public method | MmToPix(Int32, Int32, Int32, Int32) | 使用以毫米为单位的左上角坐标和宽度高度值生成绘图容器PictureBox中以像素为单位的矩形对象
Public method | MmToPixX | 将X方向毫米数转换成绘图容器PictureBox中像素数
Public method | MmToPixZ | 将Z方向毫米数转换成绘图容器PictureBox中像素数
Public method | PixToMm(Vector3) | 点在场地绘图对象PictureBox坐标系中以像素为单位的坐标转换成实际场地坐标系中以毫米为单位的坐标
Public method | PixToMm(Point) | 点在场地绘图对象PictureBox坐标系中以像素为单位的坐标转换成实际场地坐标系中以毫米为单位的坐标
Public method | SetField | 从配置文件中读取可配置参数并计算出需要计算的参数
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | BorderLeftBottomVertices | 边界左下角球门块的碰撞检测多边形顶点列表
Public field | BorderLeftTopVertices | 边界左上角球门块的碰撞检测多边形顶点列表
Public field | BorderRightBottomVertices | 边界右下角球门块的碰撞检测多边形顶点列表
Public field | BorderRightTopVertices | 边界右上角球门块的碰撞检测多边形顶点列表
Public field | IsGoalBlockRegular | 球门块是否规则地摆放在仿真场地四个角上

Properties

 | Name | Description
Public property | BottomMm | 矩形场地中心为原点，右为正X，下为正Z的坐标系中场地下边界Y坐标值，单位毫米
Public property | CenterCircleRadiusMm | 中心圆的实际半径（**配置**），单位毫米
Public property | CenterCircleRadiusPix | 中心圆的屏幕半径（**待求**），单位像素
Public property | FieldCenterXPix | 比赛场地中心点在绘图容器PictureBox中的X方向屏幕坐标（**待求**），单位像素
Public property | FieldCenterZPix | 比赛场地中心点在绘图容器PictureBox中的Z方向屏幕坐标（**待求**），单位像素
Public property | FieldInnerBorderPix | 比赛场地内边界的屏幕宽度（**配置**），单位像素
Public property | FieldLengthXMm | 比赛场地X方向上的实际长度（**配置**），单位毫米
Public property | FieldLengthXPix | 比赛场地X方向上的屏幕长度（**待求**），单位像素
Public property | FieldLengthZMm | 比赛场地Z方向上的实际长度（**配置**），单位毫米
Public property | FieldLengthZPix | 比赛场地Z方向上的屏幕长度（**待求**），单位像素
Public property | FieldOuterBorderPix | 比赛场地外边界的屏幕宽度（**配置**），单位像素
Public property | ForbiddenZoneLengthXMm | 禁区X方向的实际长度（**配置**），单位毫米
Public property | ForbiddenZoneLengthXPix | 禁区X方向的屏幕长度（**待求**），单位像素
Public property | ForbiddenZoneLengthZMm | 禁区Z方向的实际长度（**配置**），单位毫米
Public property | ForbiddenZoneLengthZPix | 禁区Z方向的屏幕长度（**待求**），单位像素
Public property | FormLengthXPix | 窗体X方向上的屏幕宽度（**待求**），单位像素
Public property | FormLengthZPix | 窗体Z方向上的屏幕宽度（**待求**），单位像素
Public property | FormPaddingPix | 窗体内边距的屏幕宽度（**配置**），单位像素
Public property | GoalBlockDepthPix | 球门块短边（沿X方向）的屏幕长度（**待求**），单位像素
Public property | GoalBlockWidthPix | 球门块长边（沿Z方向）的屏幕长度（**待求**），单位像素
Public property | GoalDepthMm | 球门短边（正置沿X方向）的实际长度（**配置**），单位毫米
Public property | GoalDepthPix | 球门短边（沿X方向）的屏幕长度（**待求**），单位像素
Public property | GoalWidthMm | 球门长边（正置沿Z方向）的实际长度（**配置**），单位毫米
Public property | GoalWidthPix | 球门长边（沿Z方向）的屏幕长度（**待求**），单位像素
Public property | LeftMm | 矩形场地中心为原点，右为正X，下为正Z的坐标系中场地左边界X坐标值，单位毫米
Public property | PictureBoxXPix | 图片箱X方向上的屏幕宽度（**待求**），单位像素
Public property | PictureBoxZPix | 图片箱Z方向上的屏幕宽度（**待求**），单位像素
Public property | RightMm | 矩形场地中心为原点，右为正X，下为正Z的坐标系中场地右边界X坐标值，单位毫米
Public property | ScaleMmToPix | 毫米向像素转化的比例因子（**待求**），单位毫米每像素
Public property | ScaleMmToPixX | X方向毫米向像素转化的比例因子（**待求**），单位毫米每像素
Public property | ScaleMmToPixZ | Z方向毫米向像素转化的比例因子（**待求**），单位毫米每像素
Public property | SpanBetweenFieldAndTabControlPix | 比赛场地和选项卡控件之间空隙的屏幕宽度（**配置**），单位像素
Public property | TabControlLengthXPix | 选项卡控件X方向上的屏幕长度（**配置**），单位像素
Public property | TabControlLengthZPix | 选项卡控件Z方向上的屏幕长度（**配置**），单位像素
Public property | TopMm | 矩形场地中心为原点，右为正X，下为正Z的坐标系中场地上边界Y坐标值，单位毫米

See Also

Field Class


Field Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field Fields
Field Class See Also Send Feedback

The Field type exposes the following members.

Fields

 | Name | Description
Public field | BorderLeftBottomVertices | 边界左下角球门块的碰撞检测多边形顶点列表
Public field | BorderLeftTopVertices | 边界左上角球门块的碰撞检测多边形顶点列表
Public field | BorderRightBottomVertices | 边界右下角球门块的碰撞检测多边形顶点列表
Public field | BorderRightTopVertices | 边界右上角球门块的碰撞检测多边形顶点列表
Public field | IsGoalBlockRegular | 球门块是否规则地摆放在仿真场地四个角上

See Also

Field Class


BorderLeftBottomVertices Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..BorderLeftBottomVertices Field
Field Class See Also Send Feedback
边界左下角球门块的碰撞检测多边形顶点列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> BorderLeftBottomVertices
Visual Basic
Public BorderLeftBottomVertices As List(Of Vector3)
Visual C++
public:
List<Vector3>^ BorderLeftBottomVertices

See Also

Field Class


BorderLeftTopVertices Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..BorderLeftTopVertices Field
Field Class See Also Send Feedback
边界左上角球门块的碰撞检测多边形顶点列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> BorderLeftTopVertices
Visual Basic
Public BorderLeftTopVertices As List(Of Vector3)
Visual C++
public:
List<Vector3>^ BorderLeftTopVertices

See Also

Field Class


BorderRightBottomVertices Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..BorderRightBottomVertices Field
Field Class See Also Send Feedback
边界右下角球门块的碰撞检测多边形顶点列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> BorderRightBottomVertices
Visual Basic
Public BorderRightBottomVertices As List(Of Vector3)
Visual C++
public:
List<Vector3>^ BorderRightBottomVertices

See Also

Field Class


BorderRightTopVertices Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..BorderRightTopVertices Field
Field Class See Also Send Feedback
边界右上角球门块的碰撞检测多边形顶点列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> BorderRightTopVertices
Visual Basic
Public BorderRightTopVertices As List(Of Vector3)
Visual C++
public:
List<Vector3>^ BorderRightTopVertices

See Also

Field Class


IsGoalBlockRegular Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..IsGoalBlockRegular Field
Field Class See Also Send Feedback
球门块是否规则地摆放在仿真场地四个角上

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public bool IsGoalBlockRegular
Visual Basic
Public IsGoalBlockRegular As Boolean
Visual C++
public:
bool IsGoalBlockRegular

See Also

Field Class


Field Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field Methods
Field Class See Also Send Feedback

The Field type exposes the following members.

Methods

 | Name | Description
Public method | Draw | 将仿真比赛场地绘制到Bitmap对象上并返回该对象
Public method | DrawGoal | 绘制球门块 weiqingdan 20101116
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Instance | 创建或获取该类的唯一实例
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MmToPix(Vector3) | 将以毫米为单位的三维矢量转换成绘图容器PictureBox中以像素为单位的三维矢量，Y值置为0
Public method | MmToPix(Point) | 将以毫米为单位的二维点转换成绘图容器PictureBox中以像素为单位的二维点
Public method | MmToPix(Rectangle) | 将以毫米为坐标单位的矩形对象转换成绘图容器PictureBox中以像素为坐标单位的矩形对象
Public method | MmToPix(Int32, Int32, Int32, Int32) | 使用以毫米为单位的左上角坐标和宽度高度值生成绘图容器PictureBox中以像素为单位的矩形对象
Public method | MmToPixX | 将X方向毫米数转换成绘图容器PictureBox中像素数
Public method | MmToPixZ | 将Z方向毫米数转换成绘图容器PictureBox中像素数
Public method | PixToMm(Vector3) | 点在场地绘图对象PictureBox坐标系中以像素为单位的坐标转换成实际场地坐标系中以毫米为单位的坐标
Public method | PixToMm(Point) | 点在场地绘图对象PictureBox坐标系中以像素为单位的坐标转换成实际场地坐标系中以毫米为单位的坐标
Public method | SetField | 从配置文件中读取可配置参数并计算出需要计算的参数
Public method | ToString | (Inherited from Object.)

See Also

Field Class


Draw Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..Draw Method
Field Class See Also Send Feedback
将仿真比赛场地绘制到Bitmap对象上并返回该对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Bitmap Draw()
Visual Basic
Public Function Draw As Bitmap
Visual C++
public:
Bitmap^ Draw()

Return Value

绘制好比赛场地的Bitmap对象的引用

See Also

Field Class


DrawGoal Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..DrawGoal Method
Field Class See Also Send Feedback
绘制球门块 weiqingdan 20101116

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void DrawGoal(
    Graphics myGraphic,
    Point point,
    Field..::..GoalBlockType goalBlockType,
    int iThetaAngle
)
Visual Basic
Public Sub DrawGoal ( _
    myGraphic As Graphics, _
    point As Point, _
    goalBlockType As Field..::..GoalBlockType, _
    iThetaAngle As Integer _
)
Visual C++
public:
void DrawGoal(
    Graphics^ myGraphic,
    Point point,
    Field..::..GoalBlockType goalBlockType,
    int iThetaAngle
)

Parameters

myGraphic
Type: System.Drawing..::..Graphics
GDI+绘图对象
point
Type: System.Drawing..::..Point
球门块长边的起始点
goalBlockType
Type: URWPGSim2D.Common..::..Field..::..GoalBlockType
球门块的方向，用枚举类型表示
iThetaAngle
Type: System..::..Int32
球门块长边的倾斜角度

See Also

Field Class


Instance Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..Instance Method
Field Class See Also Send Feedback
创建或获取该类的唯一实例

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static Field Instance()
Visual Basic
Public Shared Function Instance As Field
Visual C++
public:
static Field^ Instance()

Return Value

[Missing <returns> documentation for "M:URWPGSim2D.Common.Field.Instance"]

See Also

Field Class


MmToPix Method

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..MmToPix Method
Field Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MmToPix(Vector3) | 将以毫米为单位的三维矢量转换成绘图容器PictureBox中以像素为单位的三维矢量，Y值置为0
Public method | MmToPix(Point) | 将以毫米为单位的二维点转换成绘图容器PictureBox中以像素为单位的二维点
Public method | MmToPix(Rectangle) | 将以毫米为坐标单位的矩形对象转换成绘图容器PictureBox中以像素为坐标单位的矩形对象
Public method | MmToPix(Int32, Int32, Int32, Int32) | 使用以毫米为单位的左上角坐标和宽度高度值生成绘图容器PictureBox中以像素为单位的矩形对象

See Also

Field Class
Field Members


MmToPix Method ()

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..MmToPix Method ()
Field Class See Also Send Feedback
将以毫米为单位的三维矢量转换成绘图容器PictureBox中以像素为单位的三维矢量，Y值置为0

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 MmToPix(
    Vector3 vector3
)
Visual Basic
Public Function MmToPix ( _
    vector3 As Vector3 _
) As Vector3
Visual C++
public:
Vector3 MmToPix(
    Vector3 vector3
)

Parameters

vector3
Type: Vector3
以毫米为单位的三维矢量

Return Value

绘图容器PictureBox中以像素为单位的三维矢量

See Also

Field Class
MmToPix Overload


MmToPix Method (Point)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..MmToPix Method (Point)
Field Class See Also Send Feedback
将以毫米为单位的二维点转换成绘图容器PictureBox中以像素为单位的二维点

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Point MmToPix(
    Point pointMm
)
Visual Basic
Public Function MmToPix ( _
    pointMm As Point _
) As Point
Visual C++
public:
Point MmToPix(
    Point pointMm
)

Parameters

pointMm
Type: System.Drawing..::..Point
以毫米为单位的二维点

Return Value

绘图容器PictureBox中以像素为单位的二维点

See Also

Field Class
MmToPix Overload


MmToPix Method (Rectangle)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..MmToPix Method (Rectangle)
Field Class See Also Send Feedback
将以毫米为坐标单位的矩形对象转换成绘图容器PictureBox中以像素为坐标单位的矩形对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Rectangle MmToPix(
    Rectangle rectMm
)
Visual Basic
Public Function MmToPix ( _
    rectMm As Rectangle _
) As Rectangle
Visual C++
public:
Rectangle MmToPix(
    Rectangle rectMm
)

Parameters

rectMm
Type: System.Drawing..::..Rectangle
以毫米为坐标单位的矩形对象

Return Value

绘图容器PictureBox中以像素为坐标单位的矩形对象

See Also

Field Class
MmToPix Overload


MmToPix Method (Int32, Int32, Int32, Int32)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..MmToPix Method (Int32, Int32, Int32, Int32)
Field Class See Also Send Feedback
使用以毫米为单位的左上角坐标和宽度高度值生成绘图容器PictureBox中以像素为单位的矩形对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Rectangle MmToPix(
    int xMm,
    int zMm,
    int widthMm,
    int heightMm
)
Visual Basic
Public Function MmToPix ( _
    xMm As Integer, _
    zMm As Integer, _
    widthMm As Integer, _
    heightMm As Integer _
) As Rectangle
Visual C++
public:
Rectangle MmToPix(
    int xMm,
    int zMm,
    int widthMm,
    int heightMm
)

Parameters

xMm
Type: System..::..Int32
矩形左上角X坐标以毫米为单位的值
zMm
Type: System..::..Int32
矩形左上角Z坐标以毫米为单位的值
widthMm
Type: System..::..Int32
矩形宽度以毫米为单位的值
heightMm
Type: System..::..Int32
矩形高度以毫米为单位的值

Return Value

绘图容器PictureBox中以像素为单位的矩形对象

See Also

Field Class
MmToPix Overload


MmToPixX Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..MmToPixX Method
Field Class See Also Send Feedback
将X方向毫米数转换成绘图容器PictureBox中像素数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int MmToPixX(
    int mm
)
Visual Basic
Public Function MmToPixX ( _
    mm As Integer _
) As Integer
Visual C++
public:
int MmToPixX(
    int mm
)

Parameters

mm
Type: System..::..Int32
X方向毫米数

Return Value

X方向在绘图容器PictureBox中像素数

See Also

Field Class


MmToPixZ Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..MmToPixZ Method
Field Class See Also Send Feedback
将Z方向毫米数转换成绘图容器PictureBox中像素数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int MmToPixZ(
    int mm
)
Visual Basic
Public Function MmToPixZ ( _
    mm As Integer _
) As Integer
Visual C++
public:
int MmToPixZ(
    int mm
)

Parameters

mm
Type: System..::..Int32
Z方向毫米数

Return Value

Z方向在绘图容器PictureBox中像素数

See Also

Field Class


PixToMm Method

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..PixToMm Method
Field Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PixToMm(Vector3) | 点在场地绘图对象PictureBox坐标系中以像素为单位的坐标转换成实际场地坐标系中以毫米为单位的坐标
Public method | PixToMm(Point) | 点在场地绘图对象PictureBox坐标系中以像素为单位的坐标转换成实际场地坐标系中以毫米为单位的坐标

See Also

Field Class
Field Members


PixToMm Method ()

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..PixToMm Method ()
Field Class See Also Send Feedback
点在场地绘图对象PictureBox坐标系中以像素为单位的坐标转换成实际场地坐标系中以毫米为单位的坐标

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 PixToMm(
    Vector3 vector3Pix
)
Visual Basic
Public Function PixToMm ( _
    vector3Pix As Vector3 _
) As Vector3
Visual C++
public:
Vector3 PixToMm(
    Vector3 vector3Pix
)

Parameters

vector3Pix
Type: Vector3
点在场地绘图对象PictureBox坐标系中以像素为单位的三维坐标值

Return Value

点在实际场地坐标系中以毫米为单位的三维坐标值

See Also

Field Class
PixToMm Overload


PixToMm Method (Point)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..PixToMm Method (Point)
Field Class See Also Send Feedback
点在场地绘图对象PictureBox坐标系中以像素为单位的坐标转换成实际场地坐标系中以毫米为单位的坐标

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Point PixToMm(
    Point pointPix
)
Visual Basic
Public Function PixToMm ( _
    pointPix As Point _
) As Point
Visual C++
public:
Point PixToMm(
    Point pointPix
)

Parameters

pointPix
Type: System.Drawing..::..Point
点在场地绘图对象PictureBox坐标系中以像素为单位的坐标值

Return Value

点在实际场地坐标系中以毫米为单位的坐标值

See Also

Field Class
PixToMm Overload


SetField Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..SetField Method
Field Class See Also Send Feedback
从配置文件中读取可配置参数并计算出需要计算的参数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void SetField()
Visual Basic
Public Sub SetField
Visual C++
public:
void SetField()

See Also

Field Class


Field Properties

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field Properties
Field Class See Also Send Feedback

The Field type exposes the following members.

Properties

 | Name | Description
Public property | BottomMm | 矩形场地中心为原点，右为正X，下为正Z的坐标系中场地下边界Y坐标值，单位毫米
Public property | CenterCircleRadiusMm | 中心圆的实际半径（**配置**），单位毫米
Public property | CenterCircleRadiusPix | 中心圆的屏幕半径（**待求**），单位像素
Public property | FieldCenterXPix | 比赛场地中心点在绘图容器PictureBox中的X方向屏幕坐标（**待求**），单位像素
Public property | FieldCenterZPix | 比赛场地中心点在绘图容器PictureBox中的Z方向屏幕坐标（**待求**），单位像素
Public property | FieldInnerBorderPix | 比赛场地内边界的屏幕宽度（**配置**），单位像素
Public property | FieldLengthXMm | 比赛场地X方向上的实际长度（**配置**），单位毫米
Public property | FieldLengthXPix | 比赛场地X方向上的屏幕长度（**待求**），单位像素
Public property | FieldLengthZMm | 比赛场地Z方向上的实际长度（**配置**），单位毫米
Public property | FieldLengthZPix | 比赛场地Z方向上的屏幕长度（**待求**），单位像素
Public property | FieldOuterBorderPix | 比赛场地外边界的屏幕宽度（**配置**），单位像素
Public property | ForbiddenZoneLengthXMm | 禁区X方向的实际长度（**配置**），单位毫米
Public property | ForbiddenZoneLengthXPix | 禁区X方向的屏幕长度（**待求**），单位像素
Public property | ForbiddenZoneLengthZMm | 禁区Z方向的实际长度（**配置**），单位毫米
Public property | ForbiddenZoneLengthZPix | 禁区Z方向的屏幕长度（**待求**），单位像素
Public property | FormLengthXPix | 窗体X方向上的屏幕宽度（**待求**），单位像素
Public property | FormLengthZPix | 窗体Z方向上的屏幕宽度（**待求**），单位像素
Public property | FormPaddingPix | 窗体内边距的屏幕宽度（**配置**），单位像素
Public property | GoalBlockDepthPix | 球门块短边（沿X方向）的屏幕长度（**待求**），单位像素
Public property | GoalBlockWidthPix | 球门块长边（沿Z方向）的屏幕长度（**待求**），单位像素
Public property | GoalDepthMm | 球门短边（正置沿X方向）的实际长度（**配置**），单位毫米
Public property | GoalDepthPix | 球门短边（沿X方向）的屏幕长度（**待求**），单位像素
Public property | GoalWidthMm | 球门长边（正置沿Z方向）的实际长度（**配置**），单位毫米
Public property | GoalWidthPix | 球门长边（沿Z方向）的屏幕长度（**待求**），单位像素
Public property | LeftMm | 矩形场地中心为原点，右为正X，下为正Z的坐标系中场地左边界X坐标值，单位毫米
Public property | PictureBoxXPix | 图片箱X方向上的屏幕宽度（**待求**），单位像素
Public property | PictureBoxZPix | 图片箱Z方向上的屏幕宽度（**待求**），单位像素
Public property | RightMm | 矩形场地中心为原点，右为正X，下为正Z的坐标系中场地右边界X坐标值，单位毫米
Public property | ScaleMmToPix | 毫米向像素转化的比例因子（**待求**），单位毫米每像素
Public property | ScaleMmToPixX | X方向毫米向像素转化的比例因子（**待求**），单位毫米每像素
Public property | ScaleMmToPixZ | Z方向毫米向像素转化的比例因子（**待求**），单位毫米每像素
Public property | SpanBetweenFieldAndTabControlPix | 比赛场地和选项卡控件之间空隙的屏幕宽度（**配置**），单位像素
Public property | TabControlLengthXPix | 选项卡控件X方向上的屏幕长度（**配置**），单位像素
Public property | TabControlLengthZPix | 选项卡控件Z方向上的屏幕长度（**配置**），单位像素
Public property | TopMm | 矩形场地中心为原点，右为正X，下为正Z的坐标系中场地上边界Y坐标值，单位毫米

See Also

Field Class


BottomMm Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..BottomMm Property
Field Class See Also Send Feedback
矩形场地中心为原点，右为正X，下为正Z的坐标系中场地下边界Y坐标值，单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int BottomMm { get; set; }
Visual Basic
Public Property BottomMm As Integer
    Get
    Set
Visual C++
public:
property int BottomMm {
    int get ();
    void set (int value);
}

See Also

Field Class


CenterCircleRadiusMm Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..CenterCircleRadiusMm Property
Field Class See Also Send Feedback
中心圆的实际半径（**配置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int CenterCircleRadiusMm { get; set; }
Visual Basic
Public Property CenterCircleRadiusMm As Integer
    Get
    Set
Visual C++
public:
property int CenterCircleRadiusMm {
    int get ();
    void set (int value);
}

See Also

Field Class


CenterCircleRadiusPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..CenterCircleRadiusPix Property
Field Class See Also Send Feedback
中心圆的屏幕半径（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int CenterCircleRadiusPix { get; set; }
Visual Basic
Public Property CenterCircleRadiusPix As Integer
    Get
    Set
Visual C++
public:
property int CenterCircleRadiusPix {
    int get ();
    void set (int value);
}

See Also

Field Class


FieldCenterXPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..FieldCenterXPix Property
Field Class See Also Send Feedback
比赛场地中心点在绘图容器PictureBox中的X方向屏幕坐标（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FieldCenterXPix { get; set; }
Visual Basic
Public Property FieldCenterXPix As Integer
    Get
    Set
Visual C++
public:
property int FieldCenterXPix {
    int get ();
    void set (int value);
}

See Also

Field Class


FieldCenterZPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..FieldCenterZPix Property
Field Class See Also Send Feedback
比赛场地中心点在绘图容器PictureBox中的Z方向屏幕坐标（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FieldCenterZPix { get; set; }
Visual Basic
Public Property FieldCenterZPix As Integer
    Get
    Set
Visual C++
public:
property int FieldCenterZPix {
    int get ();
    void set (int value);
}

See Also

Field Class


FieldInnerBorderPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..FieldInnerBorderPix Property
Field Class See Also Send Feedback
比赛场地内边界的屏幕宽度（**配置**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FieldInnerBorderPix { get; set; }
Visual Basic
Public Property FieldInnerBorderPix As Integer
    Get
    Set
Visual C++
public:
property int FieldInnerBorderPix {
    int get ();
    void set (int value);
}

See Also

Field Class


FieldLengthXMm Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..FieldLengthXMm Property
Field Class See Also Send Feedback
比赛场地X方向上的实际长度（**配置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FieldLengthXMm { get; set; }
Visual Basic
Public Property FieldLengthXMm As Integer
    Get
    Set
Visual C++
public:
property int FieldLengthXMm {
    int get ();
    void set (int value);
}

See Also

Field Class


FieldLengthXPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..FieldLengthXPix Property
Field Class See Also Send Feedback
比赛场地X方向上的屏幕长度（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FieldLengthXPix { get; set; }
Visual Basic
Public Property FieldLengthXPix As Integer
    Get
    Set
Visual C++
public:
property int FieldLengthXPix {
    int get ();
    void set (int value);
}

See Also

Field Class


FieldLengthZMm Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..FieldLengthZMm Property
Field Class See Also Send Feedback
比赛场地Z方向上的实际长度（**配置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FieldLengthZMm { get; set; }
Visual Basic
Public Property FieldLengthZMm As Integer
    Get
    Set
Visual C++
public:
property int FieldLengthZMm {
    int get ();
    void set (int value);
}

See Also

Field Class


FieldLengthZPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..FieldLengthZPix Property
Field Class See Also Send Feedback
比赛场地Z方向上的屏幕长度（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FieldLengthZPix { get; set; }
Visual Basic
Public Property FieldLengthZPix As Integer
    Get
    Set
Visual C++
public:
property int FieldLengthZPix {
    int get ();
    void set (int value);
}

See Also

Field Class


FieldOuterBorderPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..FieldOuterBorderPix Property
Field Class See Also Send Feedback
比赛场地外边界的屏幕宽度（**配置**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FieldOuterBorderPix { get; set; }
Visual Basic
Public Property FieldOuterBorderPix As Integer
    Get
    Set
Visual C++
public:
property int FieldOuterBorderPix {
    int get ();
    void set (int value);
}

See Also

Field Class


ForbiddenZoneLengthXMm Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..ForbiddenZoneLengthXMm Property
Field Class See Also Send Feedback
禁区X方向的实际长度（**配置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int ForbiddenZoneLengthXMm { get; set; }
Visual Basic
Public Property ForbiddenZoneLengthXMm As Integer
    Get
    Set
Visual C++
public:
property int ForbiddenZoneLengthXMm {
    int get ();
    void set (int value);
}

See Also

Field Class


ForbiddenZoneLengthXPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..ForbiddenZoneLengthXPix Property
Field Class See Also Send Feedback
禁区X方向的屏幕长度（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int ForbiddenZoneLengthXPix { get; set; }
Visual Basic
Public Property ForbiddenZoneLengthXPix As Integer
    Get
    Set
Visual C++
public:
property int ForbiddenZoneLengthXPix {
    int get ();
    void set (int value);
}

See Also

Field Class


ForbiddenZoneLengthZMm Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..ForbiddenZoneLengthZMm Property
Field Class See Also Send Feedback
禁区Z方向的实际长度（**配置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int ForbiddenZoneLengthZMm { get; set; }
Visual Basic
Public Property ForbiddenZoneLengthZMm As Integer
    Get
    Set
Visual C++
public:
property int ForbiddenZoneLengthZMm {
    int get ();
    void set (int value);
}

See Also

Field Class


ForbiddenZoneLengthZPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..ForbiddenZoneLengthZPix Property
Field Class See Also Send Feedback
禁区Z方向的屏幕长度（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int ForbiddenZoneLengthZPix { get; set; }
Visual Basic
Public Property ForbiddenZoneLengthZPix As Integer
    Get
    Set
Visual C++
public:
property int ForbiddenZoneLengthZPix {
    int get ();
    void set (int value);
}

See Also

Field Class


FormLengthXPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..FormLengthXPix Property
Field Class See Also Send Feedback
窗体X方向上的屏幕宽度（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FormLengthXPix { get; set; }
Visual Basic
Public Property FormLengthXPix As Integer
    Get
    Set
Visual C++
public:
property int FormLengthXPix {
    int get ();
    void set (int value);
}

See Also

Field Class


FormLengthZPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..FormLengthZPix Property
Field Class See Also Send Feedback
窗体Z方向上的屏幕宽度（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FormLengthZPix { get; set; }
Visual Basic
Public Property FormLengthZPix As Integer
    Get
    Set
Visual C++
public:
property int FormLengthZPix {
    int get ();
    void set (int value);
}

See Also

Field Class


FormPaddingPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..FormPaddingPix Property
Field Class See Also Send Feedback
窗体内边距的屏幕宽度（**配置**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FormPaddingPix { get; set; }
Visual Basic
Public Property FormPaddingPix As Integer
    Get
    Set
Visual C++
public:
property int FormPaddingPix {
    int get ();
    void set (int value);
}

See Also

Field Class


GoalBlockDepthPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..GoalBlockDepthPix Property
Field Class See Also Send Feedback
球门块短边（沿X方向）的屏幕长度（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int GoalBlockDepthPix { get; set; }
Visual Basic
Public Property GoalBlockDepthPix As Integer
    Get
    Set
Visual C++
public:
property int GoalBlockDepthPix {
    int get ();
    void set (int value);
}

See Also

Field Class


GoalBlockWidthPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..GoalBlockWidthPix Property
Field Class See Also Send Feedback
球门块长边（沿Z方向）的屏幕长度（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int GoalBlockWidthPix { get; set; }
Visual Basic
Public Property GoalBlockWidthPix As Integer
    Get
    Set
Visual C++
public:
property int GoalBlockWidthPix {
    int get ();
    void set (int value);
}

See Also

Field Class


GoalDepthMm Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..GoalDepthMm Property
Field Class See Also Send Feedback
球门短边（正置沿X方向）的实际长度（**配置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int GoalDepthMm { get; set; }
Visual Basic
Public Property GoalDepthMm As Integer
    Get
    Set
Visual C++
public:
property int GoalDepthMm {
    int get ();
    void set (int value);
}

See Also

Field Class


GoalDepthPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..GoalDepthPix Property
Field Class See Also Send Feedback
球门短边（沿X方向）的屏幕长度（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int GoalDepthPix { get; set; }
Visual Basic
Public Property GoalDepthPix As Integer
    Get
    Set
Visual C++
public:
property int GoalDepthPix {
    int get ();
    void set (int value);
}

See Also

Field Class


GoalWidthMm Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..GoalWidthMm Property
Field Class See Also Send Feedback
球门长边（正置沿Z方向）的实际长度（**配置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int GoalWidthMm { get; set; }
Visual Basic
Public Property GoalWidthMm As Integer
    Get
    Set
Visual C++
public:
property int GoalWidthMm {
    int get ();
    void set (int value);
}

See Also

Field Class


GoalWidthPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..GoalWidthPix Property
Field Class See Also Send Feedback
球门长边（沿Z方向）的屏幕长度（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int GoalWidthPix { get; set; }
Visual Basic
Public Property GoalWidthPix As Integer
    Get
    Set
Visual C++
public:
property int GoalWidthPix {
    int get ();
    void set (int value);
}

See Also

Field Class


LeftMm Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..LeftMm Property
Field Class See Also Send Feedback
矩形场地中心为原点，右为正X，下为正Z的坐标系中场地左边界X坐标值，单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int LeftMm { get; set; }
Visual Basic
Public Property LeftMm As Integer
    Get
    Set
Visual C++
public:
property int LeftMm {
    int get ();
    void set (int value);
}

See Also

Field Class


PictureBoxXPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..PictureBoxXPix Property
Field Class See Also Send Feedback
图片箱X方向上的屏幕宽度（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int PictureBoxXPix { get; set; }
Visual Basic
Public Property PictureBoxXPix As Integer
    Get
    Set
Visual C++
public:
property int PictureBoxXPix {
    int get ();
    void set (int value);
}

See Also

Field Class


PictureBoxZPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..PictureBoxZPix Property
Field Class See Also Send Feedback
图片箱Z方向上的屏幕宽度（**待求**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int PictureBoxZPix { get; set; }
Visual Basic
Public Property PictureBoxZPix As Integer
    Get
    Set
Visual C++
public:
property int PictureBoxZPix {
    int get ();
    void set (int value);
}

See Also

Field Class


RightMm Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..RightMm Property
Field Class See Also Send Feedback
矩形场地中心为原点，右为正X，下为正Z的坐标系中场地右边界X坐标值，单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int RightMm { get; set; }
Visual Basic
Public Property RightMm As Integer
    Get
    Set
Visual C++
public:
property int RightMm {
    int get ();
    void set (int value);
}

See Also

Field Class


ScaleMmToPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..ScaleMmToPix Property
Field Class See Also Send Feedback
毫米向像素转化的比例因子（**待求**），单位毫米每像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public double ScaleMmToPix { get; set; }
Visual Basic
Public Property ScaleMmToPix As Double
    Get
    Set
Visual C++
public:
property double ScaleMmToPix {
    double get ();
    void set (double value);
}

See Also

Field Class


ScaleMmToPixX Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..ScaleMmToPixX Property
Field Class See Also Send Feedback
X方向毫米向像素转化的比例因子（**待求**），单位毫米每像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public double ScaleMmToPixX { get; set; }
Visual Basic
Public Property ScaleMmToPixX As Double
    Get
    Set
Visual C++
public:
property double ScaleMmToPixX {
    double get ();
    void set (double value);
}

See Also

Field Class


ScaleMmToPixZ Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..ScaleMmToPixZ Property
Field Class See Also Send Feedback
Z方向毫米向像素转化的比例因子（**待求**），单位毫米每像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public double ScaleMmToPixZ { get; set; }
Visual Basic
Public Property ScaleMmToPixZ As Double
    Get
    Set
Visual C++
public:
property double ScaleMmToPixZ {
    double get ();
    void set (double value);
}

See Also

Field Class


SpanBetweenFieldAndTabControlPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..SpanBetweenFieldAndTabControlPix Property
Field Class See Also Send Feedback
比赛场地和选项卡控件之间空隙的屏幕宽度（**配置**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int SpanBetweenFieldAndTabControlPix { get; set; }
Visual Basic
Public Property SpanBetweenFieldAndTabControlPix As Integer
    Get
    Set
Visual C++
public:
property int SpanBetweenFieldAndTabControlPix {
    int get ();
    void set (int value);
}

See Also

Field Class


TabControlLengthXPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..TabControlLengthXPix Property
Field Class See Also Send Feedback
选项卡控件X方向上的屏幕长度（**配置**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int TabControlLengthXPix { get; set; }
Visual Basic
Public Property TabControlLengthXPix As Integer
    Get
    Set
Visual C++
public:
property int TabControlLengthXPix {
    int get ();
    void set (int value);
}

See Also

Field Class


TabControlLengthZPix Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..TabControlLengthZPix Property
Field Class See Also Send Feedback
选项卡控件Z方向上的屏幕长度（**配置**），单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int TabControlLengthZPix { get; set; }
Visual Basic
Public Property TabControlLengthZPix As Integer
    Get
    Set
Visual C++
public:
property int TabControlLengthZPix {
    int get ();
    void set (int value);
}

See Also

Field Class


TopMm Property

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..TopMm Property
Field Class See Also Send Feedback
矩形场地中心为原点，右为正X，下为正Z的坐标系中场地上边界Y坐标值，单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int TopMm { get; set; }
Visual Basic
Public Property TopMm As Integer
    Get
    Set
Visual C++
public:
property int TopMm {
    int get ();
    void set (int value);
}

See Also

Field Class


Field.GoalBlockType Enumeration

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Field..::..GoalBlockType Enumeration
Field Class See Also Send Feedback
球门块方向类型，TYPE11/TYPE12分别表示直角弯钩里侧沿逆时针/顺时针方向

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public enum GoalBlockType
Visual Basic
Public Enumeration GoalBlockType
Visual C++
public enum class GoalBlockType

Members

Member name | Value | Description
TYPE11 | 0 | 球门块直角弯钩里侧沿逆时针方向
TYPE12 | 1 | 球门块直角弯钩里侧沿顺时针方向

See Also

URWPGSim2D.Common Namespace

有关这个主题的评论请发邮件到 bug report

Copyright @ PKU&HNIU


FishSettingComboControls Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls Class
Members See Also Send Feedback
服务端Fish设置界面FishSetting块控件组合类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public class FishSettingComboControls
Visual Basic
Public Class FishSettingComboControls
Visual C++
public ref class FishSettingComboControls

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..FishSettingComboControls

See Also

FishSettingComboControls Members


FishSettingComboControls Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls Members
FishSettingComboControls Class Constructors Methods Fields See Also Send Feedback

The FishSettingComboControls type exposes the following members.

Constructors

 | Name | Description
Public method | FishSettingComboControls | 带参数构造函数

Methods

 | Name | Description
Public method | CmbPlayers_SelectedIndexChanged | 更换队伍队员时点击按钮触发事件
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | BtnBackColor | 仿真机器鱼后部色标选择按钮控件
Public field | BtnConfirm | 仿真机器鱼设置确认按钮控件
Public field | BtnFrontColor | 仿真机器鱼前部色标选择按钮控件
Public field | CmbPlayers | 仿真机器鱼选择下拉框控件
Public field | GrpContainer | 分组容器控件
Public field | TeamId | 当前组合控件所代表队伍的编号（0,1...)
Public field | TxtDirectionDeg | 仿真机器鱼鱼体方向显示控件（弧度转成角度显示）
Public field | TxtPositionMmX | 仿真机器鱼位置坐标X分量显示控件
Public field | TxtPositionMmZ | 仿真机器鱼位置坐标Z分量显示控件

See Also

FishSettingComboControls Class


FishSettingComboControls Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls Constructor
FishSettingComboControls Class See Also Send Feedback
带参数构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public FishSettingComboControls(
    int teamId,
    int Fishes
)
Visual Basic
Public Sub New ( _
    teamId As Integer, _
    Fishes As Integer _
)
Visual C++
public:
FishSettingComboControls(
    int teamId,
    int Fishes
)

Parameters

teamId
Type: System..::..Int32
当前对象所代表的仿真使命参与队伍编号（从0开始）
Fishes
Type: System..::..Int32
当前对象所代表的仿真使命参与队伍仿真机器鱼数量

See Also

FishSettingComboControls Class


FishSettingComboControls Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls Fields
FishSettingComboControls Class See Also Send Feedback

The FishSettingComboControls type exposes the following members.

Fields

 | Name | Description
Public field | BtnBackColor | 仿真机器鱼后部色标选择按钮控件
Public field | BtnConfirm | 仿真机器鱼设置确认按钮控件
Public field | BtnFrontColor | 仿真机器鱼前部色标选择按钮控件
Public field | CmbPlayers | 仿真机器鱼选择下拉框控件
Public field | GrpContainer | 分组容器控件
Public field | TeamId | 当前组合控件所代表队伍的编号（0,1...)
Public field | TxtDirectionDeg | 仿真机器鱼鱼体方向显示控件（弧度转成角度显示）
Public field | TxtPositionMmX | 仿真机器鱼位置坐标X分量显示控件
Public field | TxtPositionMmZ | 仿真机器鱼位置坐标Z分量显示控件

See Also

FishSettingComboControls Class


BtnBackColor Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls..::..BtnBackColor Field
FishSettingComboControls Class See Also Send Feedback
仿真机器鱼后部色标选择按钮控件

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Button BtnBackColor
Visual Basic
Public BtnBackColor As Button
Visual C++
public:
Button^ BtnBackColor

See Also

FishSettingComboControls Class


BtnConfirm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls..::..BtnConfirm Field
FishSettingComboControls Class See Also Send Feedback
仿真机器鱼设置确认按钮控件

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Button BtnConfirm
Visual Basic
Public BtnConfirm As Button
Visual C++
public:
Button^ BtnConfirm

See Also

FishSettingComboControls Class


BtnFrontColor Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls..::..BtnFrontColor Field
FishSettingComboControls Class See Also Send Feedback
仿真机器鱼前部色标选择按钮控件

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Button BtnFrontColor
Visual Basic
Public BtnFrontColor As Button
Visual C++
public:
Button^ BtnFrontColor

See Also

FishSettingComboControls Class


CmbPlayers Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls..::..CmbPlayers Field
FishSettingComboControls Class See Also Send Feedback
仿真机器鱼选择下拉框控件

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public ComboBox CmbPlayers
Visual Basic
Public CmbPlayers As ComboBox
Visual C++
public:
ComboBox^ CmbPlayers

See Also

FishSettingComboControls Class


GrpContainer Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls..::..GrpContainer Field
FishSettingComboControls Class See Also Send Feedback
分组容器控件

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public GroupBox GrpContainer
Visual Basic
Public GrpContainer As GroupBox
Visual C++
public:
GroupBox^ GrpContainer

See Also

FishSettingComboControls Class


TeamId Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls..::..TeamId Field
FishSettingComboControls Class See Also Send Feedback
当前组合控件所代表队伍的编号（0,1...)

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int TeamId
Visual Basic
Public TeamId As Integer
Visual C++
public:
int TeamId

See Also

FishSettingComboControls Class


TxtDirectionDeg Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls..::..TxtDirectionDeg Field
FishSettingComboControls Class See Also Send Feedback
仿真机器鱼鱼体方向显示控件（弧度转成角度显示）

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public TextBox TxtDirectionDeg
Visual Basic
Public TxtDirectionDeg As TextBox
Visual C++
public:
TextBox^ TxtDirectionDeg

See Also

FishSettingComboControls Class


TxtPositionMmX Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls..::..TxtPositionMmX Field
FishSettingComboControls Class See Also Send Feedback
仿真机器鱼位置坐标X分量显示控件

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public TextBox TxtPositionMmX
Visual Basic
Public TxtPositionMmX As TextBox
Visual C++
public:
TextBox^ TxtPositionMmX

See Also

FishSettingComboControls Class


TxtPositionMmZ Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls..::..TxtPositionMmZ Field
FishSettingComboControls Class See Also Send Feedback
仿真机器鱼位置坐标Z分量显示控件

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public TextBox TxtPositionMmZ
Visual Basic
Public TxtPositionMmZ As TextBox
Visual C++
public:
TextBox^ TxtPositionMmZ

See Also

FishSettingComboControls Class


FishSettingComboControls Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls Methods
FishSettingComboControls Class See Also Send Feedback

The FishSettingComboControls type exposes the following members.

Methods

 | Name | Description
Public method | CmbPlayers_SelectedIndexChanged | 更换队伍队员时点击按钮触发事件
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FishSettingComboControls Class


CmbPlayers_SelectedIndexChanged Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
FishSettingComboControls..::..CmbPlayers_SelectedIndexChanged Method
FishSettingComboControls Class See Also Send Feedback
更换队伍队员时点击按钮触发事件

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void CmbPlayers_SelectedIndexChanged(
    Object sender,
    EventArgs e
)
Visual Basic
Public Sub CmbPlayers_SelectedIndexChanged ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
public:
void CmbPlayers_SelectedIndexChanged(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::..Object
事件对象
e
Type: System..::..EventArgs
事件参数

See Also

FishSettingComboControls Class


HalfCourt Enumeration

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
HalfCourt Enumeration
See Also Send Feedback
场地左右半场类型枚举

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public enum HalfCourt
Visual Basic
<SerializableAttribute> _
Public Enumeration HalfCourt
Visual C++
[SerializableAttribute]
public enum class HalfCourt

Members

Member name | Value | Description
LEFT | 0 | 左半场
RIGHT | 1 | 右半场

See Also

URWPGSim2D.Common Namespace

有关这个主题的评论请发邮件到 bug report

Copyright @ PKU&HNIU


IMission Interface

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission Interface
Members See Also Send Feedback
仿真使命（比赛或实验项目）接口，仿真使命基类实现此接口

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public interface IMission
Visual Basic
Public Interface IMission
Visual C++
public interface class IMission

See Also

IMission Members


IMission Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission Members
IMission Interface Methods See Also Send Feedback

The IMission type exposes the following members.

Methods

 | Name | Description
Public method | Draw | 绘制当前使命各相关动态图形对象，在使命基类中实现
Public method | GetDecision | 获取当前使命的决策数组，在仿真基类中实现
Public method | GetEnvironment | 获取当前使命的公共仿真环境，在使命基类中实现
Public method | GetMissionCommonPara | 获取当前使命的公共参数，在使命基类中实现
Public method | GetTeams | 获取当前使命参与队伍列表及每支队伍的通用仿真机器鱼对象，在使命基类中实现 每支队伍的公共参数为新建的副本，不是原始队伍列表中相应对象的引用
Public method | ProcessBallLocomotion | 更新当前使命全部仿真水球的运动学参数，在使命基类中实现
Public method | ProcessCollision | 处理当前周期仿真环境中各种对象间的碰撞，包括检测和响应碰撞，在使命基类中实现
Public method | ProcessControlRules | 处理当前仿真使命的控制规则，在具体使命类中实现
Public method | ProcessFishLocomotion | 更新当前使命全部仿真机器鱼的运动学参数，在使命基类中实现 注意左右半场的处理策略：若仿真机器鱼所在队伍位于右半场， 更新质心坐标值、鱼体方向值、速度方向值、角速度值时，增量值均按正常值取反， 如此便可实现运动行为反向的效果
Public method | SetDecisionsToFishes | 根据当前决策数组更新全部仿真机器鱼的决策数据，在使命基类中实现
Public method | SetMission | 设置当前使命各相关对象的初始值，在每个具体使命类中实现
Public method | SetMissionCommonPara | 设置当前使命的公共参数，在使命基类中实现

See Also

IMission Interface


IMission Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission Methods
IMission Interface See Also Send Feedback

The IMission type exposes the following members.

Methods

 | Name | Description
Public method | Draw | 绘制当前使命各相关动态图形对象，在使命基类中实现
Public method | GetDecision | 获取当前使命的决策数组，在仿真基类中实现
Public method | GetEnvironment | 获取当前使命的公共仿真环境，在使命基类中实现
Public method | GetMissionCommonPara | 获取当前使命的公共参数，在使命基类中实现
Public method | GetTeams | 获取当前使命参与队伍列表及每支队伍的通用仿真机器鱼对象，在使命基类中实现 每支队伍的公共参数为新建的副本，不是原始队伍列表中相应对象的引用
Public method | ProcessBallLocomotion | 更新当前使命全部仿真水球的运动学参数，在使命基类中实现
Public method | ProcessCollision | 处理当前周期仿真环境中各种对象间的碰撞，包括检测和响应碰撞，在使命基类中实现
Public method | ProcessControlRules | 处理当前仿真使命的控制规则，在具体使命类中实现
Public method | ProcessFishLocomotion | 更新当前使命全部仿真机器鱼的运动学参数，在使命基类中实现 注意左右半场的处理策略：若仿真机器鱼所在队伍位于右半场， 更新质心坐标值、鱼体方向值、速度方向值、角速度值时，增量值均按正常值取反， 如此便可实现运动行为反向的效果
Public method | SetDecisionsToFishes | 根据当前决策数组更新全部仿真机器鱼的决策数据，在使命基类中实现
Public method | SetMission | 设置当前使命各相关对象的初始值，在每个具体使命类中实现
Public method | SetMissionCommonPara | 设置当前使命的公共参数，在使命基类中实现

See Also

IMission Interface


Draw Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission..::..Draw Method
IMission Interface See Also Send Feedback
绘制当前使命各相关动态图形对象，在使命基类中实现

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
Bitmap Draw()
Visual Basic
Function Draw As Bitmap
Visual C++
Bitmap^ Draw()

Return Value

绘制好各动态图形对象的Bitmap对象

See Also

IMission Interface


GetDecision Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission..::..GetDecision Method
IMission Interface See Also Send Feedback
获取当前使命的决策数组，在仿真基类中实现

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
Decision[,] GetDecision()
Visual Basic
Function GetDecision As Decision(,)
Visual C++
array<Decision,2>^ GetDecision()

Return Value

当前使命各支队伍各个队员的决策数组，d[i, j]为第i队第j条仿真机器鱼的决策数据

See Also

IMission Interface


GetEnvironment Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission..::..GetEnvironment Method
IMission Interface See Also Send Feedback
获取当前使命的公共仿真环境，在使命基类中实现

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
SimEnvironment GetEnvironment()
Visual Basic
Function GetEnvironment As SimEnvironment
Visual C++
SimEnvironment^ GetEnvironment()

Return Value

仿真环境基类对象引用

See Also

IMission Interface


GetMissionCommonPara Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission..::..GetMissionCommonPara Method
IMission Interface See Also Send Feedback
获取当前使命的公共参数，在使命基类中实现

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
MissionCommonPara GetMissionCommonPara()
Visual Basic
Function GetMissionCommonPara As MissionCommonPara
Visual C++
MissionCommonPara^ GetMissionCommonPara()

Return Value

当前使命的公共参数值

See Also

IMission Interface


GetTeams Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission..::..GetTeams Method
IMission Interface See Also Send Feedback
获取当前使命参与队伍列表及每支队伍的通用仿真机器鱼对象，在使命基类中实现 每支队伍的公共参数为新建的副本，不是原始队伍列表中相应对象的引用

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
List<Team<RoboFish>> GetTeams()
Visual Basic
Function GetTeams As List(Of Team(Of RoboFish))
Visual C++
List<Team<RoboFish^>^>^ GetTeams()

Return Value

仿真使命参与队伍列表，每支队伍里有相应的通用仿真机器鱼对象引用

See Also

IMission Interface


ProcessBallLocomotion Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission..::..ProcessBallLocomotion Method
IMission Interface See Also Send Feedback
更新当前使命全部仿真水球的运动学参数，在使命基类中实现

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
void ProcessBallLocomotion()
Visual Basic
Sub ProcessBallLocomotion
Visual C++
void ProcessBallLocomotion()

See Also

IMission Interface


ProcessCollision Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission..::..ProcessCollision Method
IMission Interface See Also Send Feedback
处理当前周期仿真环境中各种对象间的碰撞，包括检测和响应碰撞，在使命基类中实现

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
void ProcessCollision()
Visual Basic
Sub ProcessCollision
Visual C++
void ProcessCollision()

See Also

IMission Interface


ProcessControlRules Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission..::..ProcessControlRules Method
IMission Interface See Also Send Feedback
处理当前仿真使命的控制规则，在具体使命类中实现

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
void ProcessControlRules()
Visual Basic
Sub ProcessControlRules
Visual C++
void ProcessControlRules()

See Also

IMission Interface


ProcessFishLocomotion Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission..::..ProcessFishLocomotion Method
IMission Interface See Also Send Feedback
更新当前使命全部仿真机器鱼的运动学参数，在使命基类中实现 注意左右半场的处理策略：若仿真机器鱼所在队伍位于右半场， 更新质心坐标值、鱼体方向值、速度方向值、角速度值时，增量值均按正常值取反， 如此便可实现运动行为反向的效果

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
void ProcessFishLocomotion()
Visual Basic
Sub ProcessFishLocomotion
Visual C++
void ProcessFishLocomotion()

See Also

IMission Interface


SetDecisionsToFishes Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission..::..SetDecisionsToFishes Method
IMission Interface See Also Send Feedback
根据当前决策数组更新全部仿真机器鱼的决策数据，在使命基类中实现

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
void SetDecisionsToFishes()
Visual Basic
Sub SetDecisionsToFishes
Visual C++
void SetDecisionsToFishes()

See Also

IMission Interface


SetMission Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission..::..SetMission Method
IMission Interface See Also Send Feedback
设置当前使命各相关对象的初始值，在每个具体使命类中实现

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
void SetMission()
Visual Basic
Sub SetMission
Visual C++
void SetMission()

See Also

IMission Interface


SetMissionCommonPara Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IMission..::..SetMissionCommonPara Method
IMission Interface See Also Send Feedback
设置当前使命的公共参数，在使命基类中实现

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
void SetMissionCommonPara(
    MissionCommonPara para
)
Visual Basic
Sub SetMissionCommonPara ( _
    para As MissionCommonPara _
)
Visual C++
void SetMissionCommonPara(
    MissionCommonPara^ para
)

Parameters

para
Type: URWPGSim2D.Common..::..MissionCommonPara
当前使命的公共参数值

See Also

IMission Interface


IRoboFish Interface

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
IRoboFish Interface
See Also Send Feedback
仿真机器鱼行为接口，仿真机器鱼基类实现此接口

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public interface IRoboFish
Visual Basic
Public Interface IRoboFish
Visual C++
public interface class IRoboFish

See Also

URWPGSim2D.Common Namespace

有关这个主题的评论请发邮件到 bug report

Copyright @ PKU&HNIU


ISimEnvironment Interface

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
ISimEnvironment Interface
See Also Send Feedback
仿真环境接口，仿真环境基类实现此接口

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public interface ISimEnvironment
Visual Basic
Public Interface ISimEnvironment
Visual C++
public interface class ISimEnvironment

See Also

URWPGSim2D.Common Namespace

有关这个主题的评论请发邮件到 bug report

Copyright @ PKU&HNIU


Mission Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission Class
Members See Also Send Feedback
仿真使命（比赛或实验项目）基类，所有具体使命（比赛或实验项目）使用的使命类必须继承该类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class Mission : IMission, ICloneable,
    IDssSerializable
Visual Basic
<SerializableAttribute> _
Public Class Mission _
    Implements IMission, ICloneable, IDssSerializable
Visual C++
[SerializableAttribute]
public ref class Mission : IMission,
    ICloneable, IDssSerializable

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..Mission

See Also

Mission Members


Mission Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission Members
Mission Class Constructors Methods Fields See Also Send Feedback

The Mission type exposes the following members.

Constructors

 | Name | Description
Public method | Mission | 构造函数

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Draw | 实现IMission中的接口用于 绘制当前使命中的动态图形对象
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDecision | 实现IMission中的接口用于 获取当前使命类型的决策数组
Public method | GetEnvironment | 实现IMission中的接口用于 获取当前使命的公共仿真环境
Public method | GetHashCode | (Inherited from Object.)
Public method | GetMissionCommonPara | 实现IMission中的接口用于 获取当前使命的公共参数
Public method | GetTeams | 实现IMission中的接口用于 获取当前使命参与队伍列表及每支队伍的通用仿真机器鱼对象 每支队伍的公共参数为新建的副本，不是原始队伍列表中相应对象的引用
Public method | GetType | (Inherited from Object.)
Protected method | InitDecision | 初始化决策数组空间，由各具体使命类构造函数调用 该方法要在调用SetMissionCommonPara设置好比赛类型公共参数（如每队队员数量）之后调用
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessBallLocomotion | 实现IMission中的接口用于 更新当前使命全部仿真水球的运动学参数
Public method | ProcessCollision | 实现IMission中的接口用于 处理当前周期仿真环境中各种对象间的碰撞，包括检测和响应碰撞
Public method | ProcessControlRules | 处理当前仿真使命的控制规则，在具体使命类中实现
Public method | ProcessFishLocomotion | 实现IMission中的接口用于 更新当前使命中全部仿真机器鱼的运动学参数 注意左右半场的处理方法：若仿真机器鱼所在队伍位于右半场， 更新质心坐标值、鱼体方向值、速度方向值、角速度值时，增量值均按正常值取反， 如此便可实现运动行为反向的效果
Public method | RecoveryPose | 恢复所处半场 用于仿真机器鱼所属队伍位于右半场时绘制/碰撞检测/向客户端或策略传递参数后的处理
Protected method | ResetDecision | 将决策数组各元素重置为默认值，由各具体使命类的SetMission方法调用 供使命类型改变时重新初始化当前选中的使命用
Protected method | ResetSomeLocomotionPara | 重启或改变仿真使命类型时重置当前选中使命的动态对象（仿真机器鱼和仿真水球）的部分运动学参数 主要是将速度值/速度方向值/角速度值/直游档位值/转弯档位值等重置为默认值 该方法由各具体使命类的SetMission接口实现方法调用
Public method | ReversePose | 对调所处半场，即将位置坐标和鱼体方向取反 用于仿真机器鱼所属队伍位于右半场时绘制/碰撞检测/向客户端或策略传递参数前的处理
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | SetDecisionsToFishes | 实现IMission中的接口用于 根据当前决策数组更新全部仿真机器鱼的决策数据
Public method | SetFishColor | 设置仿真机器鱼的颜色
Public method | SetFishPose | 设置仿真机器鱼位姿
Public method | SetMission | 设置当前使命各相关对象的初始值，在每个具体使命类中实现
Public method | SetMissionCommonPara | 实现IMission中的接口用于 设置当前使命的公共参数
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | CommonPara | 仿真使命（比赛或实验项目）公共参数
Public field | DecisionRef | 仿真使命（比赛或实验项目）各支队伍各条仿真机器鱼的决策数组 DecisionRef[i, j]为第i队第j条鱼的决策数据
Public field | EnvRef | 仿真使命（比赛或实验项目）所使用的通用仿真环境
Public field | TeamsRef | 仿真使命（比赛或实验项目）通用参与队伍列表及其通用仿真机器鱼

See Also

Mission Class


Mission Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission Constructor
Mission Class See Also Send Feedback
构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Mission()
Visual Basic
Public Sub New
Visual C++
public:
Mission()

See Also

Mission Class


Mission Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission Fields
Mission Class See Also Send Feedback

The Mission type exposes the following members.

Fields

 | Name | Description
Public field | CommonPara | 仿真使命（比赛或实验项目）公共参数
Public field | DecisionRef | 仿真使命（比赛或实验项目）各支队伍各条仿真机器鱼的决策数组 DecisionRef[i, j]为第i队第j条鱼的决策数据
Public field | EnvRef | 仿真使命（比赛或实验项目）所使用的通用仿真环境
Public field | TeamsRef | 仿真使命（比赛或实验项目）通用参与队伍列表及其通用仿真机器鱼

See Also

Mission Class


CommonPara Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..CommonPara Field
Mission Class See Also Send Feedback
仿真使命（比赛或实验项目）公共参数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public MissionCommonPara CommonPara
Visual Basic
Public CommonPara As MissionCommonPara
Visual C++
public:
MissionCommonPara^ CommonPara

See Also

Mission Class


DecisionRef Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..DecisionRef Field
Mission Class See Also Send Feedback
仿真使命（比赛或实验项目）各支队伍各条仿真机器鱼的决策数组 DecisionRef[i, j]为第i队第j条鱼的决策数据

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Decision[,] DecisionRef
Visual Basic
Public DecisionRef As Decision(,)
Visual C++
public:
array<Decision,2>^ DecisionRef

See Also

Mission Class


EnvRef Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..EnvRef Field
Mission Class See Also Send Feedback
仿真使命（比赛或实验项目）所使用的通用仿真环境

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public SimEnvironment EnvRef
Visual Basic
Public EnvRef As SimEnvironment
Visual C++
public:
SimEnvironment^ EnvRef

See Also

Mission Class


TeamsRef Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..TeamsRef Field
Mission Class See Also Send Feedback
仿真使命（比赛或实验项目）通用参与队伍列表及其通用仿真机器鱼

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Team<RoboFish>> TeamsRef
Visual Basic
Public TeamsRef As List(Of Team(Of RoboFish))
Visual C++
public:
List<Team<RoboFish^>^>^ TeamsRef

See Also

Mission Class


Mission Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission Methods
Mission Class See Also Send Feedback

The Mission type exposes the following members.

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Draw | 实现IMission中的接口用于 绘制当前使命中的动态图形对象
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDecision | 实现IMission中的接口用于 获取当前使命类型的决策数组
Public method | GetEnvironment | 实现IMission中的接口用于 获取当前使命的公共仿真环境
Public method | GetHashCode | (Inherited from Object.)
Public method | GetMissionCommonPara | 实现IMission中的接口用于 获取当前使命的公共参数
Public method | GetTeams | 实现IMission中的接口用于 获取当前使命参与队伍列表及每支队伍的通用仿真机器鱼对象 每支队伍的公共参数为新建的副本，不是原始队伍列表中相应对象的引用
Public method | GetType | (Inherited from Object.)
Protected method | InitDecision | 初始化决策数组空间，由各具体使命类构造函数调用 该方法要在调用SetMissionCommonPara设置好比赛类型公共参数（如每队队员数量）之后调用
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ProcessBallLocomotion | 实现IMission中的接口用于 更新当前使命全部仿真水球的运动学参数
Public method | ProcessCollision | 实现IMission中的接口用于 处理当前周期仿真环境中各种对象间的碰撞，包括检测和响应碰撞
Public method | ProcessControlRules | 处理当前仿真使命的控制规则，在具体使命类中实现
Public method | ProcessFishLocomotion | 实现IMission中的接口用于 更新当前使命中全部仿真机器鱼的运动学参数 注意左右半场的处理方法：若仿真机器鱼所在队伍位于右半场， 更新质心坐标值、鱼体方向值、速度方向值、角速度值时，增量值均按正常值取反， 如此便可实现运动行为反向的效果
Public method | RecoveryPose | 恢复所处半场 用于仿真机器鱼所属队伍位于右半场时绘制/碰撞检测/向客户端或策略传递参数后的处理
Protected method | ResetDecision | 将决策数组各元素重置为默认值，由各具体使命类的SetMission方法调用 供使命类型改变时重新初始化当前选中的使命用
Protected method | ResetSomeLocomotionPara | 重启或改变仿真使命类型时重置当前选中使命的动态对象（仿真机器鱼和仿真水球）的部分运动学参数 主要是将速度值/速度方向值/角速度值/直游档位值/转弯档位值等重置为默认值 该方法由各具体使命类的SetMission接口实现方法调用
Public method | ReversePose | 对调所处半场，即将位置坐标和鱼体方向取反 用于仿真机器鱼所属队伍位于右半场时绘制/碰撞检测/向客户端或策略传递参数前的处理
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | SetDecisionsToFishes | 实现IMission中的接口用于 根据当前决策数组更新全部仿真机器鱼的决策数据
Public method | SetFishColor | 设置仿真机器鱼的颜色
Public method | SetFishPose | 设置仿真机器鱼位姿
Public method | SetMission | 设置当前使命各相关对象的初始值，在每个具体使命类中实现
Public method | SetMissionCommonPara | 实现IMission中的接口用于 设置当前使命的公共参数
Public method | ToString | (Inherited from Object.)

See Also

Mission Class


Clone Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..Clone Method
Mission Class See Also Send Feedback
实现Clone接口的方法，拷贝一份当前对象的副本

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

当前对象的副本

Implements

ICloneable..::..Clone()()()()
IDssSerializableClone()()()()

See Also

Mission Class


CopyTo Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..CopyTo Method
Mission Class See Also Send Feedback
实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void CopyTo(
    IDssSerializable target
)
Visual Basic
Public Overridable Sub CopyTo ( _
    target As IDssSerializable _
)
Visual C++
public:
virtual void CopyTo(
    IDssSerializable^ target
)

Parameters

target
Type: IDssSerializable
当前对象拷贝到的目标对象

Implements

IDssSerializableCopyTo(IDssSerializable)

See Also

Mission Class


Deserialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..Deserialize Method
Mission Class See Also Send Feedback
实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Deserialize(
    BinaryReader reader
)
Visual Basic
Public Overridable Function Deserialize ( _
    reader As BinaryReader _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IO..::..BinaryReader
反序列化操作的来源对象

Return Value

反序列化得到的当前类型对象

Implements

IDssSerializableDeserialize(BinaryReader)

See Also

Mission Class


Draw Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..Draw Method
Mission Class See Also Send Feedback
实现IMission中的接口用于 绘制当前使命中的动态图形对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Bitmap Draw()
Visual Basic
Public Function Draw As Bitmap
Visual C++
public:
virtual Bitmap^ Draw() sealed

Return Value

绘制好各动态图形对象的Bitmap对象

Implements

IMission..::..Draw()()()()

See Also

Mission Class


GetDecision Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..GetDecision Method
Mission Class See Also Send Feedback
实现IMission中的接口用于 获取当前使命类型的决策数组

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Decision[,] GetDecision()
Visual Basic
Public Function GetDecision As Decision(,)
Visual C++
public:
virtual array<Decision,2>^ GetDecision() sealed

Return Value

当前使命类型各支队伍各个队员的决策数组，d[i, j]为第i队第j条仿真机器鱼的决策数据

Implements

IMission..::..GetDecision()()()()

See Also

Mission Class


GetEnvironment Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..GetEnvironment Method
Mission Class See Also Send Feedback
实现IMission中的接口用于 获取当前使命的公共仿真环境

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public SimEnvironment GetEnvironment()
Visual Basic
Public Function GetEnvironment As SimEnvironment
Visual C++
public:
virtual SimEnvironment^ GetEnvironment() sealed

Return Value

仿真环境基类对象引用

Implements

IMission..::..GetEnvironment()()()()

See Also

Mission Class


GetMissionCommonPara Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..GetMissionCommonPara Method
Mission Class See Also Send Feedback
实现IMission中的接口用于 获取当前使命的公共参数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public MissionCommonPara GetMissionCommonPara()
Visual Basic
Public Function GetMissionCommonPara As MissionCommonPara
Visual C++
public:
virtual MissionCommonPara^ GetMissionCommonPara() sealed

Return Value

当前使命类型的公共参数值

Implements

IMission..::..GetMissionCommonPara()()()()

See Also

Mission Class


GetTeams Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..GetTeams Method
Mission Class See Also Send Feedback
实现IMission中的接口用于 获取当前使命参与队伍列表及每支队伍的通用仿真机器鱼对象 每支队伍的公共参数为新建的副本，不是原始队伍列表中相应对象的引用

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Team<RoboFish>> GetTeams()
Visual Basic
Public Function GetTeams As List(Of Team(Of RoboFish))
Visual C++
public:
virtual List<Team<RoboFish^>^>^ GetTeams() sealed

Return Value

仿真使命参与队伍列表，每支队伍里有相应的通用仿真机器鱼对象引用

Implements

IMission..::..GetTeams()()()()

See Also

Mission Class


InitDecision Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..InitDecision Method
Mission Class See Also Send Feedback
初始化决策数组空间，由各具体使命类构造函数调用 该方法要在调用SetMissionCommonPara设置好比赛类型公共参数（如每队队员数量）之后调用

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
protected void InitDecision()
Visual Basic
Protected Sub InitDecision
Visual C++
protected:
void InitDecision()

Return Value

See Also

Mission Class


ProcessBallLocomotion Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..ProcessBallLocomotion Method
Mission Class See Also Send Feedback
实现IMission中的接口用于 更新当前使命全部仿真水球的运动学参数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void ProcessBallLocomotion()
Visual Basic
Public Sub ProcessBallLocomotion
Visual C++
public:
virtual void ProcessBallLocomotion() sealed

Implements

IMission..::..ProcessBallLocomotion()()()()

See Also

Mission Class


ProcessCollision Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..ProcessCollision Method
Mission Class See Also Send Feedback
实现IMission中的接口用于 处理当前周期仿真环境中各种对象间的碰撞，包括检测和响应碰撞

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void ProcessCollision()
Visual Basic
Public Sub ProcessCollision
Visual C++
public:
virtual void ProcessCollision() sealed

Implements

IMission..::..ProcessCollision()()()()

See Also

Mission Class


ProcessControlRules Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..ProcessControlRules Method
Mission Class See Also Send Feedback
处理当前仿真使命的控制规则，在具体使命类中实现

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void ProcessControlRules()
Visual Basic
Public Overridable Sub ProcessControlRules
Visual C++
public:
virtual void ProcessControlRules()

Implements

IMission..::..ProcessControlRules()()()()

See Also

Mission Class


ProcessFishLocomotion Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..ProcessFishLocomotion Method
Mission Class See Also Send Feedback
实现IMission中的接口用于 更新当前使命中全部仿真机器鱼的运动学参数 注意左右半场的处理方法：若仿真机器鱼所在队伍位于右半场， 更新质心坐标值、鱼体方向值、速度方向值、角速度值时，增量值均按正常值取反， 如此便可实现运动行为反向的效果

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void ProcessFishLocomotion()
Visual Basic
Public Sub ProcessFishLocomotion
Visual C++
public:
virtual void ProcessFishLocomotion() sealed

Implements

IMission..::..ProcessFishLocomotion()()()()

See Also

Mission Class


RecoveryPose Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..RecoveryPose Method
Mission Class See Also Send Feedback
恢复所处半场 用于仿真机器鱼所属队伍位于右半场时绘制/碰撞检测/向客户端或策略传递参数后的处理

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void RecoveryPose()
Visual Basic
Public Sub RecoveryPose
Visual C++
public:
void RecoveryPose()

See Also

Mission Class


ResetDecision Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..ResetDecision Method
Mission Class See Also Send Feedback
将决策数组各元素重置为默认值，由各具体使命类的SetMission方法调用 供使命类型改变时重新初始化当前选中的使命用

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
protected void ResetDecision()
Visual Basic
Protected Sub ResetDecision
Visual C++
protected:
void ResetDecision()

See Also

Mission Class


ResetSomeLocomotionPara Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..ResetSomeLocomotionPara Method
Mission Class See Also Send Feedback
重启或改变仿真使命类型时重置当前选中使命的动态对象（仿真机器鱼和仿真水球）的部分运动学参数 主要是将速度值/速度方向值/角速度值/直游档位值/转弯档位值等重置为默认值 该方法由各具体使命类的SetMission接口实现方法调用

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
protected void ResetSomeLocomotionPara()
Visual Basic
Protected Sub ResetSomeLocomotionPara
Visual C++
protected:
void ResetSomeLocomotionPara()

See Also

Mission Class


ReversePose Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..ReversePose Method
Mission Class See Also Send Feedback
对调所处半场，即将位置坐标和鱼体方向取反 用于仿真机器鱼所属队伍位于右半场时绘制/碰撞检测/向客户端或策略传递参数前的处理

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void ReversePose()
Visual Basic
Public Sub ReversePose
Visual C++
public:
void ReversePose()

See Also

Mission Class


Serialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..Serialize Method
Mission Class See Also Send Feedback
实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void Serialize(
    BinaryWriter writer
)
Visual Basic
Public Overridable Sub Serialize ( _
    writer As BinaryWriter _
)
Visual C++
public:
virtual void Serialize(
    BinaryWriter^ writer
)

Parameters

writer
Type: System.IO..::..BinaryWriter
当前对象序列化到的目标对象

Implements

IDssSerializableSerialize(BinaryWriter)

See Also

Mission Class


SetDecisionsToFishes Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..SetDecisionsToFishes Method
Mission Class See Also Send Feedback
实现IMission中的接口用于 根据当前决策数组更新全部仿真机器鱼的决策数据

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void SetDecisionsToFishes()
Visual Basic
Public Sub SetDecisionsToFishes
Visual C++
public:
virtual void SetDecisionsToFishes() sealed

Implements

IMission..::..SetDecisionsToFishes()()()()

See Also

Mission Class


SetFishColor Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..SetFishColor Method
Mission Class See Also Send Feedback
设置仿真机器鱼的颜色

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void SetFishColor(
    int teamId,
    int fishId,
    Color colorFront,
    Color colorBack
)
Visual Basic
Public Sub SetFishColor ( _
    teamId As Integer, _
    fishId As Integer, _
    colorFront As Color, _
    colorBack As Color _
)
Visual C++
public:
void SetFishColor(
    int teamId,
    int fishId,
    Color colorFront,
    Color colorBack
)

Parameters

teamId
Type: System..::..Int32
待设置颜色的仿真机器鱼所在队伍编号（从0开始）
fishId
Type: System..::..Int32
待设置颜色的仿真机器鱼在其队伍中的编号（从0开始）
colorFront
Type: System.Drawing..::..Color
仿真机器鱼鱼体矩形前半部分颜色
colorBack
Type: System.Drawing..::..Color
仿真机器鱼鱼体矩形后半部分颜色

See Also

Mission Class


SetFishPose Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..SetFishPose Method
Mission Class See Also Send Feedback
设置仿真机器鱼位姿

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void SetFishPose(
    int teamId,
    int fishId,
    Vector3 position,
    float direction
)
Visual Basic
Public Sub SetFishPose ( _
    teamId As Integer, _
    fishId As Integer, _
    position As Vector3, _
    direction As Single _
)
Visual C++
public:
void SetFishPose(
    int teamId,
    int fishId,
    Vector3 position,
    float direction
)

Parameters

teamId
Type: System..::..Int32
待设置颜色的仿真机器鱼所在队伍编号（从0开始）
fishId
Type: System..::..Int32
待设置颜色的仿真机器鱼在其队伍中的编号（从0开始）
position
Type: Vector3
仿真机器鱼位置
direction
Type: System..::..Single
仿真机器鱼方向

See Also

Mission Class


SetMission Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..SetMission Method
Mission Class See Also Send Feedback
设置当前使命各相关对象的初始值，在每个具体使命类中实现

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void SetMission()
Visual Basic
Public Overridable Sub SetMission
Visual C++
public:
virtual void SetMission()

Implements

IMission..::..SetMission()()()()

See Also

Mission Class


SetMissionCommonPara Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Mission..::..SetMissionCommonPara Method
Mission Class See Also Send Feedback
实现IMission中的接口用于 设置当前使命的公共参数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void SetMissionCommonPara(
    MissionCommonPara para
)
Visual Basic
Public Sub SetMissionCommonPara ( _
    para As MissionCommonPara _
)
Visual C++
public:
virtual void SetMissionCommonPara(
    MissionCommonPara^ para
) sealed

Parameters

para
Type: URWPGSim2D.Common..::..MissionCommonPara
当前使命类型的公共参数值

Implements

IMission..::..SetMissionCommonPara(MissionCommonPara)

See Also

Mission Class


MissionCommonPara Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara Class
Members See Also Send Feedback
仿真使命（比赛或实验项目）公共参数类型结构体

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class MissionCommonPara : ICloneable,
    IDssSerializable
Visual Basic
<SerializableAttribute> _
Public Class MissionCommonPara _
    Implements ICloneable, IDssSerializable
Visual C++
[SerializableAttribute]
public ref class MissionCommonPara : ICloneable,
    IDssSerializable

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..MissionCommonPara

See Also

MissionCommonPara Members


MissionCommonPara Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara Members
MissionCommonPara Class Constructors Methods Fields See Also Send Feedback

The MissionCommonPara type exposes the following members.

Constructors

 | Name | Description
Public method | MissionCommonPara()()()() | 默认构造函数
Public method | MissionCommonPara(String, Int32, Int32, Int32, Int32) | 带参数构造函数，默认构造出1V1比赛类型的使命公共参数结构体变量

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | DisplayingCycles | 动态对象（仿真机器鱼和仿真水球）参数集中显示窗口DlgFishInfo打开后经过的周期数
Public field | FishCntPerTeam | 仿真使命（比赛或实验项目）参与队伍每队仿真机器鱼数量
Public field | IsExchangeHalfCourt | 仿真使命运行过程中需要交换半场，true则需要，false则不需要 added by liushu 20110314
Public field | IsPaused | 仿真使命（比赛或实验项目）是否正在运行，且处于暂停状态
Public field | IsPauseNeeded | 仿真使命（比赛或实验项目）运行过程中，需要模拟点击界面“暂停”按钮，true需要，false不需要 用于对抗性比赛进球或交换半场后，在ProcessControlRules方法中设置以通知Sim2DSvr使用代码模拟按下“暂停”按钮
Public field | IsRunning | 仿真使命（比赛或实验项目）是否正在运行，用于实现界面状态约束
Public field | IsShowDlgNeeded | 仿真使命（比赛或实验项目）运行过程中，当前周期是否需要弹出提示对话框
Public field | Message | 仿真使命（比赛或实验项目）运行过程中，需要使用弹出对话框显示的消息字符串
Public field | MsPerCycle | 仿真使命（比赛或实验项目）的仿真周期毫秒数
Public field | Name | 仿真使命（比赛或实验项目）名称字符串
Public field | RemainingCycles | 仿真使命（比赛或实验项目）过程当前所剩仿真周期数
Public field | TeamCount | 仿真使命（比赛或实验项目）参与队伍数量
Public field | TotalSeconds | 仿真使命（比赛或实验项目）完成所需时间总秒数

See Also

MissionCommonPara Class


MissionCommonPara Constructor

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara Constructor
MissionCommonPara Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MissionCommonPara()()()() | 默认构造函数
Public method | MissionCommonPara(String, Int32, Int32, Int32, Int32) | 带参数构造函数，默认构造出1V1比赛类型的使命公共参数结构体变量

See Also

MissionCommonPara Class
MissionCommonPara Members


MissionCommonPara Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara Constructor
MissionCommonPara Class See Also Send Feedback
默认构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public MissionCommonPara()
Visual Basic
Public Sub New
Visual C++
public:
MissionCommonPara()

See Also

MissionCommonPara Class
MissionCommonPara Overload


MissionCommonPara Constructor (String, Int32, Int32, Int32, Int32)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara Constructor (String, Int32, Int32, Int32, Int32)
MissionCommonPara Class See Also Send Feedback
带参数构造函数，默认构造出1V1比赛类型的使命公共参数结构体变量

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public MissionCommonPara(
    string strName,
    int iTeamCount,
    int iFishCntPerTeam,
    int iTotalSeconds,
    int iMsPerCycle
)
Visual Basic
Public Sub New ( _
    strName As String, _
    iTeamCount As Integer, _
    iFishCntPerTeam As Integer, _
    iTotalSeconds As Integer, _
    iMsPerCycle As Integer _
)
Visual C++
public:
MissionCommonPara(
    String^ strName,
    int iTeamCount,
    int iFishCntPerTeam,
    int iTotalSeconds,
    int iMsPerCycle
)

Parameters

strName
Type: System..::..String

[Missing <param name="strName"/> documentation for "M:URWPGSim2D.Common.MissionCommonPara.#ctor(System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

iTeamCount
Type: System..::..Int32

[Missing <param name="iTeamCount"/> documentation for "M:URWPGSim2D.Common.MissionCommonPara.#ctor(System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

iFishCntPerTeam
Type: System..::..Int32

[Missing <param name="iFishCntPerTeam"/> documentation for "M:URWPGSim2D.Common.MissionCommonPara.#ctor(System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

iTotalSeconds
Type: System..::..Int32

[Missing <param name="iTotalSeconds"/> documentation for "M:URWPGSim2D.Common.MissionCommonPara.#ctor(System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

iMsPerCycle
Type: System..::..Int32

[Missing <param name="iMsPerCycle"/> documentation for "M:URWPGSim2D.Common.MissionCommonPara.#ctor(System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

MissionCommonPara Class
MissionCommonPara Overload


MissionCommonPara Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara Fields
MissionCommonPara Class See Also Send Feedback

The MissionCommonPara type exposes the following members.

Fields

 | Name | Description
Public field | DisplayingCycles | 动态对象（仿真机器鱼和仿真水球）参数集中显示窗口DlgFishInfo打开后经过的周期数
Public field | FishCntPerTeam | 仿真使命（比赛或实验项目）参与队伍每队仿真机器鱼数量
Public field | IsExchangeHalfCourt | 仿真使命运行过程中需要交换半场，true则需要，false则不需要 added by liushu 20110314
Public field | IsPaused | 仿真使命（比赛或实验项目）是否正在运行，且处于暂停状态
Public field | IsPauseNeeded | 仿真使命（比赛或实验项目）运行过程中，需要模拟点击界面“暂停”按钮，true需要，false不需要 用于对抗性比赛进球或交换半场后，在ProcessControlRules方法中设置以通知Sim2DSvr使用代码模拟按下“暂停”按钮
Public field | IsRunning | 仿真使命（比赛或实验项目）是否正在运行，用于实现界面状态约束
Public field | IsShowDlgNeeded | 仿真使命（比赛或实验项目）运行过程中，当前周期是否需要弹出提示对话框
Public field | Message | 仿真使命（比赛或实验项目）运行过程中，需要使用弹出对话框显示的消息字符串
Public field | MsPerCycle | 仿真使命（比赛或实验项目）的仿真周期毫秒数
Public field | Name | 仿真使命（比赛或实验项目）名称字符串
Public field | RemainingCycles | 仿真使命（比赛或实验项目）过程当前所剩仿真周期数
Public field | TeamCount | 仿真使命（比赛或实验项目）参与队伍数量
Public field | TotalSeconds | 仿真使命（比赛或实验项目）完成所需时间总秒数

See Also

MissionCommonPara Class


DisplayingCycles Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..DisplayingCycles Field
MissionCommonPara Class See Also Send Feedback
动态对象（仿真机器鱼和仿真水球）参数集中显示窗口DlgFishInfo打开后经过的周期数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int DisplayingCycles
Visual Basic
Public DisplayingCycles As Integer
Visual C++
public:
int DisplayingCycles

See Also

MissionCommonPara Class


FishCntPerTeam Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..FishCntPerTeam Field
MissionCommonPara Class See Also Send Feedback
仿真使命（比赛或实验项目）参与队伍每队仿真机器鱼数量

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FishCntPerTeam
Visual Basic
Public FishCntPerTeam As Integer
Visual C++
public:
int FishCntPerTeam

See Also

MissionCommonPara Class


IsExchangeHalfCourt Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..IsExchangeHalfCourt Field
MissionCommonPara Class See Also Send Feedback
仿真使命运行过程中需要交换半场，true则需要，false则不需要 added by liushu 20110314

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public bool IsExchangeHalfCourt
Visual Basic
Public IsExchangeHalfCourt As Boolean
Visual C++
public:
bool IsExchangeHalfCourt

See Also

MissionCommonPara Class


IsPaused Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..IsPaused Field
MissionCommonPara Class See Also Send Feedback
仿真使命（比赛或实验项目）是否正在运行，且处于暂停状态

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public bool IsPaused
Visual Basic
Public IsPaused As Boolean
Visual C++
public:
bool IsPaused

See Also

MissionCommonPara Class


IsPauseNeeded Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..IsPauseNeeded Field
MissionCommonPara Class See Also Send Feedback
仿真使命（比赛或实验项目）运行过程中，需要模拟点击界面“暂停”按钮，true需要，false不需要 用于对抗性比赛进球或交换半场后，在ProcessControlRules方法中设置以通知Sim2DSvr使用代码模拟按下“暂停”按钮

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public bool IsPauseNeeded
Visual Basic
Public IsPauseNeeded As Boolean
Visual C++
public:
bool IsPauseNeeded

Remarks

added by LiYoubing 20110309

See Also

MissionCommonPara Class


IsRunning Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..IsRunning Field
MissionCommonPara Class See Also Send Feedback
仿真使命（比赛或实验项目）是否正在运行，用于实现界面状态约束

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public bool IsRunning
Visual Basic
Public IsRunning As Boolean
Visual C++
public:
bool IsRunning

See Also

MissionCommonPara Class


IsShowDlgNeeded Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..IsShowDlgNeeded Field
MissionCommonPara Class See Also Send Feedback
仿真使命（比赛或实验项目）运行过程中，当前周期是否需要弹出提示对话框

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public bool IsShowDlgNeeded
Visual Basic
Public IsShowDlgNeeded As Boolean
Visual C++
public:
bool IsShowDlgNeeded

See Also

MissionCommonPara Class


Message Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..Message Field
MissionCommonPara Class See Also Send Feedback
仿真使命（比赛或实验项目）运行过程中，需要使用弹出对话框显示的消息字符串

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public string Message
Visual Basic
Public Message As String
Visual C++
public:
String^ Message

See Also

MissionCommonPara Class


MsPerCycle Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..MsPerCycle Field
MissionCommonPara Class See Also Send Feedback
仿真使命（比赛或实验项目）的仿真周期毫秒数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int MsPerCycle
Visual Basic
Public MsPerCycle As Integer
Visual C++
public:
int MsPerCycle

See Also

MissionCommonPara Class


Name Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..Name Field
MissionCommonPara Class See Also Send Feedback
仿真使命（比赛或实验项目）名称字符串

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public string Name
Visual Basic
Public Name As String
Visual C++
public:
String^ Name

See Also

MissionCommonPara Class


RemainingCycles Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..RemainingCycles Field
MissionCommonPara Class See Also Send Feedback
仿真使命（比赛或实验项目）过程当前所剩仿真周期数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int RemainingCycles
Visual Basic
Public RemainingCycles As Integer
Visual C++
public:
int RemainingCycles

See Also

MissionCommonPara Class


TeamCount Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..TeamCount Field
MissionCommonPara Class See Also Send Feedback
仿真使命（比赛或实验项目）参与队伍数量

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int TeamCount
Visual Basic
Public TeamCount As Integer
Visual C++
public:
int TeamCount

See Also

MissionCommonPara Class


TotalSeconds Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..TotalSeconds Field
MissionCommonPara Class See Also Send Feedback
仿真使命（比赛或实验项目）完成所需时间总秒数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int TotalSeconds
Visual Basic
Public TotalSeconds As Integer
Visual C++
public:
int TotalSeconds

See Also

MissionCommonPara Class


MissionCommonPara Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara Methods
MissionCommonPara Class See Also Send Feedback

The MissionCommonPara type exposes the following members.

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | ToString | (Inherited from Object.)

See Also

MissionCommonPara Class


Clone Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..Clone Method
MissionCommonPara Class See Also Send Feedback
实现Clone接口的方法，拷贝一份当前对象的副本

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

当前对象的副本

Implements

ICloneable..::..Clone()()()()
IDssSerializableClone()()()()

See Also

MissionCommonPara Class


CopyTo Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..CopyTo Method
MissionCommonPara Class See Also Send Feedback
实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void CopyTo(
    IDssSerializable target
)
Visual Basic
Public Overridable Sub CopyTo ( _
    target As IDssSerializable _
)
Visual C++
public:
virtual void CopyTo(
    IDssSerializable^ target
)

Parameters

target
Type: IDssSerializable
当前对象拷贝到的目标对象

Implements

IDssSerializableCopyTo(IDssSerializable)

See Also

MissionCommonPara Class


Deserialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..Deserialize Method
MissionCommonPara Class See Also Send Feedback
实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Deserialize(
    BinaryReader reader
)
Visual Basic
Public Overridable Function Deserialize ( _
    reader As BinaryReader _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IO..::..BinaryReader
反序列化操作的来源对象

Return Value

反序列化得到的当前类型对象

Implements

IDssSerializableDeserialize(BinaryReader)

See Also

MissionCommonPara Class


Serialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MissionCommonPara..::..Serialize Method
MissionCommonPara Class See Also Send Feedback
实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void Serialize(
    BinaryWriter writer
)
Visual Basic
Public Overridable Sub Serialize ( _
    writer As BinaryWriter _
)
Visual C++
public:
virtual void Serialize(
    BinaryWriter^ writer
)

Parameters

writer
Type: System.IO..::..BinaryWriter
当前对象序列化到的目标对象

Implements

IDssSerializableSerialize(BinaryWriter)

See Also

MissionCommonPara Class


MyMission Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MyMission Class
Members See Also Send Feedback
与使命相关各对象的引用

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public class MyMission
Visual Basic
Public Class MyMission
Visual C++
public ref class MyMission

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..MyMission

See Also

MyMission Members


MyMission Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MyMission Members
MyMission Class Methods Fields See Also Send Feedback

The MyMission type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Instance | 创建或获取该类的唯一实例
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | DecisionRef | 当前仿真周期决策结果数组，_decisions[i, j]表示第i支队伍第j条仿真机器鱼的决策结果 其值通过使命接口引用变量IMissionRef调用GetDecision()方法获得
Public field | EnvRef | 仿真环境引用变量，其值通过使命接口引用变量IMissionRef调用GetEnvironment()方法获得
Public field | IMissionRef | 使命接口引用变量，用于调用各具体比赛类型的使命类实例中的方法
Public field | IsRomteMode | 指示服务端运行模式，true表示运行于Remote模式，false表示运行于Local模式 该值为true时
Public field | MissionRef | 通用使命对象引用变量，指向当前选中的具体使命类型对象
Public field | ParasRef | 仿真使命公共参数引用变量 其值通过使命接口引用变量IMissionRef调用GetMissionCommonPara()方法获得
Public field | TeamsRef | 仿真使命参与队伍列表引用变量，其中的RoboFish成员指向具体的仿真机器鱼对象 其值通过使命接口引用变量IMissionRef调用GetTeams()方法获得

See Also

MyMission Class


MyMission Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MyMission Fields
MyMission Class See Also Send Feedback

The MyMission type exposes the following members.

Fields

 | Name | Description
Public field | DecisionRef | 当前仿真周期决策结果数组，_decisions[i, j]表示第i支队伍第j条仿真机器鱼的决策结果 其值通过使命接口引用变量IMissionRef调用GetDecision()方法获得
Public field | EnvRef | 仿真环境引用变量，其值通过使命接口引用变量IMissionRef调用GetEnvironment()方法获得
Public field | IMissionRef | 使命接口引用变量，用于调用各具体比赛类型的使命类实例中的方法
Public field | IsRomteMode | 指示服务端运行模式，true表示运行于Remote模式，false表示运行于Local模式 该值为true时
Public field | MissionRef | 通用使命对象引用变量，指向当前选中的具体使命类型对象
Public field | ParasRef | 仿真使命公共参数引用变量 其值通过使命接口引用变量IMissionRef调用GetMissionCommonPara()方法获得
Public field | TeamsRef | 仿真使命参与队伍列表引用变量，其中的RoboFish成员指向具体的仿真机器鱼对象 其值通过使命接口引用变量IMissionRef调用GetTeams()方法获得

See Also

MyMission Class


DecisionRef Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MyMission..::..DecisionRef Field
MyMission Class See Also Send Feedback
当前仿真周期决策结果数组，_decisions[i, j]表示第i支队伍第j条仿真机器鱼的决策结果 其值通过使命接口引用变量IMissionRef调用GetDecision()方法获得

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Decision[,] DecisionRef
Visual Basic
Public DecisionRef As Decision(,)
Visual C++
public:
array<Decision,2>^ DecisionRef

See Also

MyMission Class


EnvRef Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MyMission..::..EnvRef Field
MyMission Class See Also Send Feedback
仿真环境引用变量，其值通过使命接口引用变量IMissionRef调用GetEnvironment()方法获得

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public SimEnvironment EnvRef
Visual Basic
Public EnvRef As SimEnvironment
Visual C++
public:
SimEnvironment^ EnvRef

See Also

MyMission Class


IMissionRef Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MyMission..::..IMissionRef Field
MyMission Class See Also Send Feedback
使命接口引用变量，用于调用各具体比赛类型的使命类实例中的方法

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public IMission IMissionRef
Visual Basic
Public IMissionRef As IMission
Visual C++
public:
IMission^ IMissionRef

See Also

MyMission Class


IsRomteMode Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MyMission..::..IsRomteMode Field
MyMission Class See Also Send Feedback
指示服务端运行模式，true表示运行于Remote模式，false表示运行于Local模式 该值为true时

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public bool IsRomteMode
Visual Basic
Public IsRomteMode As Boolean
Visual C++
public:
bool IsRomteMode

See Also

MyMission Class


MissionRef Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MyMission..::..MissionRef Field
MyMission Class See Also Send Feedback
通用使命对象引用变量，指向当前选中的具体使命类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Mission MissionRef
Visual Basic
Public MissionRef As Mission
Visual C++
public:
Mission^ MissionRef

See Also

MyMission Class


ParasRef Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MyMission..::..ParasRef Field
MyMission Class See Also Send Feedback
仿真使命公共参数引用变量 其值通过使命接口引用变量IMissionRef调用GetMissionCommonPara()方法获得

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public MissionCommonPara ParasRef
Visual Basic
Public ParasRef As MissionCommonPara
Visual C++
public:
MissionCommonPara^ ParasRef

See Also

MyMission Class


TeamsRef Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MyMission..::..TeamsRef Field
MyMission Class See Also Send Feedback
仿真使命参与队伍列表引用变量，其中的RoboFish成员指向具体的仿真机器鱼对象 其值通过使命接口引用变量IMissionRef调用GetTeams()方法获得

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Team<RoboFish>> TeamsRef
Visual Basic
Public TeamsRef As List(Of Team(Of RoboFish))
Visual C++
public:
List<Team<RoboFish^>^>^ TeamsRef

See Also

MyMission Class


MyMission Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MyMission Methods
MyMission Class See Also Send Feedback

The MyMission type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Instance | 创建或获取该类的唯一实例
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

MyMission Class


Instance Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
MyMission..::..Instance Method
MyMission Class See Also Send Feedback
创建或获取该类的唯一实例

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static MyMission Instance()
Visual Basic
Public Shared Function Instance As MyMission
Visual C++
public:
static MyMission^ Instance()

Return Value

[Missing <returns> documentation for "M:URWPGSim2D.Common.MyMission.Instance"]

See Also

MyMission Class


RectangularDynamic Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic Class
Members See Also Send Feedback
仿真场地中方形动态对象基类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class RectangularDynamic
Visual Basic
<SerializableAttribute> _
Public Class RectangularDynamic
Visual C++
[SerializableAttribute]
public ref class RectangularDynamic

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..RectangularDynamic

See Also

RectangularDynamic Members


RectangularDynamic Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic Members
RectangularDynamic Class Constructors Methods Fields See Also Send Feedback

The RectangularDynamic type exposes the following members.

Constructors

 | Name | Description
Public method | RectangularDynamic | 构造函数

Methods

 | Name | Description
Public method | Draw | 将当前对象绘制到GDI+绘图对象上
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SetRectangularDynamic | 设置默认参数
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | AngularVelocityRadPs | 当前角速度值，单位弧度每秒rad/s
Public field | BorderWidthPix | 边框宽度，单位像素
Public field | Collision | 当前碰撞状态
Public field | ColorBorder | 边框颜色
Public field | ColorFilled | 填充颜色
Public field | DirectionRad | 方向（**设置**），单位弧度
Public field | LengthDirectionRad | 当前长度（Length）方向，单位弧度rad
Public field | LengthMm | 长度（**设置**），单位毫米
Public field | PositionMm | 当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | PreAngularVelocityRadPs | 当前角速度值备份，单位弧度每秒rad/s
Public field | PreCollision | 当前碰撞状态备份
Public field | PreLengthDirectionRad | 当前长度（Length）方向备份，单位弧度rad
Public field | PrePositionMm | 当前中心点坐标备份，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | PreVelocityDirectionRad | 当前速度方向备份，单位弧度rad，值域[-PI, PI)
Public field | PreVelocityMmPs | 当前速度值备份，单位毫米每秒mm/s
Public field | VelocityDirectionRad | 当前速度方向，单位弧度rad，值域[-PI, PI)
Public field | VelocityMmPs | 当前速度值，单位毫米每秒mm/s
Public field | WidthMm | 宽度（**设置**），单位毫米

See Also

RectangularDynamic Class


RectangularDynamic Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic Constructor
RectangularDynamic Class See Also Send Feedback
构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public RectangularDynamic()
Visual Basic
Public Sub New
Visual C++
public:
RectangularDynamic()

See Also

RectangularDynamic Class


RectangularDynamic Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic Fields
RectangularDynamic Class See Also Send Feedback

The RectangularDynamic type exposes the following members.

Fields

 | Name | Description
Public field | AngularVelocityRadPs | 当前角速度值，单位弧度每秒rad/s
Public field | BorderWidthPix | 边框宽度，单位像素
Public field | Collision | 当前碰撞状态
Public field | ColorBorder | 边框颜色
Public field | ColorFilled | 填充颜色
Public field | DirectionRad | 方向（**设置**），单位弧度
Public field | LengthDirectionRad | 当前长度（Length）方向，单位弧度rad
Public field | LengthMm | 长度（**设置**），单位毫米
Public field | PositionMm | 当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | PreAngularVelocityRadPs | 当前角速度值备份，单位弧度每秒rad/s
Public field | PreCollision | 当前碰撞状态备份
Public field | PreLengthDirectionRad | 当前长度（Length）方向备份，单位弧度rad
Public field | PrePositionMm | 当前中心点坐标备份，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | PreVelocityDirectionRad | 当前速度方向备份，单位弧度rad，值域[-PI, PI)
Public field | PreVelocityMmPs | 当前速度值备份，单位毫米每秒mm/s
Public field | VelocityDirectionRad | 当前速度方向，单位弧度rad，值域[-PI, PI)
Public field | VelocityMmPs | 当前速度值，单位毫米每秒mm/s
Public field | WidthMm | 宽度（**设置**），单位毫米

See Also

RectangularDynamic Class


AngularVelocityRadPs Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..AngularVelocityRadPs Field
RectangularDynamic Class See Also Send Feedback
当前角速度值，单位弧度每秒rad/s

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float AngularVelocityRadPs
Visual Basic
Public AngularVelocityRadPs As Single
Visual C++
public:
float AngularVelocityRadPs

See Also

RectangularDynamic Class


BorderWidthPix Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..BorderWidthPix Field
RectangularDynamic Class See Also Send Feedback
边框宽度，单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int BorderWidthPix
Visual Basic
Public BorderWidthPix As Integer
Visual C++
public:
int BorderWidthPix

See Also

RectangularDynamic Class


Collision Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..Collision Field
RectangularDynamic Class See Also Send Feedback
当前碰撞状态

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public CollisionType Collision
Visual Basic
Public Collision As CollisionType
Visual C++
public:
CollisionType Collision

See Also

RectangularDynamic Class


ColorBorder Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..ColorBorder Field
RectangularDynamic Class See Also Send Feedback
边框颜色

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Color ColorBorder
Visual Basic
Public ColorBorder As Color
Visual C++
public:
Color ColorBorder

See Also

RectangularDynamic Class


ColorFilled Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..ColorFilled Field
RectangularDynamic Class See Also Send Feedback
填充颜色

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Color ColorFilled
Visual Basic
Public ColorFilled As Color
Visual C++
public:
Color ColorFilled

See Also

RectangularDynamic Class


DirectionRad Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..DirectionRad Field
RectangularDynamic Class See Also Send Feedback
方向（**设置**），单位弧度

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float DirectionRad
Visual Basic
Public DirectionRad As Single
Visual C++
public:
float DirectionRad

See Also

RectangularDynamic Class


LengthDirectionRad Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..LengthDirectionRad Field
RectangularDynamic Class See Also Send Feedback
当前长度（Length）方向，单位弧度rad

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float LengthDirectionRad
Visual Basic
Public LengthDirectionRad As Single
Visual C++
public:
float LengthDirectionRad

See Also

RectangularDynamic Class


LengthMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..LengthMm Field
RectangularDynamic Class See Also Send Feedback
长度（**设置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int LengthMm
Visual Basic
Public LengthMm As Integer
Visual C++
public:
int LengthMm

See Also

RectangularDynamic Class


PositionMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..PositionMm Field
RectangularDynamic Class See Also Send Feedback
当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 PositionMm
Visual Basic
Public PositionMm As Vector3
Visual C++
public:
Vector3 PositionMm

See Also

RectangularDynamic Class


PreAngularVelocityRadPs Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..PreAngularVelocityRadPs Field
RectangularDynamic Class See Also Send Feedback
当前角速度值备份，单位弧度每秒rad/s

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float PreAngularVelocityRadPs
Visual Basic
Public PreAngularVelocityRadPs As Single
Visual C++
public:
float PreAngularVelocityRadPs

See Also

RectangularDynamic Class


PreCollision Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..PreCollision Field
RectangularDynamic Class See Also Send Feedback
当前碰撞状态备份

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public CollisionType PreCollision
Visual Basic
Public PreCollision As CollisionType
Visual C++
public:
CollisionType PreCollision

See Also

RectangularDynamic Class


PreLengthDirectionRad Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..PreLengthDirectionRad Field
RectangularDynamic Class See Also Send Feedback
当前长度（Length）方向备份，单位弧度rad

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float PreLengthDirectionRad
Visual Basic
Public PreLengthDirectionRad As Single
Visual C++
public:
float PreLengthDirectionRad

See Also

RectangularDynamic Class


PrePositionMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..PrePositionMm Field
RectangularDynamic Class See Also Send Feedback
当前中心点坐标备份，各维坐标单位毫米mm，2D版本中Y坐标固定为0

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 PrePositionMm
Visual Basic
Public PrePositionMm As Vector3
Visual C++
public:
Vector3 PrePositionMm

See Also

RectangularDynamic Class


PreVelocityDirectionRad Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..PreVelocityDirectionRad Field
RectangularDynamic Class See Also Send Feedback
当前速度方向备份，单位弧度rad，值域[-PI, PI)

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float PreVelocityDirectionRad
Visual Basic
Public PreVelocityDirectionRad As Single
Visual C++
public:
float PreVelocityDirectionRad

See Also

RectangularDynamic Class


PreVelocityMmPs Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..PreVelocityMmPs Field
RectangularDynamic Class See Also Send Feedback
当前速度值备份，单位毫米每秒mm/s

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float PreVelocityMmPs
Visual Basic
Public PreVelocityMmPs As Single
Visual C++
public:
float PreVelocityMmPs

See Also

RectangularDynamic Class


VelocityDirectionRad Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..VelocityDirectionRad Field
RectangularDynamic Class See Also Send Feedback
当前速度方向，单位弧度rad，值域[-PI, PI)

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float VelocityDirectionRad
Visual Basic
Public VelocityDirectionRad As Single
Visual C++
public:
float VelocityDirectionRad

See Also

RectangularDynamic Class


VelocityMmPs Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..VelocityMmPs Field
RectangularDynamic Class See Also Send Feedback
当前速度值，单位毫米每秒mm/s

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float VelocityMmPs
Visual Basic
Public VelocityMmPs As Single
Visual C++
public:
float VelocityMmPs

See Also

RectangularDynamic Class


WidthMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..WidthMm Field
RectangularDynamic Class See Also Send Feedback
宽度（**设置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int WidthMm
Visual Basic
Public WidthMm As Integer
Visual C++
public:
int WidthMm

See Also

RectangularDynamic Class


RectangularDynamic Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic Methods
RectangularDynamic Class See Also Send Feedback

The RectangularDynamic type exposes the following members.

Methods

 | Name | Description
Public method | Draw | 将当前对象绘制到GDI+绘图对象上
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SetRectangularDynamic | 设置默认参数
Public method | ToString | (Inherited from Object.)

See Also

RectangularDynamic Class


Draw Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..Draw Method
RectangularDynamic Class See Also Send Feedback
将当前对象绘制到GDI+绘图对象上

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void Draw(
    ref Graphics g
)
Visual Basic
Public Sub Draw ( _
    ByRef g As Graphics _
)
Visual C++
public:
void Draw(
    Graphics^% g
)

Parameters

g
Type: System.Drawing..::..Graphics %
来自与绘图容器PictureBox等尺寸的Bitmap的GDI+绘图对象

See Also

RectangularDynamic Class


SetRectangularDynamic Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularDynamic..::..SetRectangularDynamic Method
RectangularDynamic Class See Also Send Feedback
设置默认参数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void SetRectangularDynamic()
Visual Basic
Public Sub SetRectangularDynamic
Visual C++
public:
void SetRectangularDynamic()

See Also

RectangularDynamic Class


RectangularObstacle Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle Class
Members See Also Send Feedback
仿真方形静态障碍物类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class RectangularObstacle : RectangularStatic,
    ICloneable, IDssSerializable
Visual Basic
<SerializableAttribute> _
Public Class RectangularObstacle _
    Inherits RectangularStatic _
    Implements ICloneable, IDssSerializable
Visual C++
[SerializableAttribute]
public ref class RectangularObstacle : public RectangularStatic,
    ICloneable, IDssSerializable

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..RectangularStatic
URWPGSim2D.Common..::..RectangularObstacle

See Also

RectangularObstacle Members


RectangularObstacle Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle Members
RectangularObstacle Class Constructors Methods Fields See Also Send Feedback

The RectangularObstacle type exposes the following members.

Constructors

 | Name | Description
Public method | RectangularObstacle()()()() | 默认构造函数
Public method | RectangularObstacle(String, Vector3, Color, Int32, Int32, Single) | 带参数构造函数
Public method | RectangularObstacle(String, Vector3, Color, Color, Int32, Int32, Single) | 带参数构造函数
Public method | RectangularObstacle(String, Vector3, Color, Color, Int32, Int32, Int32, Single) | 带参数构造函数

Methods

 | Name | Description
Protected method | CalculateCollisionDetectionParas | 计算碰撞检测参数，由各继承类构造函数调用 (Inherited from RectangularStatic.)
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本 (Overrides RectangularStatic..::..Clone()()()().)
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象 (Overrides RectangularStatic..::..CopyTo(IDssSerializable).)
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象 (Overrides RectangularStatic..::..Deserialize(BinaryReader).)
Public method | Draw | 将当前对象绘制到GDI+绘图对象上 (Inherited from RectangularStatic.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象 (Overrides RectangularStatic..::..Serialize(BinaryWriter).)
Public method | SetRectangularStatic | 设置默认参数 (Inherited from RectangularStatic.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | BorderWidthPix | 边框宽度，单位像素 (Inherited from RectangularStatic.)
Public field | CircumcircleRadiusMm | 外接圆半径（**根据长度宽度计算**），单位毫米 (Inherited from RectangularStatic.)
Public field | ColorBorder | 边框颜色 (Inherited from RectangularStatic.)
Public field | ColorFilled | 填充颜色 (Inherited from RectangularStatic.)
Public field | DirectionRad | 方向（**设置**），单位弧度 (Inherited from RectangularStatic.)
Public field | LengthDirectionRad | 当前长度（Length）方向，单位弧度rad (Inherited from RectangularStatic.)
Public field | LengthMm | 长度（**设置**），单位毫米 (Inherited from RectangularStatic.)
Public field | Name | 名称
Public field | PolygonVertices | 矩形4个顶点列表，4个元素依次为左上/右上/右下/左下，各顶点各维坐标单位毫米 (Inherited from RectangularStatic.)
Public field | PositionMm | 当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0 (Inherited from RectangularStatic.)
Public field | WidthMm | 宽度（**设置**），单位毫米 (Inherited from RectangularStatic.)

See Also

RectangularObstacle Class


RectangularObstacle Constructor

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle Constructor
RectangularObstacle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RectangularObstacle()()()() | 默认构造函数
Public method | RectangularObstacle(String, Vector3, Color, Int32, Int32, Single) | 带参数构造函数
Public method | RectangularObstacle(String, Vector3, Color, Color, Int32, Int32, Single) | 带参数构造函数
Public method | RectangularObstacle(String, Vector3, Color, Color, Int32, Int32, Int32, Single) | 带参数构造函数

See Also

RectangularObstacle Class
RectangularObstacle Members


RectangularObstacle Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle Constructor
RectangularObstacle Class See Also Send Feedback
默认构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public RectangularObstacle()
Visual Basic
Public Sub New
Visual C++
public:
RectangularObstacle()

See Also

RectangularObstacle Class
RectangularObstacle Overload


RectangularObstacle Constructor (String, , Color, Int32, Int32, Single)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle Constructor (String, , Color, Int32, Int32, Single)
RectangularObstacle Class See Also Send Feedback
带参数构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public RectangularObstacle(
    string strName,
    Vector3 positionMm,
    Color color,
    int lengthMm,
    int widthMm,
    float directionDeg
)
Visual Basic
Public Sub New ( _
    strName As String, _
    positionMm As Vector3, _
    color As Color, _
    lengthMm As Integer, _
    widthMm As Integer, _
    directionDeg As Single _
)
Visual C++
public:
RectangularObstacle(
    String^ strName,
    Vector3 positionMm,
    Color color,
    int lengthMm,
    int widthMm,
    float directionDeg
)

Parameters

strName
Type: System..::..String
仿真方形障碍物名称
positionMm
Type: Vector3
仿真方形障碍物位置（在场地坐标系中，以毫米为单位）
color
Type: System.Drawing..::..Color
仿真方形障碍物颜色
lengthMm
Type: System..::..Int32
仿真方形障碍物长度（以毫米为单位）
widthMm
Type: System..::..Int32
仿真方形障碍物宽度（以毫米为单位）
directionDeg
Type: System..::..Single
仿真方形障碍物方向（在场地坐标系中，以弧度为单位）

See Also

RectangularObstacle Class
RectangularObstacle Overload


RectangularObstacle Constructor (String, , Color, Color, Int32, Int32, Single)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle Constructor (String, , Color, Color, Int32, Int32, Single)
RectangularObstacle Class See Also Send Feedback
带参数构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public RectangularObstacle(
    string strName,
    Vector3 positionMm,
    Color colorBorder,
    Color colorFilled,
    int lengthMm,
    int widthMm,
    float directionDeg
)
Visual Basic
Public Sub New ( _
    strName As String, _
    positionMm As Vector3, _
    colorBorder As Color, _
    colorFilled As Color, _
    lengthMm As Integer, _
    widthMm As Integer, _
    directionDeg As Single _
)
Visual C++
public:
RectangularObstacle(
    String^ strName,
    Vector3 positionMm,
    Color colorBorder,
    Color colorFilled,
    int lengthMm,
    int widthMm,
    float directionDeg
)

Parameters

strName
Type: System..::..String
仿真方形障碍物名称
positionMm
Type: Vector3
仿真方形障碍物位置（在场地坐标系中，以毫米为单位）
colorBorder
Type: System.Drawing..::..Color
仿真方形障碍物轮廓颜色
colorFilled
Type: System.Drawing..::..Color
仿真方形障碍物填充颜色
lengthMm
Type: System..::..Int32
仿真方形障碍物长度（以毫米为单位）
widthMm
Type: System..::..Int32
仿真方形障碍物宽度（以毫米为单位）
directionDeg
Type: System..::..Single
仿真方形障碍物方向（在场地坐标系中，以弧度为单位）

See Also

RectangularObstacle Class
RectangularObstacle Overload


RectangularObstacle Constructor (String, , Color, Color, Int32, Int32, Int32, Single)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle Constructor (String, , Color, Color, Int32, Int32, Int32, Single)
RectangularObstacle Class See Also Send Feedback
带参数构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public RectangularObstacle(
    string strName,
    Vector3 positionMm,
    Color colorBorder,
    Color colorFilled,
    int borderWithPix,
    int lengthMm,
    int widthMm,
    float directionDeg
)
Visual Basic
Public Sub New ( _
    strName As String, _
    positionMm As Vector3, _
    colorBorder As Color, _
    colorFilled As Color, _
    borderWithPix As Integer, _
    lengthMm As Integer, _
    widthMm As Integer, _
    directionDeg As Single _
)
Visual C++
public:
RectangularObstacle(
    String^ strName,
    Vector3 positionMm,
    Color colorBorder,
    Color colorFilled,
    int borderWithPix,
    int lengthMm,
    int widthMm,
    float directionDeg
)

Parameters

strName
Type: System..::..String
仿真方形障碍物名称
positionMm
Type: Vector3
仿真方形障碍物位置（在场地坐标系中，以毫米为单位）
colorBorder
Type: System.Drawing..::..Color
仿真方形障碍物轮廓颜色
colorFilled
Type: System.Drawing..::..Color
仿真方形障碍物填充颜色
borderWithPix
Type: System..::..Int32
仿真方形障碍物轮廓像素宽度
lengthMm
Type: System..::..Int32
仿真方形障碍物长度（以毫米为单位）
widthMm
Type: System..::..Int32
仿真方形障碍物宽度（以毫米为单位）
directionDeg
Type: System..::..Single
仿真方形障碍物方向（在场地坐标系中，以弧度为单位）

See Also

RectangularObstacle Class
RectangularObstacle Overload


RectangularObstacle Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle Fields
RectangularObstacle Class See Also Send Feedback

The RectangularObstacle type exposes the following members.

Fields

 | Name | Description
Public field | BorderWidthPix | 边框宽度，单位像素 (Inherited from RectangularStatic.)
Public field | CircumcircleRadiusMm | 外接圆半径（**根据长度宽度计算**），单位毫米 (Inherited from RectangularStatic.)
Public field | ColorBorder | 边框颜色 (Inherited from RectangularStatic.)
Public field | ColorFilled | 填充颜色 (Inherited from RectangularStatic.)
Public field | DirectionRad | 方向（**设置**），单位弧度 (Inherited from RectangularStatic.)
Public field | LengthDirectionRad | 当前长度（Length）方向，单位弧度rad (Inherited from RectangularStatic.)
Public field | LengthMm | 长度（**设置**），单位毫米 (Inherited from RectangularStatic.)
Public field | Name | 名称
Public field | PolygonVertices | 矩形4个顶点列表，4个元素依次为左上/右上/右下/左下，各顶点各维坐标单位毫米 (Inherited from RectangularStatic.)
Public field | PositionMm | 当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0 (Inherited from RectangularStatic.)
Public field | WidthMm | 宽度（**设置**），单位毫米 (Inherited from RectangularStatic.)

See Also

RectangularObstacle Class


Name Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle..::..Name Field
RectangularObstacle Class See Also Send Feedback
名称

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public string Name
Visual Basic
Public Name As String
Visual C++
public:
String^ Name

See Also

RectangularObstacle Class


RectangularObstacle Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle Methods
RectangularObstacle Class See Also Send Feedback

The RectangularObstacle type exposes the following members.

Methods

 | Name | Description
Protected method | CalculateCollisionDetectionParas | 计算碰撞检测参数，由各继承类构造函数调用 (Inherited from RectangularStatic.)
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本 (Overrides RectangularStatic..::..Clone()()()().)
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象 (Overrides RectangularStatic..::..CopyTo(IDssSerializable).)
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象 (Overrides RectangularStatic..::..Deserialize(BinaryReader).)
Public method | Draw | 将当前对象绘制到GDI+绘图对象上 (Inherited from RectangularStatic.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象 (Overrides RectangularStatic..::..Serialize(BinaryWriter).)
Public method | SetRectangularStatic | 设置默认参数 (Inherited from RectangularStatic.)
Public method | ToString | (Inherited from Object.)

See Also

RectangularObstacle Class


Clone Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle..::..Clone Method
RectangularObstacle Class See Also Send Feedback
实现Clone接口的方法，拷贝一份当前对象的副本

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

当前对象的副本

Implements

ICloneable..::..Clone()()()()
IDssSerializableClone()()()()
ICloneable..::..Clone()()()()
IDssSerializableClone()()()()

See Also

RectangularObstacle Class


CopyTo Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle..::..CopyTo Method
RectangularObstacle Class See Also Send Feedback
实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override void CopyTo(
    IDssSerializable target
)
Visual Basic
Public Overrides Sub CopyTo ( _
    target As IDssSerializable _
)
Visual C++
public:
virtual void CopyTo(
    IDssSerializable^ target
) override

Parameters

target
Type: IDssSerializable
当前对象拷贝到的目标对象

Implements

IDssSerializableCopyTo(IDssSerializable)
IDssSerializableCopyTo(IDssSerializable)

See Also

RectangularObstacle Class


Deserialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle..::..Deserialize Method
RectangularObstacle Class See Also Send Feedback
实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override Object Deserialize(
    BinaryReader reader
)
Visual Basic
Public Overrides Function Deserialize ( _
    reader As BinaryReader _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    BinaryReader^ reader
) override

Parameters

reader
Type: System.IO..::..BinaryReader
反序列化操作的来源对象

Return Value

反序列化得到的当前类型对象

Implements

IDssSerializableDeserialize(BinaryReader)
IDssSerializableDeserialize(BinaryReader)

See Also

RectangularObstacle Class


Serialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularObstacle..::..Serialize Method
RectangularObstacle Class See Also Send Feedback
实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override void Serialize(
    BinaryWriter writer
)
Visual Basic
Public Overrides Sub Serialize ( _
    writer As BinaryWriter _
)
Visual C++
public:
virtual void Serialize(
    BinaryWriter^ writer
) override

Parameters

writer
Type: System.IO..::..BinaryWriter
当前对象序列化到的目标对象

Implements

IDssSerializableSerialize(BinaryWriter)
IDssSerializableSerialize(BinaryWriter)

See Also

RectangularObstacle Class


RectangularStatic Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic Class
Members See Also Send Feedback
仿真场地中方形静态对象基类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class RectangularStatic : ICloneable,
    IDssSerializable
Visual Basic
<SerializableAttribute> _
Public Class RectangularStatic _
    Implements ICloneable, IDssSerializable
Visual C++
[SerializableAttribute]
public ref class RectangularStatic : ICloneable,
    IDssSerializable

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..RectangularStatic
URWPGSim2D.Common..::..Channel
URWPGSim2D.Common..::..RectangularObstacle

See Also

RectangularStatic Members


RectangularStatic Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic Members
RectangularStatic Class Constructors Methods Fields See Also Send Feedback

The RectangularStatic type exposes the following members.

Constructors

 | Name | Description
Public method | RectangularStatic | 构造函数

Methods

 | Name | Description
Protected method | CalculateCollisionDetectionParas | 计算碰撞检测参数，由各继承类构造函数调用
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Draw | 将当前对象绘制到GDI+绘图对象上
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | SetRectangularStatic | 设置默认参数
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | BorderWidthPix | 边框宽度，单位像素
Public field | CircumcircleRadiusMm | 外接圆半径（**根据长度宽度计算**），单位毫米
Public field | ColorBorder | 边框颜色
Public field | ColorFilled | 填充颜色
Public field | DirectionRad | 方向（**设置**），单位弧度
Public field | LengthDirectionRad | 当前长度（Length）方向，单位弧度rad
Public field | LengthMm | 长度（**设置**），单位毫米
Public field | PolygonVertices | 矩形4个顶点列表，4个元素依次为左上/右上/右下/左下，各顶点各维坐标单位毫米
Public field | PositionMm | 当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | WidthMm | 宽度（**设置**），单位毫米

See Also

RectangularStatic Class


RectangularStatic Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic Constructor
RectangularStatic Class See Also Send Feedback
构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public RectangularStatic()
Visual Basic
Public Sub New
Visual C++
public:
RectangularStatic()

See Also

RectangularStatic Class


RectangularStatic Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic Fields
RectangularStatic Class See Also Send Feedback

The RectangularStatic type exposes the following members.

Fields

 | Name | Description
Public field | BorderWidthPix | 边框宽度，单位像素
Public field | CircumcircleRadiusMm | 外接圆半径（**根据长度宽度计算**），单位毫米
Public field | ColorBorder | 边框颜色
Public field | ColorFilled | 填充颜色
Public field | DirectionRad | 方向（**设置**），单位弧度
Public field | LengthDirectionRad | 当前长度（Length）方向，单位弧度rad
Public field | LengthMm | 长度（**设置**），单位毫米
Public field | PolygonVertices | 矩形4个顶点列表，4个元素依次为左上/右上/右下/左下，各顶点各维坐标单位毫米
Public field | PositionMm | 当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | WidthMm | 宽度（**设置**），单位毫米

See Also

RectangularStatic Class


BorderWidthPix Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..BorderWidthPix Field
RectangularStatic Class See Also Send Feedback
边框宽度，单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int BorderWidthPix
Visual Basic
Public BorderWidthPix As Integer
Visual C++
public:
int BorderWidthPix

See Also

RectangularStatic Class


CircumcircleRadiusMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..CircumcircleRadiusMm Field
RectangularStatic Class See Also Send Feedback
外接圆半径（**根据长度宽度计算**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int CircumcircleRadiusMm
Visual Basic
Public CircumcircleRadiusMm As Integer
Visual C++
public:
int CircumcircleRadiusMm

See Also

RectangularStatic Class


ColorBorder Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..ColorBorder Field
RectangularStatic Class See Also Send Feedback
边框颜色

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Color ColorBorder
Visual Basic
Public ColorBorder As Color
Visual C++
public:
Color ColorBorder

See Also

RectangularStatic Class


ColorFilled Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..ColorFilled Field
RectangularStatic Class See Also Send Feedback
填充颜色

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Color ColorFilled
Visual Basic
Public ColorFilled As Color
Visual C++
public:
Color ColorFilled

See Also

RectangularStatic Class


DirectionRad Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..DirectionRad Field
RectangularStatic Class See Also Send Feedback
方向（**设置**），单位弧度

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float DirectionRad
Visual Basic
Public DirectionRad As Single
Visual C++
public:
float DirectionRad

See Also

RectangularStatic Class


LengthDirectionRad Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..LengthDirectionRad Field
RectangularStatic Class See Also Send Feedback
当前长度（Length）方向，单位弧度rad

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float LengthDirectionRad
Visual Basic
Public LengthDirectionRad As Single
Visual C++
public:
float LengthDirectionRad

See Also

RectangularStatic Class


LengthMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..LengthMm Field
RectangularStatic Class See Also Send Feedback
长度（**设置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int LengthMm
Visual Basic
Public LengthMm As Integer
Visual C++
public:
int LengthMm

See Also

RectangularStatic Class


PolygonVertices Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..PolygonVertices Field
RectangularStatic Class See Also Send Feedback
矩形4个顶点列表，4个元素依次为左上/右上/右下/左下，各顶点各维坐标单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> PolygonVertices
Visual Basic
Public PolygonVertices As List(Of Vector3)
Visual C++
public:
List<Vector3>^ PolygonVertices

See Also

RectangularStatic Class


PositionMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..PositionMm Field
RectangularStatic Class See Also Send Feedback
当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 PositionMm
Visual Basic
Public PositionMm As Vector3
Visual C++
public:
Vector3 PositionMm

See Also

RectangularStatic Class


WidthMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..WidthMm Field
RectangularStatic Class See Also Send Feedback
宽度（**设置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int WidthMm
Visual Basic
Public WidthMm As Integer
Visual C++
public:
int WidthMm

See Also

RectangularStatic Class


RectangularStatic Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic Methods
RectangularStatic Class See Also Send Feedback

The RectangularStatic type exposes the following members.

Methods

 | Name | Description
Protected method | CalculateCollisionDetectionParas | 计算碰撞检测参数，由各继承类构造函数调用
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Draw | 将当前对象绘制到GDI+绘图对象上
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | SetRectangularStatic | 设置默认参数
Public method | ToString | (Inherited from Object.)

See Also

RectangularStatic Class


CalculateCollisionDetectionParas Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..CalculateCollisionDetectionParas Method
RectangularStatic Class See Also Send Feedback
计算碰撞检测参数，由各继承类构造函数调用

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
protected void CalculateCollisionDetectionParas()
Visual Basic
Protected Sub CalculateCollisionDetectionParas
Visual C++
protected:
void CalculateCollisionDetectionParas()

See Also

RectangularStatic Class


Clone Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..Clone Method
RectangularStatic Class See Also Send Feedback
实现Clone接口的方法，拷贝一份当前对象的副本

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

当前对象的副本

Implements

ICloneable..::..Clone()()()()
IDssSerializableClone()()()()

See Also

RectangularStatic Class


CopyTo Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..CopyTo Method
RectangularStatic Class See Also Send Feedback
实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void CopyTo(
    IDssSerializable target
)
Visual Basic
Public Overridable Sub CopyTo ( _
    target As IDssSerializable _
)
Visual C++
public:
virtual void CopyTo(
    IDssSerializable^ target
)

Parameters

target
Type: IDssSerializable
当前对象拷贝到的目标对象

Implements

IDssSerializableCopyTo(IDssSerializable)

See Also

RectangularStatic Class


Deserialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..Deserialize Method
RectangularStatic Class See Also Send Feedback
实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Deserialize(
    BinaryReader reader
)
Visual Basic
Public Overridable Function Deserialize ( _
    reader As BinaryReader _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IO..::..BinaryReader
反序列化操作的来源对象

Return Value

反序列化得到的当前类型对象

Implements

IDssSerializableDeserialize(BinaryReader)

See Also

RectangularStatic Class


Draw Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..Draw Method
RectangularStatic Class See Also Send Feedback
将当前对象绘制到GDI+绘图对象上

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void Draw(
    ref Graphics g
)
Visual Basic
Public Sub Draw ( _
    ByRef g As Graphics _
)
Visual C++
public:
void Draw(
    Graphics^% g
)

Parameters

g
Type: System.Drawing..::..Graphics %
来自与绘图容器PictureBox等尺寸的Bitmap的GDI+绘图对象

See Also

RectangularStatic Class


Serialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..Serialize Method
RectangularStatic Class See Also Send Feedback
实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void Serialize(
    BinaryWriter writer
)
Visual Basic
Public Overridable Sub Serialize ( _
    writer As BinaryWriter _
)
Visual C++
public:
virtual void Serialize(
    BinaryWriter^ writer
)

Parameters

writer
Type: System.IO..::..BinaryWriter
当前对象序列化到的目标对象

Implements

IDssSerializableSerialize(BinaryWriter)

See Also

RectangularStatic Class


SetRectangularStatic Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RectangularStatic..::..SetRectangularStatic Method
RectangularStatic Class See Also Send Feedback
设置默认参数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void SetRectangularStatic()
Visual Basic
Public Sub SetRectangularStatic
Visual C++
public:
void SetRectangularStatic()

See Also

RectangularStatic Class


RoboFish Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish Class
Members See Also Send Feedback
仿真机器鱼基类，所有具体使命（比赛或实验项目）使用的仿真机器鱼类必须继承该类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class RoboFish : IRoboFish, ICloneable,
    IDssSerializable
Visual Basic
<SerializableAttribute> _
Public Class RoboFish _
    Implements IRoboFish, ICloneable, IDssSerializable
Visual C++
[SerializableAttribute]
public ref class RoboFish : IRoboFish,
    ICloneable, IDssSerializable

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..RoboFish

See Also

RoboFish Members


RoboFish Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish Members
RoboFish Class Constructors Methods Fields See Also Send Feedback

The RoboFish type exposes the following members.

Constructors

 | Name | Description
Public method | RoboFish | 构造函数

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Draw | 将当前仿真机器鱼绘制到GDI+绘图对象上
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | fishPostionCalculate | 鱼各个点的更新计算方法 added by Chen Wei 20110307 仿真使命（比赛或实验项目）是否正在运行即机器鱼是否正在游动仿真使命（比赛或实验项目）是否暂停即机器鱼是否正在游动仿真机器鱼尾部关节的初始相位仿真机器鱼对象
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RecoveryPose | 恢复所处半场 用于仿真机器鱼所属队伍位于右半场时绘制/碰撞检测/向客户端或策略传递参数后的处理
Public method | ResetSomeLocomotionPara | 重置仿真机器鱼的部分运动学参数，用于重新初始化使命清除上一次运行结束时保存的值
Public method | ReversePose | 对调所处半场，即将位置坐标和鱼体方向取反 用于仿真机器鱼所属队伍位于右半场时绘制/碰撞检测/向客户端或策略传递参数前的处理
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | SetFish | 从配置文件中读取可配置参数并计算出需要计算的参数
Public method | ToString | (Inherited from Object.)
Public method | UpdatePose | 根据仿真周期毫秒数更新仿真机器鱼位姿
Public method | UpdateVelocityAndAngularVelocity | 根据仿真周期毫秒数更新仿真机器鱼速度值速度方向和角速度值

Fields

 | Name | Description
Public field | AngularVelocityRadPs | 当前角速度值，单位弧度每秒rad/s
Public field | BodyDirectionRad | 当前鱼体方向，单位弧度rad，值域[-PI, PI)
Public field | BodyLength | 鱼体前端刚体长度（**配置**），单位毫米
Public field | BodyPolygonVertices | 鱼体碰撞检测BV树叶结点，鱼体躯干部分五边形顶点列表，五个顶点顺序分别为头部左边点、头部顶点、头部右边点、右下边点、左下边点
Public field | BodyWidth | 鱼体前端刚体宽度（**配置**），单位毫米
Public field | Collision | 当前碰撞状态
Public field | CollisionModelBodyCenterPositionMm | 鱼体碰撞检测BV树第二层子结点，鱼刚体部分圆形模型的圆心，各维坐标单位毫米
Public field | CollisionModelBodyRadiusMm | 鱼体碰撞检测BV树第二层子结点，鱼刚体部分圆形模型的半径，单位毫米
Public field | CollisionModelCenterPositionMm | 鱼体碰撞检测BV树根结点，鱼圆形模型的圆心，各维坐标单位毫米
Public field | CollisionModelRadiusMm | 鱼体碰撞检测BV树根结点，鱼圆形模型半径（**待求**），单位毫米
Public field | CollisionModelTailCenterPositionMm | 鱼体碰撞检测BV树第二层子结点，鱼尾部圆形模型的圆心，各维坐标单位毫米
Public field | CollisionModelTailRadiusMm | 鱼体碰撞检测BV树第二层子结点，鱼尾部圆形模型半径，单位毫米
Public field | ColorBack | 后方色标（队员标识）颜色
Public field | ColorFront | 前方色标（队伍标识）颜色
Public field | CountDrawing | 仿真机器鱼绘制次数计数（Draw()方法中用）
Public field | FishBodyRadiusMm | 仿真机器鱼前端矩形部分外接圆半径，用于界面选中仿真机器鱼处理过程，单位毫米
Public field | InitPhase | 尾部三个关节正弦摆动公式的初始调节相位值
Public field | LeftPectoralPolygonVertices | 鱼体碰撞检测BV树叶结点，左胸鳍三角形顶点列表，三个顶点顺序分别为胸鳍最左边点，下边点，上边点
Public field | PolygonVertices | 鱼体碰撞检测内层模型四边形的4个顶点列表，4个元素依次为头部/右胸鳍/尾部/左胸鳍顶点，各顶点各维坐标单位毫米
Public field | PositionMm | 当前绘图中心（鱼头刚体部分矩形中心）坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | PreAngularVelocityRadPs | 当前角速度值备份，单位弧度每秒rad/s
Public field | PreBodyDirectionRad | 当前鱼体方向备份，单位弧度rad，值域[-PI, PI)
Public field | PreCollision | 当前碰撞状态备份
Public field | PrePositionMm | 当前绘图中心（鱼头刚体部分矩形中心）坐标备份，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | PreTactic | 当前决策数据值备份，每周期运动学计算完毕后使用目标决策数据值更新
Public field | PreVelocityDirectionRad | 当前速度方向备份，单位弧度rad，值域(-PI, PI]
Public field | PreVelocityMmPs | 当前速度值备份，单位毫米每秒mm/s
Public field | RightPectoralPolygonVertices | 鱼体碰撞检测BV树叶结点，右胸鳍三角形顶点列表，三个顶点顺序分别为胸鳍最右边点，下边点，上边点
Public field | Tactic | 当前决策数据值，每周期运动学计算完毕后根据条件决定是否更新
Public field | Tail1PolygonVertices | 鱼体碰撞检测BV树叶结点，第一关节四边形顶点列表，四个顶点顺序分别为左上边点、右上边点、右下边点、左下边点
Public field | Tail2PolygonVertices | 鱼体碰撞检测BV树叶结点，第二关节四边形顶点列表，四个顶点顺序分别为左上边点、右上边点、右下边点、左下边点
Public field | Tail3PolygonVertices | 鱼体碰撞检测BV树叶结点，第三关节四边形顶点列表，四个顶点顺序分别为左上边点、右上边点、右下边点、左下边点
Public field | TailJointLength1 | 尾部第一个关节长度（**配置**），单位毫米
Public field | TailJointLength2 | 尾部第二个关节长度（**配置**），单位毫米
Public field | TailJointLength3 | 尾部第三个关节长度（**配置**），单位毫米
Public field | TailToBodyAngle1 | 尾部第一个关节相对鱼体的角度（**实时计算**），单位弧度
Public field | TailToBodyAngle2 | 尾部第二个关节相对鱼体的角度（**实时计算**），单位弧度
Public field | TailToBodyAngle3 | 尾部第三个关节相对鱼体的角度（**实时计算**），单位弧度
Public field | TargetTactic | 目标决策数据值，由高层策略计算后给出
Public field | TrajectoryPoints | 仿真机器鱼绘制轨迹用的点列表
Public field | VelocityDirectionRad | 当前速度方向，单位弧度rad，值域(-PI, PI]
Public field | VelocityMmPs | 当前速度值，单位毫米每秒mm/s

See Also

RoboFish Class


RoboFish Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish Constructor
RoboFish Class See Also Send Feedback
构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public RoboFish()
Visual Basic
Public Sub New
Visual C++
public:
RoboFish()

See Also

RoboFish Class


RoboFish Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish Fields
RoboFish Class See Also Send Feedback

The RoboFish type exposes the following members.

Fields

 | Name | Description
Public field | AngularVelocityRadPs | 当前角速度值，单位弧度每秒rad/s
Public field | BodyDirectionRad | 当前鱼体方向，单位弧度rad，值域[-PI, PI)
Public field | BodyLength | 鱼体前端刚体长度（**配置**），单位毫米
Public field | BodyPolygonVertices | 鱼体碰撞检测BV树叶结点，鱼体躯干部分五边形顶点列表，五个顶点顺序分别为头部左边点、头部顶点、头部右边点、右下边点、左下边点
Public field | BodyWidth | 鱼体前端刚体宽度（**配置**），单位毫米
Public field | Collision | 当前碰撞状态
Public field | CollisionModelBodyCenterPositionMm | 鱼体碰撞检测BV树第二层子结点，鱼刚体部分圆形模型的圆心，各维坐标单位毫米
Public field | CollisionModelBodyRadiusMm | 鱼体碰撞检测BV树第二层子结点，鱼刚体部分圆形模型的半径，单位毫米
Public field | CollisionModelCenterPositionMm | 鱼体碰撞检测BV树根结点，鱼圆形模型的圆心，各维坐标单位毫米
Public field | CollisionModelRadiusMm | 鱼体碰撞检测BV树根结点，鱼圆形模型半径（**待求**），单位毫米
Public field | CollisionModelTailCenterPositionMm | 鱼体碰撞检测BV树第二层子结点，鱼尾部圆形模型的圆心，各维坐标单位毫米
Public field | CollisionModelTailRadiusMm | 鱼体碰撞检测BV树第二层子结点，鱼尾部圆形模型半径，单位毫米
Public field | ColorBack | 后方色标（队员标识）颜色
Public field | ColorFront | 前方色标（队伍标识）颜色
Public field | CountDrawing | 仿真机器鱼绘制次数计数（Draw()方法中用）
Public field | FishBodyRadiusMm | 仿真机器鱼前端矩形部分外接圆半径，用于界面选中仿真机器鱼处理过程，单位毫米
Public field | InitPhase | 尾部三个关节正弦摆动公式的初始调节相位值
Public field | LeftPectoralPolygonVertices | 鱼体碰撞检测BV树叶结点，左胸鳍三角形顶点列表，三个顶点顺序分别为胸鳍最左边点，下边点，上边点
Public field | PolygonVertices | 鱼体碰撞检测内层模型四边形的4个顶点列表，4个元素依次为头部/右胸鳍/尾部/左胸鳍顶点，各顶点各维坐标单位毫米
Public field | PositionMm | 当前绘图中心（鱼头刚体部分矩形中心）坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | PreAngularVelocityRadPs | 当前角速度值备份，单位弧度每秒rad/s
Public field | PreBodyDirectionRad | 当前鱼体方向备份，单位弧度rad，值域[-PI, PI)
Public field | PreCollision | 当前碰撞状态备份
Public field | PrePositionMm | 当前绘图中心（鱼头刚体部分矩形中心）坐标备份，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | PreTactic | 当前决策数据值备份，每周期运动学计算完毕后使用目标决策数据值更新
Public field | PreVelocityDirectionRad | 当前速度方向备份，单位弧度rad，值域(-PI, PI]
Public field | PreVelocityMmPs | 当前速度值备份，单位毫米每秒mm/s
Public field | RightPectoralPolygonVertices | 鱼体碰撞检测BV树叶结点，右胸鳍三角形顶点列表，三个顶点顺序分别为胸鳍最右边点，下边点，上边点
Public field | Tactic | 当前决策数据值，每周期运动学计算完毕后根据条件决定是否更新
Public field | Tail1PolygonVertices | 鱼体碰撞检测BV树叶结点，第一关节四边形顶点列表，四个顶点顺序分别为左上边点、右上边点、右下边点、左下边点
Public field | Tail2PolygonVertices | 鱼体碰撞检测BV树叶结点，第二关节四边形顶点列表，四个顶点顺序分别为左上边点、右上边点、右下边点、左下边点
Public field | Tail3PolygonVertices | 鱼体碰撞检测BV树叶结点，第三关节四边形顶点列表，四个顶点顺序分别为左上边点、右上边点、右下边点、左下边点
Public field | TailJointLength1 | 尾部第一个关节长度（**配置**），单位毫米
Public field | TailJointLength2 | 尾部第二个关节长度（**配置**），单位毫米
Public field | TailJointLength3 | 尾部第三个关节长度（**配置**），单位毫米
Public field | TailToBodyAngle1 | 尾部第一个关节相对鱼体的角度（**实时计算**），单位弧度
Public field | TailToBodyAngle2 | 尾部第二个关节相对鱼体的角度（**实时计算**），单位弧度
Public field | TailToBodyAngle3 | 尾部第三个关节相对鱼体的角度（**实时计算**），单位弧度
Public field | TargetTactic | 目标决策数据值，由高层策略计算后给出
Public field | TrajectoryPoints | 仿真机器鱼绘制轨迹用的点列表
Public field | VelocityDirectionRad | 当前速度方向，单位弧度rad，值域(-PI, PI]
Public field | VelocityMmPs | 当前速度值，单位毫米每秒mm/s

See Also

RoboFish Class


AngularVelocityRadPs Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..AngularVelocityRadPs Field
RoboFish Class See Also Send Feedback
当前角速度值，单位弧度每秒rad/s

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float AngularVelocityRadPs
Visual Basic
Public AngularVelocityRadPs As Single
Visual C++
public:
float AngularVelocityRadPs

See Also

RoboFish Class


BodyDirectionRad Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..BodyDirectionRad Field
RoboFish Class See Also Send Feedback
当前鱼体方向，单位弧度rad，值域[-PI, PI)

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float BodyDirectionRad
Visual Basic
Public BodyDirectionRad As Single
Visual C++
public:
float BodyDirectionRad

See Also

RoboFish Class


BodyLength Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..BodyLength Field
RoboFish Class See Also Send Feedback
鱼体前端刚体长度（**配置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int BodyLength
Visual Basic
Public BodyLength As Integer
Visual C++
public:
int BodyLength

See Also

RoboFish Class


BodyPolygonVertices Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..BodyPolygonVertices Field
RoboFish Class See Also Send Feedback
鱼体碰撞检测BV树叶结点，鱼体躯干部分五边形顶点列表，五个顶点顺序分别为头部左边点、头部顶点、头部右边点、右下边点、左下边点

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> BodyPolygonVertices
Visual Basic
Public BodyPolygonVertices As List(Of Vector3)
Visual C++
public:
List<Vector3>^ BodyPolygonVertices

See Also

RoboFish Class


BodyWidth Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..BodyWidth Field
RoboFish Class See Also Send Feedback
鱼体前端刚体宽度（**配置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int BodyWidth
Visual Basic
Public BodyWidth As Integer
Visual C++
public:
int BodyWidth

See Also

RoboFish Class


Collision Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..Collision Field
RoboFish Class See Also Send Feedback
当前碰撞状态

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public CollisionType Collision
Visual Basic
Public Collision As CollisionType
Visual C++
public:
CollisionType Collision

See Also

RoboFish Class


CollisionModelBodyCenterPositionMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..CollisionModelBodyCenterPositionMm Field
RoboFish Class See Also Send Feedback
鱼体碰撞检测BV树第二层子结点，鱼刚体部分圆形模型的圆心，各维坐标单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 CollisionModelBodyCenterPositionMm
Visual Basic
Public CollisionModelBodyCenterPositionMm As Vector3
Visual C++
public:
Vector3 CollisionModelBodyCenterPositionMm

See Also

RoboFish Class


CollisionModelBodyRadiusMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..CollisionModelBodyRadiusMm Field
RoboFish Class See Also Send Feedback
鱼体碰撞检测BV树第二层子结点，鱼刚体部分圆形模型的半径，单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int CollisionModelBodyRadiusMm
Visual Basic
Public CollisionModelBodyRadiusMm As Integer
Visual C++
public:
int CollisionModelBodyRadiusMm

See Also

RoboFish Class


CollisionModelCenterPositionMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..CollisionModelCenterPositionMm Field
RoboFish Class See Also Send Feedback
鱼体碰撞检测BV树根结点，鱼圆形模型的圆心，各维坐标单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 CollisionModelCenterPositionMm
Visual Basic
Public CollisionModelCenterPositionMm As Vector3
Visual C++
public:
Vector3 CollisionModelCenterPositionMm

See Also

RoboFish Class


CollisionModelRadiusMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..CollisionModelRadiusMm Field
RoboFish Class See Also Send Feedback
鱼体碰撞检测BV树根结点，鱼圆形模型半径（**待求**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int CollisionModelRadiusMm
Visual Basic
Public CollisionModelRadiusMm As Integer
Visual C++
public:
int CollisionModelRadiusMm

See Also

RoboFish Class


CollisionModelTailCenterPositionMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..CollisionModelTailCenterPositionMm Field
RoboFish Class See Also Send Feedback
鱼体碰撞检测BV树第二层子结点，鱼尾部圆形模型的圆心，各维坐标单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 CollisionModelTailCenterPositionMm
Visual Basic
Public CollisionModelTailCenterPositionMm As Vector3
Visual C++
public:
Vector3 CollisionModelTailCenterPositionMm

See Also

RoboFish Class


CollisionModelTailRadiusMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..CollisionModelTailRadiusMm Field
RoboFish Class See Also Send Feedback
鱼体碰撞检测BV树第二层子结点，鱼尾部圆形模型半径，单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int CollisionModelTailRadiusMm
Visual Basic
Public CollisionModelTailRadiusMm As Integer
Visual C++
public:
int CollisionModelTailRadiusMm

See Also

RoboFish Class


ColorBack Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..ColorBack Field
RoboFish Class See Also Send Feedback
后方色标（队员标识）颜色

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Color ColorBack
Visual Basic
Public ColorBack As Color
Visual C++
public:
Color ColorBack

See Also

RoboFish Class


ColorFront Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..ColorFront Field
RoboFish Class See Also Send Feedback
前方色标（队伍标识）颜色

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Color ColorFront
Visual Basic
Public ColorFront As Color
Visual C++
public:
Color ColorFront

See Also

RoboFish Class


CountDrawing Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..CountDrawing Field
RoboFish Class See Also Send Feedback
仿真机器鱼绘制次数计数（Draw()方法中用）

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int CountDrawing
Visual Basic
Public CountDrawing As Integer
Visual C++
public:
int CountDrawing

See Also

RoboFish Class


FishBodyRadiusMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..FishBodyRadiusMm Field
RoboFish Class See Also Send Feedback
仿真机器鱼前端矩形部分外接圆半径，用于界面选中仿真机器鱼处理过程，单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FishBodyRadiusMm
Visual Basic
Public FishBodyRadiusMm As Integer
Visual C++
public:
int FishBodyRadiusMm

See Also

RoboFish Class


InitPhase Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..InitPhase Field
RoboFish Class See Also Send Feedback
尾部三个关节正弦摆动公式的初始调节相位值

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float InitPhase
Visual Basic
Public InitPhase As Single
Visual C++
public:
float InitPhase

See Also

RoboFish Class


LeftPectoralPolygonVertices Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..LeftPectoralPolygonVertices Field
RoboFish Class See Also Send Feedback
鱼体碰撞检测BV树叶结点，左胸鳍三角形顶点列表，三个顶点顺序分别为胸鳍最左边点，下边点，上边点

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> LeftPectoralPolygonVertices
Visual Basic
Public LeftPectoralPolygonVertices As List(Of Vector3)
Visual C++
public:
List<Vector3>^ LeftPectoralPolygonVertices

See Also

RoboFish Class


PolygonVertices Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..PolygonVertices Field
RoboFish Class See Also Send Feedback
鱼体碰撞检测内层模型四边形的4个顶点列表，4个元素依次为头部/右胸鳍/尾部/左胸鳍顶点，各顶点各维坐标单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> PolygonVertices
Visual Basic
Public PolygonVertices As List(Of Vector3)
Visual C++
public:
List<Vector3>^ PolygonVertices

See Also

RoboFish Class


PositionMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..PositionMm Field
RoboFish Class See Also Send Feedback
当前绘图中心（鱼头刚体部分矩形中心）坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 PositionMm
Visual Basic
Public PositionMm As Vector3
Visual C++
public:
Vector3 PositionMm

See Also

RoboFish Class


PreAngularVelocityRadPs Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..PreAngularVelocityRadPs Field
RoboFish Class See Also Send Feedback
当前角速度值备份，单位弧度每秒rad/s

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float PreAngularVelocityRadPs
Visual Basic
Public PreAngularVelocityRadPs As Single
Visual C++
public:
float PreAngularVelocityRadPs

See Also

RoboFish Class


PreBodyDirectionRad Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..PreBodyDirectionRad Field
RoboFish Class See Also Send Feedback
当前鱼体方向备份，单位弧度rad，值域[-PI, PI)

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float PreBodyDirectionRad
Visual Basic
Public PreBodyDirectionRad As Single
Visual C++
public:
float PreBodyDirectionRad

See Also

RoboFish Class


PreCollision Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..PreCollision Field
RoboFish Class See Also Send Feedback
当前碰撞状态备份

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public CollisionType PreCollision
Visual Basic
Public PreCollision As CollisionType
Visual C++
public:
CollisionType PreCollision

See Also

RoboFish Class


PrePositionMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..PrePositionMm Field
RoboFish Class See Also Send Feedback
当前绘图中心（鱼头刚体部分矩形中心）坐标备份，各维坐标单位毫米mm，2D版本中Y坐标固定为0

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 PrePositionMm
Visual Basic
Public PrePositionMm As Vector3
Visual C++
public:
Vector3 PrePositionMm

See Also

RoboFish Class


PreTactic Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..PreTactic Field
RoboFish Class See Also Send Feedback
当前决策数据值备份，每周期运动学计算完毕后使用目标决策数据值更新

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Decision PreTactic
Visual Basic
Public PreTactic As Decision
Visual C++
public:
Decision PreTactic

See Also

RoboFish Class


PreVelocityDirectionRad Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..PreVelocityDirectionRad Field
RoboFish Class See Also Send Feedback
当前速度方向备份，单位弧度rad，值域(-PI, PI]

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float PreVelocityDirectionRad
Visual Basic
Public PreVelocityDirectionRad As Single
Visual C++
public:
float PreVelocityDirectionRad

See Also

RoboFish Class


PreVelocityMmPs Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..PreVelocityMmPs Field
RoboFish Class See Also Send Feedback
当前速度值备份，单位毫米每秒mm/s

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float PreVelocityMmPs
Visual Basic
Public PreVelocityMmPs As Single
Visual C++
public:
float PreVelocityMmPs

See Also

RoboFish Class


RightPectoralPolygonVertices Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..RightPectoralPolygonVertices Field
RoboFish Class See Also Send Feedback
鱼体碰撞检测BV树叶结点，右胸鳍三角形顶点列表，三个顶点顺序分别为胸鳍最右边点，下边点，上边点

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> RightPectoralPolygonVertices
Visual Basic
Public RightPectoralPolygonVertices As List(Of Vector3)
Visual C++
public:
List<Vector3>^ RightPectoralPolygonVertices

See Also

RoboFish Class


Tactic Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..Tactic Field
RoboFish Class See Also Send Feedback
当前决策数据值，每周期运动学计算完毕后根据条件决定是否更新

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Decision Tactic
Visual Basic
Public Tactic As Decision
Visual C++
public:
Decision Tactic

See Also

RoboFish Class


Tail1PolygonVertices Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..Tail1PolygonVertices Field
RoboFish Class See Also Send Feedback
鱼体碰撞检测BV树叶结点，第一关节四边形顶点列表，四个顶点顺序分别为左上边点、右上边点、右下边点、左下边点

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> Tail1PolygonVertices
Visual Basic
Public Tail1PolygonVertices As List(Of Vector3)
Visual C++
public:
List<Vector3>^ Tail1PolygonVertices

See Also

RoboFish Class


Tail2PolygonVertices Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..Tail2PolygonVertices Field
RoboFish Class See Also Send Feedback
鱼体碰撞检测BV树叶结点，第二关节四边形顶点列表，四个顶点顺序分别为左上边点、右上边点、右下边点、左下边点

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> Tail2PolygonVertices
Visual Basic
Public Tail2PolygonVertices As List(Of Vector3)
Visual C++
public:
List<Vector3>^ Tail2PolygonVertices

See Also

RoboFish Class


Tail3PolygonVertices Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..Tail3PolygonVertices Field
RoboFish Class See Also Send Feedback
鱼体碰撞检测BV树叶结点，第三关节四边形顶点列表，四个顶点顺序分别为左上边点、右上边点、右下边点、左下边点

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Vector3> Tail3PolygonVertices
Visual Basic
Public Tail3PolygonVertices As List(Of Vector3)
Visual C++
public:
List<Vector3>^ Tail3PolygonVertices

See Also

RoboFish Class


TailJointLength1 Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..TailJointLength1 Field
RoboFish Class See Also Send Feedback
尾部第一个关节长度（**配置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int TailJointLength1
Visual Basic
Public TailJointLength1 As Integer
Visual C++
public:
int TailJointLength1

See Also

RoboFish Class


TailJointLength2 Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..TailJointLength2 Field
RoboFish Class See Also Send Feedback
尾部第二个关节长度（**配置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int TailJointLength2
Visual Basic
Public TailJointLength2 As Integer
Visual C++
public:
int TailJointLength2

See Also

RoboFish Class


TailJointLength3 Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..TailJointLength3 Field
RoboFish Class See Also Send Feedback
尾部第三个关节长度（**配置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int TailJointLength3
Visual Basic
Public TailJointLength3 As Integer
Visual C++
public:
int TailJointLength3

See Also

RoboFish Class


TailToBodyAngle1 Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..TailToBodyAngle1 Field
RoboFish Class See Also Send Feedback
尾部第一个关节相对鱼体的角度（**实时计算**），单位弧度

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float TailToBodyAngle1
Visual Basic
Public TailToBodyAngle1 As Single
Visual C++
public:
float TailToBodyAngle1

See Also

RoboFish Class


TailToBodyAngle2 Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..TailToBodyAngle2 Field
RoboFish Class See Also Send Feedback
尾部第二个关节相对鱼体的角度（**实时计算**），单位弧度

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float TailToBodyAngle2
Visual Basic
Public TailToBodyAngle2 As Single
Visual C++
public:
float TailToBodyAngle2

See Also

RoboFish Class


TailToBodyAngle3 Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..TailToBodyAngle3 Field
RoboFish Class See Also Send Feedback
尾部第三个关节相对鱼体的角度（**实时计算**），单位弧度

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float TailToBodyAngle3
Visual Basic
Public TailToBodyAngle3 As Single
Visual C++
public:
float TailToBodyAngle3

See Also

RoboFish Class


TargetTactic Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..TargetTactic Field
RoboFish Class See Also Send Feedback
目标决策数据值，由高层策略计算后给出

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Decision TargetTactic
Visual Basic
Public TargetTactic As Decision
Visual C++
public:
Decision TargetTactic

See Also

RoboFish Class


TrajectoryPoints Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..TrajectoryPoints Field
RoboFish Class See Also Send Feedback
仿真机器鱼绘制轨迹用的点列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Point> TrajectoryPoints
Visual Basic
Public TrajectoryPoints As List(Of Point)
Visual C++
public:
List<Point>^ TrajectoryPoints

See Also

RoboFish Class


VelocityDirectionRad Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..VelocityDirectionRad Field
RoboFish Class See Also Send Feedback
当前速度方向，单位弧度rad，值域(-PI, PI]

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float VelocityDirectionRad
Visual Basic
Public VelocityDirectionRad As Single
Visual C++
public:
float VelocityDirectionRad

See Also

RoboFish Class


VelocityMmPs Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..VelocityMmPs Field
RoboFish Class See Also Send Feedback
当前速度值，单位毫米每秒mm/s

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float VelocityMmPs
Visual Basic
Public VelocityMmPs As Single
Visual C++
public:
float VelocityMmPs

See Also

RoboFish Class


RoboFish Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish Methods
RoboFish Class See Also Send Feedback

The RoboFish type exposes the following members.

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Draw | 将当前仿真机器鱼绘制到GDI+绘图对象上
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | fishPostionCalculate | 鱼各个点的更新计算方法 added by Chen Wei 20110307 仿真使命（比赛或实验项目）是否正在运行即机器鱼是否正在游动仿真使命（比赛或实验项目）是否暂停即机器鱼是否正在游动仿真机器鱼尾部关节的初始相位仿真机器鱼对象
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RecoveryPose | 恢复所处半场 用于仿真机器鱼所属队伍位于右半场时绘制/碰撞检测/向客户端或策略传递参数后的处理
Public method | ResetSomeLocomotionPara | 重置仿真机器鱼的部分运动学参数，用于重新初始化使命清除上一次运行结束时保存的值
Public method | ReversePose | 对调所处半场，即将位置坐标和鱼体方向取反 用于仿真机器鱼所属队伍位于右半场时绘制/碰撞检测/向客户端或策略传递参数前的处理
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | SetFish | 从配置文件中读取可配置参数并计算出需要计算的参数
Public method | ToString | (Inherited from Object.)
Public method | UpdatePose | 根据仿真周期毫秒数更新仿真机器鱼位姿
Public method | UpdateVelocityAndAngularVelocity | 根据仿真周期毫秒数更新仿真机器鱼速度值速度方向和角速度值

See Also

RoboFish Class


Clone Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..Clone Method
RoboFish Class See Also Send Feedback
实现Clone接口的方法，拷贝一份当前对象的副本

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

当前对象的副本

Implements

ICloneable..::..Clone()()()()
IDssSerializableClone()()()()

See Also

RoboFish Class


CopyTo Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..CopyTo Method
RoboFish Class See Also Send Feedback
实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void CopyTo(
    IDssSerializable target
)
Visual Basic
Public Overridable Sub CopyTo ( _
    target As IDssSerializable _
)
Visual C++
public:
virtual void CopyTo(
    IDssSerializable^ target
)

Parameters

target
Type: IDssSerializable
当前对象拷贝到的目标对象

Implements

IDssSerializableCopyTo(IDssSerializable)

See Also

RoboFish Class


Deserialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..Deserialize Method
RoboFish Class See Also Send Feedback
实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Deserialize(
    BinaryReader reader
)
Visual Basic
Public Overridable Function Deserialize ( _
    reader As BinaryReader _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IO..::..BinaryReader
反序列化操作的来源对象

Return Value

反序列化得到的当前类型对象

Implements

IDssSerializableDeserialize(BinaryReader)

See Also

RoboFish Class


Draw Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..Draw Method
RoboFish Class See Also Send Feedback
将当前仿真机器鱼绘制到GDI+绘图对象上

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void Draw(
    ref Graphics g,
    bool isRunning,
    bool isPaused,
    float initPhase,
    int flag
)
Visual Basic
Public Sub Draw ( _
    ByRef g As Graphics, _
    isRunning As Boolean, _
    isPaused As Boolean, _
    initPhase As Single, _
    flag As Integer _
)
Visual C++
public:
void Draw(
    Graphics^% g,
    bool isRunning,
    bool isPaused,
    float initPhase,
    int flag
)

Parameters

g
Type: System.Drawing..::..Graphics %
来自与绘图容器PictureBox等尺寸的Bitmap的GDI+绘图对象
isRunning
Type: System..::..Boolean
仿真使命（比赛或实验项目）是否正在运行即机器鱼是否正在游动 用于控制是否绘制鱼尾游动效果
isPaused
Type: System..::..Boolean
仿真使命（比赛或实验项目）是否在运行过程中被设置为暂停状态 暂停状态可由界面按下暂停按钮设置，也可根据需要使用程序代码设置
initPhase
Type: System..::..Single
仿真机器鱼尾部关节的初始相位
flag
Type: System..::..Int32
所属队伍左右半场标志值1为左半场-1为右半场 在右半场flag为-1，则在绘制之前让鱼体朝向取反，如此能绘出右半场队伍的仿真机器鱼从右向左动作的效果 再配合仿真机器鱼位姿更新时各维坐标增量也取反，便实现了同一策略适用左右半场

See Also

RoboFish Class


fishPostionCalculate Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..fishPostionCalculate Method
RoboFish Class See Also Send Feedback
鱼各个点的更新计算方法 added by Chen Wei 20110307 仿真使命（比赛或实验项目）是否正在运行即机器鱼是否正在游动仿真使命（比赛或实验项目）是否暂停即机器鱼是否正在游动仿真机器鱼尾部关节的初始相位仿真机器鱼对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void fishPostionCalculate(
    bool isRunning,
    bool isPaused,
    float initPhase,
    ref RoboFish fish
)
Visual Basic
Public Sub fishPostionCalculate ( _
    isRunning As Boolean, _
    isPaused As Boolean, _
    initPhase As Single, _
    ByRef fish As RoboFish _
)
Visual C++
public:
void fishPostionCalculate(
    bool isRunning,
    bool isPaused,
    float initPhase,
    RoboFish^% fish
)

Parameters

isRunning
Type: System..::..Boolean

[Missing <param name="isRunning"/> documentation for "M:URWPGSim2D.Common.RoboFish.fishPostionCalculate(System.Boolean,System.Boolean,System.Single,URWPGSim2D.Common.RoboFish@)"]

isPaused
Type: System..::..Boolean

[Missing <param name="isPaused"/> documentation for "M:URWPGSim2D.Common.RoboFish.fishPostionCalculate(System.Boolean,System.Boolean,System.Single,URWPGSim2D.Common.RoboFish@)"]

initPhase
Type: System..::..Single

[Missing <param name="initPhase"/> documentation for "M:URWPGSim2D.Common.RoboFish.fishPostionCalculate(System.Boolean,System.Boolean,System.Single,URWPGSim2D.Common.RoboFish@)"]

fish
Type: URWPGSim2D.Common..::..RoboFish %

[Missing <param name="fish"/> documentation for "M:URWPGSim2D.Common.RoboFish.fishPostionCalculate(System.Boolean,System.Boolean,System.Single,URWPGSim2D.Common.RoboFish@)"]

See Also

RoboFish Class


RecoveryPose Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..RecoveryPose Method
RoboFish Class See Also Send Feedback
恢复所处半场 用于仿真机器鱼所属队伍位于右半场时绘制/碰撞检测/向客户端或策略传递参数后的处理

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void RecoveryPose()
Visual Basic
Public Sub RecoveryPose
Visual C++
public:
void RecoveryPose()

See Also

RoboFish Class


ResetSomeLocomotionPara Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..ResetSomeLocomotionPara Method
RoboFish Class See Also Send Feedback
重置仿真机器鱼的部分运动学参数，用于重新初始化使命清除上一次运行结束时保存的值

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void ResetSomeLocomotionPara()
Visual Basic
Public Sub ResetSomeLocomotionPara
Visual C++
public:
void ResetSomeLocomotionPara()

See Also

RoboFish Class


ReversePose Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..ReversePose Method
RoboFish Class See Also Send Feedback
对调所处半场，即将位置坐标和鱼体方向取反 用于仿真机器鱼所属队伍位于右半场时绘制/碰撞检测/向客户端或策略传递参数前的处理

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void ReversePose()
Visual Basic
Public Sub ReversePose
Visual C++
public:
void ReversePose()

See Also

RoboFish Class


Serialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..Serialize Method
RoboFish Class See Also Send Feedback
实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void Serialize(
    BinaryWriter writer
)
Visual Basic
Public Overridable Sub Serialize ( _
    writer As BinaryWriter _
)
Visual C++
public:
virtual void Serialize(
    BinaryWriter^ writer
)

Parameters

writer
Type: System.IO..::..BinaryWriter
当前对象序列化到的目标对象

Implements

IDssSerializableSerialize(BinaryWriter)

See Also

RoboFish Class


SetFish Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..SetFish Method
RoboFish Class See Also Send Feedback
从配置文件中读取可配置参数并计算出需要计算的参数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void SetFish()
Visual Basic
Public Sub SetFish
Visual C++
public:
void SetFish()

See Also

RoboFish Class


UpdatePose Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..UpdatePose Method
RoboFish Class See Also Send Feedback
根据仿真周期毫秒数更新仿真机器鱼位姿

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void UpdatePose(
    int timeIntervalMs,
    int flag
)
Visual Basic
Public Sub UpdatePose ( _
    timeIntervalMs As Integer, _
    flag As Integer _
)
Visual C++
public:
void UpdatePose(
    int timeIntervalMs,
    int flag
)

Parameters

timeIntervalMs
Type: System..::..Int32
仿真周期毫秒数
flag
Type: System..::..Int32
所属队伍左右半场标志值1为左半场-1为右半场

Remarks

注意：按照运动学模型设计的顺序，每个周期各运动学计算相关方法调用顺序为 UpdatePose, UpdateVelocityAndAngularVelocity, DetectCollision, ResponseCollision

See Also

RoboFish Class


UpdateVelocityAndAngularVelocity Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoboFish..::..UpdateVelocityAndAngularVelocity Method
RoboFish Class See Also Send Feedback
根据仿真周期毫秒数更新仿真机器鱼速度值速度方向和角速度值

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void UpdateVelocityAndAngularVelocity(
    int timeIntervalMs,
    int flag
)
Visual Basic
Public Sub UpdateVelocityAndAngularVelocity ( _
    timeIntervalMs As Integer, _
    flag As Integer _
)
Visual C++
public:
void UpdateVelocityAndAngularVelocity(
    int timeIntervalMs,
    int flag
)

Parameters

timeIntervalMs
Type: System..::..Int32
仿真周期毫秒数
flag
Type: System..::..Int32
所属队伍左右半场标志值1为左半场-1为右半场

Remarks

注意：按照运动学模型设计的顺序，每个周期各运动学计算相关方法调用顺序为 UpdatePose, UpdateVelocityAndAngularVelocity, DetectCollision, ResponseCollision

See Also

RoboFish Class


RoundedDynamic Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic Class
Members See Also Send Feedback
仿真场地中圆形动态对象基类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class RoundedDynamic : ICloneable,
    IDssSerializable
Visual Basic
<SerializableAttribute> _
Public Class RoundedDynamic _
    Implements ICloneable, IDssSerializable
Visual C++
[SerializableAttribute]
public ref class RoundedDynamic : ICloneable,
    IDssSerializable

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..RoundedDynamic
URWPGSim2D.Common..::..Ball

See Also

RoundedDynamic Members


RoundedDynamic Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic Members
RoundedDynamic Class Constructors Methods Fields See Also Send Feedback

The RoundedDynamic type exposes the following members.

Constructors

 | Name | Description
Public method | RoundedDynamic | 构造函数

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Draw | 将当前对象绘制到GDI+绘图对象上
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ResetSomeLocomotionPara | 重置仿真水球的部分运动学参数，用于重新初始化使命清除上一次运行结束时保存的值
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | SetRoundedDynamic | 设置默认参数
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | AngularVelocityRadPs | 当前角速度值，单位弧度每秒rad/s
Public field | BorderWidthPix | 边框宽度，单位像素
Public field | Collision | 当前碰撞状态
Public field | ColorBorder | 边框颜色
Public field | ColorFilled | 填充颜色
Public field | PositionMm | 当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | PreAngularVelocityRadPs | 当前角速度值备份，单位弧度每秒rad/s
Public field | PreCollision | 当前碰撞状态备份
Public field | PrePositionMm | 当前中心点坐标备份，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | PreVelocityDirectionRad | 当前速度方向备份，单位弧度rad，值域[-PI, PI)
Public field | PreVelocityMmPs | 当前速度值备份，单位毫米每秒mm/s
Public field | RadiusMm | 半径（**设置**），单位毫米
Public field | VelocityDirectionRad | 当前速度方向，单位弧度rad，值域[-PI, PI)
Public field | VelocityMmPs | 当前速度值，单位毫米每秒mm/s

See Also

RoundedDynamic Class


RoundedDynamic Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic Constructor
RoundedDynamic Class See Also Send Feedback
构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public RoundedDynamic()
Visual Basic
Public Sub New
Visual C++
public:
RoundedDynamic()

See Also

RoundedDynamic Class


RoundedDynamic Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic Fields
RoundedDynamic Class See Also Send Feedback

The RoundedDynamic type exposes the following members.

Fields

 | Name | Description
Public field | AngularVelocityRadPs | 当前角速度值，单位弧度每秒rad/s
Public field | BorderWidthPix | 边框宽度，单位像素
Public field | Collision | 当前碰撞状态
Public field | ColorBorder | 边框颜色
Public field | ColorFilled | 填充颜色
Public field | PositionMm | 当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | PreAngularVelocityRadPs | 当前角速度值备份，单位弧度每秒rad/s
Public field | PreCollision | 当前碰撞状态备份
Public field | PrePositionMm | 当前中心点坐标备份，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | PreVelocityDirectionRad | 当前速度方向备份，单位弧度rad，值域[-PI, PI)
Public field | PreVelocityMmPs | 当前速度值备份，单位毫米每秒mm/s
Public field | RadiusMm | 半径（**设置**），单位毫米
Public field | VelocityDirectionRad | 当前速度方向，单位弧度rad，值域[-PI, PI)
Public field | VelocityMmPs | 当前速度值，单位毫米每秒mm/s

See Also

RoundedDynamic Class


AngularVelocityRadPs Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..AngularVelocityRadPs Field
RoundedDynamic Class See Also Send Feedback
当前角速度值，单位弧度每秒rad/s

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float AngularVelocityRadPs
Visual Basic
Public AngularVelocityRadPs As Single
Visual C++
public:
float AngularVelocityRadPs

See Also

RoundedDynamic Class


BorderWidthPix Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..BorderWidthPix Field
RoundedDynamic Class See Also Send Feedback
边框宽度，单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int BorderWidthPix
Visual Basic
Public BorderWidthPix As Integer
Visual C++
public:
int BorderWidthPix

See Also

RoundedDynamic Class


Collision Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..Collision Field
RoundedDynamic Class See Also Send Feedback
当前碰撞状态

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public CollisionType Collision
Visual Basic
Public Collision As CollisionType
Visual C++
public:
CollisionType Collision

See Also

RoundedDynamic Class


ColorBorder Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..ColorBorder Field
RoundedDynamic Class See Also Send Feedback
边框颜色

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Color ColorBorder
Visual Basic
Public ColorBorder As Color
Visual C++
public:
Color ColorBorder

See Also

RoundedDynamic Class


ColorFilled Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..ColorFilled Field
RoundedDynamic Class See Also Send Feedback
填充颜色

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Color ColorFilled
Visual Basic
Public ColorFilled As Color
Visual C++
public:
Color ColorFilled

See Also

RoundedDynamic Class


PositionMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..PositionMm Field
RoundedDynamic Class See Also Send Feedback
当前中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 PositionMm
Visual Basic
Public PositionMm As Vector3
Visual C++
public:
Vector3 PositionMm

See Also

RoundedDynamic Class


PreAngularVelocityRadPs Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..PreAngularVelocityRadPs Field
RoundedDynamic Class See Also Send Feedback
当前角速度值备份，单位弧度每秒rad/s

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float PreAngularVelocityRadPs
Visual Basic
Public PreAngularVelocityRadPs As Single
Visual C++
public:
float PreAngularVelocityRadPs

See Also

RoundedDynamic Class


PreCollision Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..PreCollision Field
RoundedDynamic Class See Also Send Feedback
当前碰撞状态备份

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public CollisionType PreCollision
Visual Basic
Public PreCollision As CollisionType
Visual C++
public:
CollisionType PreCollision

See Also

RoundedDynamic Class


PrePositionMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..PrePositionMm Field
RoundedDynamic Class See Also Send Feedback
当前中心点坐标备份，各维坐标单位毫米mm，2D版本中Y坐标固定为0

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 PrePositionMm
Visual Basic
Public PrePositionMm As Vector3
Visual C++
public:
Vector3 PrePositionMm

See Also

RoundedDynamic Class


PreVelocityDirectionRad Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..PreVelocityDirectionRad Field
RoundedDynamic Class See Also Send Feedback
当前速度方向备份，单位弧度rad，值域[-PI, PI)

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float PreVelocityDirectionRad
Visual Basic
Public PreVelocityDirectionRad As Single
Visual C++
public:
float PreVelocityDirectionRad

See Also

RoundedDynamic Class


PreVelocityMmPs Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..PreVelocityMmPs Field
RoundedDynamic Class See Also Send Feedback
当前速度值备份，单位毫米每秒mm/s

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float PreVelocityMmPs
Visual Basic
Public PreVelocityMmPs As Single
Visual C++
public:
float PreVelocityMmPs

See Also

RoundedDynamic Class


RadiusMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..RadiusMm Field
RoundedDynamic Class See Also Send Feedback
半径（**设置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int RadiusMm
Visual Basic
Public RadiusMm As Integer
Visual C++
public:
int RadiusMm

See Also

RoundedDynamic Class


VelocityDirectionRad Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..VelocityDirectionRad Field
RoundedDynamic Class See Also Send Feedback
当前速度方向，单位弧度rad，值域[-PI, PI)

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float VelocityDirectionRad
Visual Basic
Public VelocityDirectionRad As Single
Visual C++
public:
float VelocityDirectionRad

See Also

RoundedDynamic Class


VelocityMmPs Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..VelocityMmPs Field
RoundedDynamic Class See Also Send Feedback
当前速度值，单位毫米每秒mm/s

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public float VelocityMmPs
Visual Basic
Public VelocityMmPs As Single
Visual C++
public:
float VelocityMmPs

See Also

RoundedDynamic Class


RoundedDynamic Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic Methods
RoundedDynamic Class See Also Send Feedback

The RoundedDynamic type exposes the following members.

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Draw | 将当前对象绘制到GDI+绘图对象上
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ResetSomeLocomotionPara | 重置仿真水球的部分运动学参数，用于重新初始化使命清除上一次运行结束时保存的值
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | SetRoundedDynamic | 设置默认参数
Public method | ToString | (Inherited from Object.)

See Also

RoundedDynamic Class


Clone Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..Clone Method
RoundedDynamic Class See Also Send Feedback
实现Clone接口的方法，拷贝一份当前对象的副本

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

当前对象的副本

Implements

ICloneable..::..Clone()()()()
IDssSerializableClone()()()()

See Also

RoundedDynamic Class


CopyTo Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..CopyTo Method
RoundedDynamic Class See Also Send Feedback
实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void CopyTo(
    IDssSerializable target
)
Visual Basic
Public Overridable Sub CopyTo ( _
    target As IDssSerializable _
)
Visual C++
public:
virtual void CopyTo(
    IDssSerializable^ target
)

Parameters

target
Type: IDssSerializable
当前对象拷贝到的目标对象

Implements

IDssSerializableCopyTo(IDssSerializable)

See Also

RoundedDynamic Class


Deserialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..Deserialize Method
RoundedDynamic Class See Also Send Feedback
实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Deserialize(
    BinaryReader reader
)
Visual Basic
Public Overridable Function Deserialize ( _
    reader As BinaryReader _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IO..::..BinaryReader
反序列化操作的来源对象

Return Value

反序列化得到的当前类型对象

Implements

IDssSerializableDeserialize(BinaryReader)

See Also

RoundedDynamic Class


Draw Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..Draw Method
RoundedDynamic Class See Also Send Feedback
将当前对象绘制到GDI+绘图对象上

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void Draw(
    ref Graphics g
)
Visual Basic
Public Sub Draw ( _
    ByRef g As Graphics _
)
Visual C++
public:
void Draw(
    Graphics^% g
)

Parameters

g
Type: System.Drawing..::..Graphics %
来自与绘图容器PictureBox等尺寸的Bitmap的GDI+绘图对象

See Also

RoundedDynamic Class


ResetSomeLocomotionPara Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..ResetSomeLocomotionPara Method
RoundedDynamic Class See Also Send Feedback
重置仿真水球的部分运动学参数，用于重新初始化使命清除上一次运行结束时保存的值

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void ResetSomeLocomotionPara()
Visual Basic
Public Sub ResetSomeLocomotionPara
Visual C++
public:
void ResetSomeLocomotionPara()

See Also

RoundedDynamic Class


Serialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..Serialize Method
RoundedDynamic Class See Also Send Feedback
实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void Serialize(
    BinaryWriter writer
)
Visual Basic
Public Overridable Sub Serialize ( _
    writer As BinaryWriter _
)
Visual C++
public:
virtual void Serialize(
    BinaryWriter^ writer
)

Parameters

writer
Type: System.IO..::..BinaryWriter
当前对象序列化到的目标对象

Implements

IDssSerializableSerialize(BinaryWriter)

See Also

RoundedDynamic Class


SetRoundedDynamic Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedDynamic..::..SetRoundedDynamic Method
RoundedDynamic Class See Also Send Feedback
设置默认参数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void SetRoundedDynamic()
Visual Basic
Public Sub SetRoundedDynamic
Visual C++
public:
void SetRoundedDynamic()

See Also

RoundedDynamic Class


RoundedObstacle Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle Class
Members See Also Send Feedback
仿真圆形静态障碍物类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class RoundedObstacle : RoundedStatic,
    ICloneable, IDssSerializable
Visual Basic
<SerializableAttribute> _
Public Class RoundedObstacle _
    Inherits RoundedStatic _
    Implements ICloneable, IDssSerializable
Visual C++
[SerializableAttribute]
public ref class RoundedObstacle : public RoundedStatic,
    ICloneable, IDssSerializable

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..RoundedStatic
URWPGSim2D.Common..::..RoundedObstacle

See Also

RoundedObstacle Members


RoundedObstacle Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle Members
RoundedObstacle Class Constructors Methods Fields See Also Send Feedback

The RoundedObstacle type exposes the following members.

Constructors

 | Name | Description
Public method | RoundedObstacle()()()() | 默认构造函数
Public method | RoundedObstacle(String, Vector3, Color, Int32) | 带参数构造函数
Public method | RoundedObstacle(String, Vector3, Color, Color, Int32) | 带参数构造函数
Public method | RoundedObstacle(String, Vector3, Color, Color, Int32, Int32) | 带参数构造函数

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本 (Overrides RoundedStatic..::..Clone()()()().)
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象 (Overrides RoundedStatic..::..CopyTo(IDssSerializable).)
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象 (Overrides RoundedStatic..::..Deserialize(BinaryReader).)
Public method | Draw | 将当前对象绘制到GDI+绘图对象上 (Inherited from RoundedStatic.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象 (Overrides RoundedStatic..::..Serialize(BinaryWriter).)
Public method | SetRoundedStatic | 设置默认参数 (Inherited from RoundedStatic.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | BorderWidthPix | 边框宽度，单位像素 (Inherited from RoundedStatic.)
Public field | ColorBorder | 边框颜色 (Inherited from RoundedStatic.)
Public field | ColorFilled | 填充颜色 (Inherited from RoundedStatic.)
Public field | Name | 名称
Public field | PositionMm | 中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0 (Inherited from RoundedStatic.)
Public field | RadiusMm | 半径（**设置**），单位毫米 (Inherited from RoundedStatic.)

See Also

RoundedObstacle Class


RoundedObstacle Constructor

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle Constructor
RoundedObstacle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RoundedObstacle()()()() | 默认构造函数
Public method | RoundedObstacle(String, Vector3, Color, Int32) | 带参数构造函数
Public method | RoundedObstacle(String, Vector3, Color, Color, Int32) | 带参数构造函数
Public method | RoundedObstacle(String, Vector3, Color, Color, Int32, Int32) | 带参数构造函数

See Also

RoundedObstacle Class
RoundedObstacle Members


RoundedObstacle Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle Constructor
RoundedObstacle Class See Also Send Feedback
默认构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public RoundedObstacle()
Visual Basic
Public Sub New
Visual C++
public:
RoundedObstacle()

See Also

RoundedObstacle Class
RoundedObstacle Overload


RoundedObstacle Constructor (String, , Color, Int32)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle Constructor (String, , Color, Int32)
RoundedObstacle Class See Also Send Feedback
带参数构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public RoundedObstacle(
    string strName,
    Vector3 positionMm,
    Color color,
    int radiusMm
)
Visual Basic
Public Sub New ( _
    strName As String, _
    positionMm As Vector3, _
    color As Color, _
    radiusMm As Integer _
)
Visual C++
public:
RoundedObstacle(
    String^ strName,
    Vector3 positionMm,
    Color color,
    int radiusMm
)

Parameters

strName
Type: System..::..String
仿真圆形障碍物名称
positionMm
Type: Vector3
仿真圆形障碍物位置（在世界坐标系中，以毫米为单位）
color
Type: System.Drawing..::..Color
仿真圆形障碍物颜色
radiusMm
Type: System..::..Int32
仿真圆形障碍物半径（以毫米为单位）

See Also

RoundedObstacle Class
RoundedObstacle Overload


RoundedObstacle Constructor (String, , Color, Color, Int32)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle Constructor (String, , Color, Color, Int32)
RoundedObstacle Class See Also Send Feedback
带参数构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public RoundedObstacle(
    string strName,
    Vector3 positionMm,
    Color colorBorder,
    Color colorFilled,
    int radiusMm
)
Visual Basic
Public Sub New ( _
    strName As String, _
    positionMm As Vector3, _
    colorBorder As Color, _
    colorFilled As Color, _
    radiusMm As Integer _
)
Visual C++
public:
RoundedObstacle(
    String^ strName,
    Vector3 positionMm,
    Color colorBorder,
    Color colorFilled,
    int radiusMm
)

Parameters

strName
Type: System..::..String
仿真圆形障碍物名称
positionMm
Type: Vector3
仿真圆形障碍物位置（在世界坐标系中，以毫米为单位）
colorBorder
Type: System.Drawing..::..Color
仿真圆形障碍物轮廓颜色
colorFilled
Type: System.Drawing..::..Color
仿真圆形障碍物填充颜色
radiusMm
Type: System..::..Int32
仿真圆形障碍物半径（以毫米为单位）

See Also

RoundedObstacle Class
RoundedObstacle Overload


RoundedObstacle Constructor (String, , Color, Color, Int32, Int32)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle Constructor (String, , Color, Color, Int32, Int32)
RoundedObstacle Class See Also Send Feedback
带参数构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public RoundedObstacle(
    string strName,
    Vector3 positionMm,
    Color colorBorder,
    Color colorFilled,
    int borderWithPix,
    int radiusMm
)
Visual Basic
Public Sub New ( _
    strName As String, _
    positionMm As Vector3, _
    colorBorder As Color, _
    colorFilled As Color, _
    borderWithPix As Integer, _
    radiusMm As Integer _
)
Visual C++
public:
RoundedObstacle(
    String^ strName,
    Vector3 positionMm,
    Color colorBorder,
    Color colorFilled,
    int borderWithPix,
    int radiusMm
)

Parameters

strName
Type: System..::..String
仿真圆形障碍物名称
positionMm
Type: Vector3
仿真圆形障碍物位置（在场地坐标系中，以毫米为单位）
colorBorder
Type: System.Drawing..::..Color
仿真圆形障碍物轮廓颜色
colorFilled
Type: System.Drawing..::..Color
仿真圆形障碍物填充颜色
borderWithPix
Type: System..::..Int32
仿真圆形障碍物轮廓像素宽度
radiusMm
Type: System..::..Int32
仿真圆形障碍物半径（以毫米为单位）

See Also

RoundedObstacle Class
RoundedObstacle Overload


RoundedObstacle Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle Fields
RoundedObstacle Class See Also Send Feedback

The RoundedObstacle type exposes the following members.

Fields

 | Name | Description
Public field | BorderWidthPix | 边框宽度，单位像素 (Inherited from RoundedStatic.)
Public field | ColorBorder | 边框颜色 (Inherited from RoundedStatic.)
Public field | ColorFilled | 填充颜色 (Inherited from RoundedStatic.)
Public field | Name | 名称
Public field | PositionMm | 中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0 (Inherited from RoundedStatic.)
Public field | RadiusMm | 半径（**设置**），单位毫米 (Inherited from RoundedStatic.)

See Also

RoundedObstacle Class


Name Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle..::..Name Field
RoundedObstacle Class See Also Send Feedback
名称

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public string Name
Visual Basic
Public Name As String
Visual C++
public:
String^ Name

See Also

RoundedObstacle Class


RoundedObstacle Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle Methods
RoundedObstacle Class See Also Send Feedback

The RoundedObstacle type exposes the following members.

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本 (Overrides RoundedStatic..::..Clone()()()().)
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象 (Overrides RoundedStatic..::..CopyTo(IDssSerializable).)
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象 (Overrides RoundedStatic..::..Deserialize(BinaryReader).)
Public method | Draw | 将当前对象绘制到GDI+绘图对象上 (Inherited from RoundedStatic.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象 (Overrides RoundedStatic..::..Serialize(BinaryWriter).)
Public method | SetRoundedStatic | 设置默认参数 (Inherited from RoundedStatic.)
Public method | ToString | (Inherited from Object.)

See Also

RoundedObstacle Class


Clone Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle..::..Clone Method
RoundedObstacle Class See Also Send Feedback
实现Clone接口的方法，拷贝一份当前对象的副本

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

当前对象的副本

Implements

ICloneable..::..Clone()()()()
IDssSerializableClone()()()()
ICloneable..::..Clone()()()()
IDssSerializableClone()()()()

See Also

RoundedObstacle Class


CopyTo Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle..::..CopyTo Method
RoundedObstacle Class See Also Send Feedback
实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override void CopyTo(
    IDssSerializable target
)
Visual Basic
Public Overrides Sub CopyTo ( _
    target As IDssSerializable _
)
Visual C++
public:
virtual void CopyTo(
    IDssSerializable^ target
) override

Parameters

target
Type: IDssSerializable
当前对象拷贝到的目标对象

Implements

IDssSerializableCopyTo(IDssSerializable)
IDssSerializableCopyTo(IDssSerializable)

See Also

RoundedObstacle Class


Deserialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle..::..Deserialize Method
RoundedObstacle Class See Also Send Feedback
实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override Object Deserialize(
    BinaryReader reader
)
Visual Basic
Public Overrides Function Deserialize ( _
    reader As BinaryReader _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    BinaryReader^ reader
) override

Parameters

reader
Type: System.IO..::..BinaryReader
反序列化操作的来源对象

Return Value

反序列化得到的当前类型对象

Implements

IDssSerializableDeserialize(BinaryReader)
IDssSerializableDeserialize(BinaryReader)

See Also

RoundedObstacle Class


Serialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedObstacle..::..Serialize Method
RoundedObstacle Class See Also Send Feedback
实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public override void Serialize(
    BinaryWriter writer
)
Visual Basic
Public Overrides Sub Serialize ( _
    writer As BinaryWriter _
)
Visual C++
public:
virtual void Serialize(
    BinaryWriter^ writer
) override

Parameters

writer
Type: System.IO..::..BinaryWriter
当前对象序列化到的目标对象

Implements

IDssSerializableSerialize(BinaryWriter)
IDssSerializableSerialize(BinaryWriter)

See Also

RoundedObstacle Class


RoundedStatic Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic Class
Members See Also Send Feedback
仿真场地中圆形静态对象基类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class RoundedStatic : ICloneable,
    IDssSerializable
Visual Basic
<SerializableAttribute> _
Public Class RoundedStatic _
    Implements ICloneable, IDssSerializable
Visual C++
[SerializableAttribute]
public ref class RoundedStatic : ICloneable,
    IDssSerializable

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..RoundedStatic
URWPGSim2D.Common..::..RoundedObstacle

See Also

RoundedStatic Members


RoundedStatic Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic Members
RoundedStatic Class Constructors Methods Fields See Also Send Feedback

The RoundedStatic type exposes the following members.

Constructors

 | Name | Description
Public method | RoundedStatic | 构造函数

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Draw | 将当前对象绘制到GDI+绘图对象上
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | SetRoundedStatic | 设置默认参数
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | BorderWidthPix | 边框宽度，单位像素
Public field | ColorBorder | 边框颜色
Public field | ColorFilled | 填充颜色
Public field | PositionMm | 中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | RadiusMm | 半径（**设置**），单位毫米

See Also

RoundedStatic Class


RoundedStatic Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic Constructor
RoundedStatic Class See Also Send Feedback
构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public RoundedStatic()
Visual Basic
Public Sub New
Visual C++
public:
RoundedStatic()

See Also

RoundedStatic Class


RoundedStatic Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic Fields
RoundedStatic Class See Also Send Feedback

The RoundedStatic type exposes the following members.

Fields

 | Name | Description
Public field | BorderWidthPix | 边框宽度，单位像素
Public field | ColorBorder | 边框颜色
Public field | ColorFilled | 填充颜色
Public field | PositionMm | 中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0
Public field | RadiusMm | 半径（**设置**），单位毫米

See Also

RoundedStatic Class


BorderWidthPix Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic..::..BorderWidthPix Field
RoundedStatic Class See Also Send Feedback
边框宽度，单位像素

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int BorderWidthPix
Visual Basic
Public BorderWidthPix As Integer
Visual C++
public:
int BorderWidthPix

See Also

RoundedStatic Class


ColorBorder Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic..::..ColorBorder Field
RoundedStatic Class See Also Send Feedback
边框颜色

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Color ColorBorder
Visual Basic
Public ColorBorder As Color
Visual C++
public:
Color ColorBorder

See Also

RoundedStatic Class


ColorFilled Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic..::..ColorFilled Field
RoundedStatic Class See Also Send Feedback
填充颜色

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Color ColorFilled
Visual Basic
Public ColorFilled As Color
Visual C++
public:
Color ColorFilled

See Also

RoundedStatic Class


PositionMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic..::..PositionMm Field
RoundedStatic Class See Also Send Feedback
中心点坐标，各维坐标单位毫米mm，2D版本中Y坐标固定为0

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Vector3 PositionMm
Visual Basic
Public PositionMm As Vector3
Visual C++
public:
Vector3 PositionMm

See Also

RoundedStatic Class


RadiusMm Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic..::..RadiusMm Field
RoundedStatic Class See Also Send Feedback
半径（**设置**），单位毫米

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int RadiusMm
Visual Basic
Public RadiusMm As Integer
Visual C++
public:
int RadiusMm

See Also

RoundedStatic Class


RoundedStatic Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic Methods
RoundedStatic Class See Also Send Feedback

The RoundedStatic type exposes the following members.

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Draw | 将当前对象绘制到GDI+绘图对象上
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | SetRoundedStatic | 设置默认参数
Public method | ToString | (Inherited from Object.)

See Also

RoundedStatic Class


Clone Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic..::..Clone Method
RoundedStatic Class See Also Send Feedback
实现Clone接口的方法，拷贝一份当前对象的副本

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

当前对象的副本

Implements

ICloneable..::..Clone()()()()
IDssSerializableClone()()()()

See Also

RoundedStatic Class


CopyTo Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic..::..CopyTo Method
RoundedStatic Class See Also Send Feedback
实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void CopyTo(
    IDssSerializable target
)
Visual Basic
Public Overridable Sub CopyTo ( _
    target As IDssSerializable _
)
Visual C++
public:
virtual void CopyTo(
    IDssSerializable^ target
)

Parameters

target
Type: IDssSerializable
当前对象拷贝到的目标对象

Implements

IDssSerializableCopyTo(IDssSerializable)

See Also

RoundedStatic Class


Deserialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic..::..Deserialize Method
RoundedStatic Class See Also Send Feedback
实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Deserialize(
    BinaryReader reader
)
Visual Basic
Public Overridable Function Deserialize ( _
    reader As BinaryReader _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IO..::..BinaryReader
反序列化操作的来源对象

Return Value

反序列化得到的当前类型对象

Implements

IDssSerializableDeserialize(BinaryReader)

See Also

RoundedStatic Class


Draw Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic..::..Draw Method
RoundedStatic Class See Also Send Feedback
将当前对象绘制到GDI+绘图对象上

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void Draw(
    ref Graphics g
)
Visual Basic
Public Sub Draw ( _
    ByRef g As Graphics _
)
Visual C++
public:
void Draw(
    Graphics^% g
)

Parameters

g
Type: System.Drawing..::..Graphics %
来自与绘图容器PictureBox等尺寸的Bitmap的GDI+绘图对象

See Also

RoundedStatic Class


Serialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic..::..Serialize Method
RoundedStatic Class See Also Send Feedback
实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void Serialize(
    BinaryWriter writer
)
Visual Basic
Public Overridable Sub Serialize ( _
    writer As BinaryWriter _
)
Visual C++
public:
virtual void Serialize(
    BinaryWriter^ writer
)

Parameters

writer
Type: System.IO..::..BinaryWriter
当前对象序列化到的目标对象

Implements

IDssSerializableSerialize(BinaryWriter)

See Also

RoundedStatic Class


SetRoundedStatic Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
RoundedStatic..::..SetRoundedStatic Method
RoundedStatic Class See Also Send Feedback
设置默认参数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public void SetRoundedStatic()
Visual Basic
Public Sub SetRoundedStatic
Visual C++
public:
void SetRoundedStatic()

See Also

RoundedStatic Class


SimEnvironment Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment Class
Members See Also Send Feedback
仿真环境基类，所有具体使命（比赛或实验项目）使用的环境类必须继承该类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class SimEnvironment : ISimEnvironment,
    ICloneable, IDssSerializable
Visual Basic
<SerializableAttribute> _
Public Class SimEnvironment _
    Implements ISimEnvironment, ICloneable, IDssSerializable
Visual C++
[SerializableAttribute]
public ref class SimEnvironment : ISimEnvironment,
    ICloneable, IDssSerializable

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..SimEnvironment

See Also

SimEnvironment Members


SimEnvironment Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment Members
SimEnvironment Class Constructors Methods Fields See Also Send Feedback

The SimEnvironment type exposes the following members.

Constructors

 | Name | Description
Public method | SimEnvironment | Initializes a new instance of the SimEnvironment class

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Balls | 仿真环境中仿真水球列表
Public field | Channels | 仿真环境中仿真通道列表
Public field | FieldInfo | 仿真环境中仿真场地
Public field | ObstaclesRect | 仿真环境中仿真方形障碍物列表
Public field | ObstaclesRound | 仿真环境中仿真圆形障碍物列表

See Also

SimEnvironment Class


SimEnvironment Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment Constructor
SimEnvironment Class See Also Send Feedback
Initializes a new instance of the SimEnvironment class

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public SimEnvironment()
Visual Basic
Public Sub New
Visual C++
public:
SimEnvironment()

See Also

SimEnvironment Class


SimEnvironment Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment Fields
SimEnvironment Class See Also Send Feedback

The SimEnvironment type exposes the following members.

Fields

 | Name | Description
Public field | Balls | 仿真环境中仿真水球列表
Public field | Channels | 仿真环境中仿真通道列表
Public field | FieldInfo | 仿真环境中仿真场地
Public field | ObstaclesRect | 仿真环境中仿真方形障碍物列表
Public field | ObstaclesRound | 仿真环境中仿真圆形障碍物列表

See Also

SimEnvironment Class


Balls Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment..::..Balls Field
SimEnvironment Class See Also Send Feedback
仿真环境中仿真水球列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Ball> Balls
Visual Basic
Public Balls As List(Of Ball)
Visual C++
public:
List<Ball^>^ Balls

See Also

SimEnvironment Class


Channels Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment..::..Channels Field
SimEnvironment Class See Also Send Feedback
仿真环境中仿真通道列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<Channel> Channels
Visual Basic
Public Channels As List(Of Channel)
Visual C++
public:
List<Channel^>^ Channels

See Also

SimEnvironment Class


FieldInfo Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment..::..FieldInfo Field
SimEnvironment Class See Also Send Feedback
仿真环境中仿真场地

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Field FieldInfo
Visual Basic
Public FieldInfo As Field
Visual C++
public:
Field^ FieldInfo

See Also

SimEnvironment Class


ObstaclesRect Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment..::..ObstaclesRect Field
SimEnvironment Class See Also Send Feedback
仿真环境中仿真方形障碍物列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<RectangularObstacle> ObstaclesRect
Visual Basic
Public ObstaclesRect As List(Of RectangularObstacle)
Visual C++
public:
List<RectangularObstacle^>^ ObstaclesRect

See Also

SimEnvironment Class


ObstaclesRound Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment..::..ObstaclesRound Field
SimEnvironment Class See Also Send Feedback
仿真环境中仿真圆形障碍物列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<RoundedObstacle> ObstaclesRound
Visual Basic
Public ObstaclesRound As List(Of RoundedObstacle)
Visual C++
public:
List<RoundedObstacle^>^ ObstaclesRound

See Also

SimEnvironment Class


SimEnvironment Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment Methods
SimEnvironment Class See Also Send Feedback

The SimEnvironment type exposes the following members.

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | ToString | (Inherited from Object.)

See Also

SimEnvironment Class


Clone Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment..::..Clone Method
SimEnvironment Class See Also Send Feedback
实现Clone接口的方法，拷贝一份当前对象的副本

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

当前对象的副本

Implements

ICloneable..::..Clone()()()()
IDssSerializableClone()()()()

See Also

SimEnvironment Class


CopyTo Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment..::..CopyTo Method
SimEnvironment Class See Also Send Feedback
实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void CopyTo(
    IDssSerializable target
)
Visual Basic
Public Overridable Sub CopyTo ( _
    target As IDssSerializable _
)
Visual C++
public:
virtual void CopyTo(
    IDssSerializable^ target
)

Parameters

target
Type: IDssSerializable
当前对象拷贝到的目标对象

Implements

IDssSerializableCopyTo(IDssSerializable)

See Also

SimEnvironment Class


Deserialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment..::..Deserialize Method
SimEnvironment Class See Also Send Feedback
实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Deserialize(
    BinaryReader reader
)
Visual Basic
Public Overridable Function Deserialize ( _
    reader As BinaryReader _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IO..::..BinaryReader
反序列化操作的来源对象

Return Value

反序列化得到的当前类型对象

Implements

IDssSerializableDeserialize(BinaryReader)

See Also

SimEnvironment Class


Serialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SimEnvironment..::..Serialize Method
SimEnvironment Class See Also Send Feedback
实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void Serialize(
    BinaryWriter writer
)
Visual Basic
Public Overridable Sub Serialize ( _
    writer As BinaryWriter _
)
Visual C++
public:
virtual void Serialize(
    BinaryWriter^ writer
)

Parameters

writer
Type: System.IO..::..BinaryWriter
当前对象序列化到的目标对象

Implements

IDssSerializableSerialize(BinaryWriter)

See Also

SimEnvironment Class


SysConfig Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SysConfig Class
Members See Also Send Feedback
系统参数配置xml文件处理类 by chenwei 20101106

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public class SysConfig
Visual Basic
Public Class SysConfig
Visual C++
public ref class SysConfig

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..SysConfig

See Also

SysConfig Members


SysConfig Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SysConfig Members
SysConfig Class Methods See Also Send Feedback

The SysConfig type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Instance | 创建或获取该类的唯一实例
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MyXmlReader | 根据给定的配置参数名读取配置参数值
Public method | ToString | (Inherited from Object.)

See Also

SysConfig Class


SysConfig Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SysConfig Methods
SysConfig Class See Also Send Feedback

The SysConfig type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Instance | 创建或获取该类的唯一实例
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MyXmlReader | 根据给定的配置参数名读取配置参数值
Public method | ToString | (Inherited from Object.)

See Also

SysConfig Class


Instance Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SysConfig..::..Instance Method
SysConfig Class See Also Send Feedback
创建或获取该类的唯一实例

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static SysConfig Instance()
Visual Basic
Public Shared Function Instance As SysConfig
Visual C++
public:
static SysConfig^ Instance()

Return Value

[Missing <returns> documentation for "M:URWPGSim2D.Common.SysConfig.Instance"]

See Also

SysConfig Class


MyXmlReader Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
SysConfig..::..MyXmlReader Method
SysConfig Class See Also Send Feedback
根据给定的配置参数名读取配置参数值

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public string MyXmlReader(
    string strKeyName
)
Visual Basic
Public Function MyXmlReader ( _
    strKeyName As String _
) As String
Visual C++
public:
String^ MyXmlReader(
    String^ strKeyName
)

Parameters

strKeyName
Type: System..::..String
string类型的配置参数名称

Return Value

string类型的配置参数值

See Also

SysConfig Class


Team(TFish) Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Team<(Of <(<'TFish>)>)> Class
Members See Also Send Feedback
仿真比赛队伍数据类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class Team<TFish>
Visual Basic
<SerializableAttribute> _
Public Class Team(Of TFish)
Visual C++
[SerializableAttribute]
generic<typename TFish>
public ref class Team

Type Parameters

TFish

[Missing <typeparam name="TFish"/> documentation for "T:URWPGSim2D.Common.Team`1"]

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..Team<(Of <(<'TFish>)>)>

See Also

Team<(Of <(<'TFish>)>)> Members


Team(TFish) Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Team<(Of <(<'TFish>)>)> Members
Team<(Of <(<'TFish>)>)> Class Constructors Methods Fields See Also Send Feedback

The Team<(Of <(<'TFish>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Team<(Of <(<'TFish>)>)> | 构造函数

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Fishes | 仿真比赛队伍中仿真机器鱼列表
Public field | Para | 仿真比赛队伍公共参数

See Also

Team<(Of <(<'TFish>)>)> Class


Team(TFish) Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Team<(Of <(<'TFish>)>)> Constructor
Team<(Of <(<'TFish>)>)> Class See Also Send Feedback
构造函数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public Team()
Visual Basic
Public Sub New
Visual C++
public:
Team()

See Also

Team<(Of <(<'TFish>)>)> Class


Team(TFish) Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Team<(Of <(<'TFish>)>)> Fields
Team<(Of <(<'TFish>)>)> Class See Also Send Feedback

The Team<(Of <(<'TFish>)>)> type exposes the following members.

Fields

 | Name | Description
Public field | Fishes | 仿真比赛队伍中仿真机器鱼列表
Public field | Para | 仿真比赛队伍公共参数

See Also

Team<(Of <(<'TFish>)>)> Class


Fishes Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Team<(Of <(<'TFish>)>)>..::..Fishes Field
Team<(Of <(<'TFish>)>)> Class See Also Send Feedback
仿真比赛队伍中仿真机器鱼列表

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public List<TFish> Fishes
Visual Basic
Public Fishes As List(Of TFish)
Visual C++
public:
List<TFish>^ Fishes

See Also

Team<(Of <(<'TFish>)>)> Class


Para Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Team<(Of <(<'TFish>)>)>..::..Para Field
Team<(Of <(<'TFish>)>)> Class See Also Send Feedback
仿真比赛队伍公共参数

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public TeamCommonPara Para
Visual Basic
Public Para As TeamCommonPara
Visual C++
public:
TeamCommonPara^ Para

See Also

Team<(Of <(<'TFish>)>)> Class


Team(TFish) Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
Team<(Of <(<'TFish>)>)> Methods
Team<(Of <(<'TFish>)>)> Class See Also Send Feedback

The Team<(Of <(<'TFish>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Team<(Of <(<'TFish>)>)> Class


TeamCommonPara Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara Class
Members See Also Send Feedback
仿真机器鱼队伍公共参数类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
[SerializableAttribute]
public class TeamCommonPara : ICloneable,
    IDssSerializable
Visual Basic
<SerializableAttribute> _
Public Class TeamCommonPara _
    Implements ICloneable, IDssSerializable
Visual C++
[SerializableAttribute]
public ref class TeamCommonPara : ICloneable,
    IDssSerializable

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..TeamCommonPara

See Also

TeamCommonPara Members


TeamCommonPara Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara Members
TeamCommonPara Class Constructors Methods Fields See Also Send Feedback

The TeamCommonPara type exposes the following members.

Constructors

 | Name | Description
Public method | TeamCommonPara | Initializes a new instance of the TeamCommonPara class

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | FishCount | 仿真比赛队伍中仿真机器鱼数量
Public field | IsReady | 仿真比赛队伍是否已经准备好，按下了Ready按钮
Public field | MyHalfCourt | 仿真比赛队伍中所处仿真场地半场（左或右）
Public field | Name | 仿真比赛队伍名称
Public field | Score | 仿真比赛队伍中当前得分

See Also

TeamCommonPara Class


TeamCommonPara Constructor

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara Constructor
TeamCommonPara Class See Also Send Feedback
Initializes a new instance of the TeamCommonPara class

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public TeamCommonPara()
Visual Basic
Public Sub New
Visual C++
public:
TeamCommonPara()

See Also

TeamCommonPara Class


TeamCommonPara Fields

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara Fields
TeamCommonPara Class See Also Send Feedback

The TeamCommonPara type exposes the following members.

Fields

 | Name | Description
Public field | FishCount | 仿真比赛队伍中仿真机器鱼数量
Public field | IsReady | 仿真比赛队伍是否已经准备好，按下了Ready按钮
Public field | MyHalfCourt | 仿真比赛队伍中所处仿真场地半场（左或右）
Public field | Name | 仿真比赛队伍名称
Public field | Score | 仿真比赛队伍中当前得分

See Also

TeamCommonPara Class


FishCount Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara..::..FishCount Field
TeamCommonPara Class See Also Send Feedback
仿真比赛队伍中仿真机器鱼数量

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int FishCount
Visual Basic
Public FishCount As Integer
Visual C++
public:
int FishCount

See Also

TeamCommonPara Class


IsReady Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara..::..IsReady Field
TeamCommonPara Class See Also Send Feedback
仿真比赛队伍是否已经准备好，按下了Ready按钮

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public bool IsReady
Visual Basic
Public IsReady As Boolean
Visual C++
public:
bool IsReady

See Also

TeamCommonPara Class


MyHalfCourt Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara..::..MyHalfCourt Field
TeamCommonPara Class See Also Send Feedback
仿真比赛队伍中所处仿真场地半场（左或右）

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public HalfCourt MyHalfCourt
Visual Basic
Public MyHalfCourt As HalfCourt
Visual C++
public:
HalfCourt MyHalfCourt

See Also

TeamCommonPara Class


Name Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara..::..Name Field
TeamCommonPara Class See Also Send Feedback
仿真比赛队伍名称

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public string Name
Visual Basic
Public Name As String
Visual C++
public:
String^ Name

See Also

TeamCommonPara Class


Score Field

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara..::..Score Field
TeamCommonPara Class See Also Send Feedback
仿真比赛队伍中当前得分

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public int Score
Visual Basic
Public Score As Integer
Visual C++
public:
int Score

See Also

TeamCommonPara Class


TeamCommonPara Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara Methods
TeamCommonPara Class See Also Send Feedback

The TeamCommonPara type exposes the following members.

Methods

 | Name | Description
Public method | Clone | 实现Clone接口的方法，拷贝一份当前对象的副本
Public method | CopyTo | 实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象
Public method | Deserialize | 实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | 实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象
Public method | ToString | (Inherited from Object.)

See Also

TeamCommonPara Class


Clone Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara..::..Clone Method
TeamCommonPara Class See Also Send Feedback
实现Clone接口的方法，拷贝一份当前对象的副本

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

当前对象的副本

Implements

ICloneable..::..Clone()()()()
IDssSerializableClone()()()()

See Also

TeamCommonPara Class


CopyTo Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara..::..CopyTo Method
TeamCommonPara Class See Also Send Feedback
实现CopyTo接口的方法,将当前对象拷贝到target指定的IDssSerializable类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void CopyTo(
    IDssSerializable target
)
Visual Basic
Public Overridable Sub CopyTo ( _
    target As IDssSerializable _
)
Visual C++
public:
virtual void CopyTo(
    IDssSerializable^ target
)

Parameters

target
Type: IDssSerializable
当前对象拷贝到的目标对象

Implements

IDssSerializableCopyTo(IDssSerializable)

See Also

TeamCommonPara Class


Deserialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara..::..Deserialize Method
TeamCommonPara Class See Also Send Feedback
实现Deserialize接口的方法，从reader指定的BinaryReader类型对象中反序列化一个当前类型的对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual Object Deserialize(
    BinaryReader reader
)
Visual Basic
Public Overridable Function Deserialize ( _
    reader As BinaryReader _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IO..::..BinaryReader
反序列化操作的来源对象

Return Value

反序列化得到的当前类型对象

Implements

IDssSerializableDeserialize(BinaryReader)

See Also

TeamCommonPara Class


Serialize Method

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
TeamCommonPara..::..Serialize Method
TeamCommonPara Class See Also Send Feedback
实现Serialize接口的方法，将当前对象序列化到writer指定的BinaryWriter类型对象

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public virtual void Serialize(
    BinaryWriter writer
)
Visual Basic
Public Overridable Sub Serialize ( _
    writer As BinaryWriter _
)
Visual C++
public:
virtual void Serialize(
    BinaryWriter^ writer
)

Parameters

writer
Type: System.IO..::..BinaryWriter
当前对象序列化到的目标对象

Implements

IDssSerializableSerialize(BinaryWriter)

See Also

TeamCommonPara Class


UrwpgSimHelper Class

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper Class
Members See Also Send Feedback
URWPGSim项目需要用到的辅助功能静态类

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static class UrwpgSimHelper
Visual Basic
Public NotInheritable Class UrwpgSimHelper
Visual C++
public ref class UrwpgSimHelper abstract sealed

Inheritance Hierarchy

System..::..Object
URWPGSim2D.Common..::..UrwpgSimHelper

See Also

UrwpgSimHelper Members


UrwpgSimHelper Members

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper Members
UrwpgSimHelper Class Methods See Also Send Feedback

Methods

Name | Description
CoordinateTransformation(Single, Vector3, Vector3, Vector3%) | 本地坐标系到世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）的变换
CoordinateTransformation(Single, Vector3, Vector3%, Vector3) | 世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）到本地坐标系的变换
CoordinateTransformation(Single, Single, Single, Single, Single, Single%, Single%) | 本地坐标系到世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）的变换
CoordinateTransformation(Single, Single, Single, Single%, Single%, Single, Single) | 世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）到本地坐标系的变换
Max(Int32, Int32, Int32, Int32, Int32%) | 求4个值的int序列的最大值并标出最大值的序号（0,1,2,3）
Max(Single, Single, Single, Single, Int32%) | 求4个值的float序列的最大值并标出最大值的序号（0,1,2,3）
Min(Int32, Int32, Int32, Int32, Int32%) | 求4个值的int序列的最小值并标出最小值的序号（0,1,2,3）
Min(Single, Single, Single, Single, Int32%) | 求4个值的float序列的最小值并标出最小值的序号（0,1,2,3）

See Also

UrwpgSimHelper Class


UrwpgSimHelper Methods

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper Methods
UrwpgSimHelper Class See Also Send Feedback

Methods

Name | Description
CoordinateTransformation(Single, Vector3, Vector3, Vector3%) | 本地坐标系到世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）的变换
CoordinateTransformation(Single, Vector3, Vector3%, Vector3) | 世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）到本地坐标系的变换
CoordinateTransformation(Single, Single, Single, Single, Single, Single%, Single%) | 本地坐标系到世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）的变换
CoordinateTransformation(Single, Single, Single, Single%, Single%, Single, Single) | 世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）到本地坐标系的变换
Max(Int32, Int32, Int32, Int32, Int32%) | 求4个值的int序列的最大值并标出最大值的序号（0,1,2,3）
Max(Single, Single, Single, Single, Int32%) | 求4个值的float序列的最大值并标出最大值的序号（0,1,2,3）
Min(Int32, Int32, Int32, Int32, Int32%) | 求4个值的int序列的最小值并标出最小值的序号（0,1,2,3）
Min(Single, Single, Single, Single, Int32%) | 求4个值的float序列的最小值并标出最小值的序号（0,1,2,3）

See Also

UrwpgSimHelper Class


CoordinateTransformation Method

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper..::..CoordinateTransformation Method
UrwpgSimHelper Class See Also Send Feedback

Overload List

Name | Description
CoordinateTransformation(Single, Vector3, Vector3, Vector3%) | 本地坐标系到世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）的变换
CoordinateTransformation(Single, Vector3, Vector3%, Vector3) | 世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）到本地坐标系的变换
CoordinateTransformation(Single, Single, Single, Single, Single, Single%, Single%) | 本地坐标系到世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）的变换
CoordinateTransformation(Single, Single, Single, Single%, Single%, Single, Single) | 世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）到本地坐标系的变换

See Also

UrwpgSimHelper Class
UrwpgSimHelper Members


CoordinateTransformation Method (Single, , , )

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper..::..CoordinateTransformation Method (Single, , , %)
UrwpgSimHelper Class See Also Send Feedback
本地坐标系到世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）的变换

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static void CoordinateTransformation(
    float theta,
    Vector3 localOri,
    Vector3 local,
    ref Vector3 world
)
Visual Basic
Public Shared Sub CoordinateTransformation ( _
    theta As Single, _
    localOri As Vector3, _
    local As Vector3, _
    ByRef world As Vector3 _
)
Visual C++
public:
static void CoordinateTransformation(
    float theta,
    Vector3 localOri,
    Vector3 local,
    Vector3% world
)

Parameters

theta
Type: System..::..Single
本地坐标系X轴在世界坐标系中的角度值
localOri
Type: Vector3
输入参数，本地坐标系原点在世界坐标系下的xna.Vector3坐标值
local
Type: Vector3
输入参数，待变换坐标的点在本地坐标系下的xna.Vector3坐标值
world
Type: Vector3%
输出参数，待变换坐标的点在世界坐标系下的xna.Vector3坐标值

See Also

UrwpgSimHelper Class
CoordinateTransformation Overload


CoordinateTransformation Method (Single, , , )

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper..::..CoordinateTransformation Method (Single, , %, )
UrwpgSimHelper Class See Also Send Feedback
世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）到本地坐标系的变换

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static void CoordinateTransformation(
    float theta,
    Vector3 localOri,
    ref Vector3 local,
    Vector3 world
)
Visual Basic
Public Shared Sub CoordinateTransformation ( _
    theta As Single, _
    localOri As Vector3, _
    ByRef local As Vector3, _
    world As Vector3 _
)
Visual C++
public:
static void CoordinateTransformation(
    float theta,
    Vector3 localOri,
    Vector3% local,
    Vector3 world
)

Parameters

theta
Type: System..::..Single
本地坐标系X轴在世界坐标系中的角度值
localOri
Type: Vector3
输入参数，本地坐标系原点在世界坐标系下的xna.Vector3坐标值
local
Type: Vector3%
输出参数，待变换坐标的点在本地坐标系下的xna.Vector3坐标值
world
Type: Vector3
输入参数，待变换坐标的点在世界坐标系下的xna.Vector3坐标值

See Also

UrwpgSimHelper Class
CoordinateTransformation Overload


CoordinateTransformation Method (Single, Single, Single, Single, Single, Single, Single)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper..::..CoordinateTransformation Method (Single, Single, Single, Single, Single, Single%, Single%)
UrwpgSimHelper Class See Also Send Feedback
本地坐标系到世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）的变换

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static void CoordinateTransformation(
    float theta,
    float xLocalOri,
    float zLocalOri,
    float xLocal,
    float zLocal,
    ref float xWorld,
    ref float zWorld
)
Visual Basic
Public Shared Sub CoordinateTransformation ( _
    theta As Single, _
    xLocalOri As Single, _
    zLocalOri As Single, _
    xLocal As Single, _
    zLocal As Single, _
    ByRef xWorld As Single, _
    ByRef zWorld As Single _
)
Visual C++
public:
static void CoordinateTransformation(
    float theta,
    float xLocalOri,
    float zLocalOri,
    float xLocal,
    float zLocal,
    float% xWorld,
    float% zWorld
)

Parameters

theta
Type: System..::..Single
本地坐标系正X在世界坐标系中的角度值
xLocalOri
Type: System..::..Single
输入参数，本地坐标系原点在世界坐标系下的X坐标值
zLocalOri
Type: System..::..Single
输入参数，本地坐标系原点在世界坐标系下的Z坐标值
xLocal
Type: System..::..Single
输入参数，待变换坐标的点在本地坐标系下的X坐标值
zLocal
Type: System..::..Single
输入参数，待变换坐标的点在本地坐标系下的Z坐标值
xWorld
Type: System..::..Single %
输出参数，待变换坐标的点在世界坐标系下的X坐标值
zWorld
Type: System..::..Single %
输出参数，待变换坐标的点在世界坐标系下的Z坐标值

See Also

UrwpgSimHelper Class
CoordinateTransformation Overload


CoordinateTransformation Method (Single, Single, Single, Single, Single, Single, Single)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper..::..CoordinateTransformation Method (Single, Single, Single, Single%, Single%, Single, Single)
UrwpgSimHelper Class See Also Send Feedback
世界坐标系（仿真场地中心为原点，向右为正X，向下为Z的坐标系）到本地坐标系的变换

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static void CoordinateTransformation(
    float theta,
    float xLocalOri,
    float zLocalOri,
    ref float xLocal,
    ref float zLocal,
    float xWorld,
    float zWorld
)
Visual Basic
Public Shared Sub CoordinateTransformation ( _
    theta As Single, _
    xLocalOri As Single, _
    zLocalOri As Single, _
    ByRef xLocal As Single, _
    ByRef zLocal As Single, _
    xWorld As Single, _
    zWorld As Single _
)
Visual C++
public:
static void CoordinateTransformation(
    float theta,
    float xLocalOri,
    float zLocalOri,
    float% xLocal,
    float% zLocal,
    float xWorld,
    float zWorld
)

Parameters

theta
Type: System..::..Single
本地坐标系正X在世界坐标系中的角度值
xLocalOri
Type: System..::..Single
输入参数，本地坐标系原点在世界坐标系下的X坐标值
zLocalOri
Type: System..::..Single
输入参数，本地坐标系原点在世界坐标系下的Z坐标值
xLocal
Type: System..::..Single %
输出参数，待变换坐标的点在本地坐标系下的X坐标值
zLocal
Type: System..::..Single %
输出参数，待变换坐标的点在本地坐标系下的Z坐标值
xWorld
Type: System..::..Single
输入参数，待变换坐标的点在世界坐标系下的X坐标值
zWorld
Type: System..::..Single
输入参数，待变换坐标的点在世界坐标系下的Z坐标值

See Also

UrwpgSimHelper Class
CoordinateTransformation Overload


Max Method

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper..::..Max Method
UrwpgSimHelper Class See Also Send Feedback

Overload List

Name | Description
Max(Int32, Int32, Int32, Int32, Int32%) | 求4个值的int序列的最大值并标出最大值的序号（0,1,2,3）
Max(Single, Single, Single, Single, Int32%) | 求4个值的float序列的最大值并标出最大值的序号（0,1,2,3）

See Also

UrwpgSimHelper Class
UrwpgSimHelper Members


Max Method (Int32, Int32, Int32, Int32, Int32)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper..::..Max Method (Int32, Int32, Int32, Int32, Int32%)
UrwpgSimHelper Class See Also Send Feedback
求4个值的int序列的最大值并标出最大值的序号（0,1,2,3）

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static int Max(
    int value1,
    int value2,
    int value3,
    int value4,
    ref int seq
)
Visual Basic
Public Shared Function Max ( _
    value1 As Integer, _
    value2 As Integer, _
    value3 As Integer, _
    value4 As Integer, _
    ByRef seq As Integer _
) As Integer
Visual C++
public:
static int Max(
    int value1,
    int value2,
    int value3,
    int value4,
    int% seq
)

Parameters

value1
Type: System..::..Int32
第0号int值
value2
Type: System..::..Int32
第1号int值
value3
Type: System..::..Int32
第2号int值
value4
Type: System..::..Int32
第3号int值
seq
Type: System..::..Int32 %
最大值的序号（0,1,2,3）

Return Value

最大值

See Also

UrwpgSimHelper Class
Max Overload


Max Method (Single, Single, Single, Single, Int32)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper..::..Max Method (Single, Single, Single, Single, Int32%)
UrwpgSimHelper Class See Also Send Feedback
求4个值的float序列的最大值并标出最大值的序号（0,1,2,3）

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static float Max(
    float value1,
    float value2,
    float value3,
    float value4,
    ref int seq
)
Visual Basic
Public Shared Function Max ( _
    value1 As Single, _
    value2 As Single, _
    value3 As Single, _
    value4 As Single, _
    ByRef seq As Integer _
) As Single
Visual C++
public:
static float Max(
    float value1,
    float value2,
    float value3,
    float value4,
    int% seq
)

Parameters

value1
Type: System..::..Single
第0号整数
value2
Type: System..::..Single
第1号整数
value3
Type: System..::..Single
第2号整数
value4
Type: System..::..Single
第3号整数
seq
Type: System..::..Int32 %
最大值的序号（0,1,2,3）

Return Value

最大值

See Also

UrwpgSimHelper Class
Max Overload


Min Method

[image] [image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper..::..Min Method
UrwpgSimHelper Class See Also Send Feedback

Overload List

Name | Description
Min(Int32, Int32, Int32, Int32, Int32%) | 求4个值的int序列的最小值并标出最小值的序号（0,1,2,3）
Min(Single, Single, Single, Single, Int32%) | 求4个值的float序列的最小值并标出最小值的序号（0,1,2,3）

See Also

UrwpgSimHelper Class
UrwpgSimHelper Members


Min Method (Int32, Int32, Int32, Int32, Int32)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper..::..Min Method (Int32, Int32, Int32, Int32, Int32%)
UrwpgSimHelper Class See Also Send Feedback
求4个值的int序列的最小值并标出最小值的序号（0,1,2,3）

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static int Min(
    int value1,
    int value2,
    int value3,
    int value4,
    ref int seq
)
Visual Basic
Public Shared Function Min ( _
    value1 As Integer, _
    value2 As Integer, _
    value3 As Integer, _
    value4 As Integer, _
    ByRef seq As Integer _
) As Integer
Visual C++
public:
static int Min(
    int value1,
    int value2,
    int value3,
    int value4,
    int% seq
)

Parameters

value1
Type: System..::..Int32
第0号整数
value2
Type: System..::..Int32
第1号整数
value3
Type: System..::..Int32
第2号整数
value4
Type: System..::..Int32
第3号整数
seq
Type: System..::..Int32 %
最小值的序号（0,1,2,3）

Return Value

最小值

See Also

UrwpgSimHelper Class
Min Overload


Min Method (Single, Single, Single, Single, Int32)

[image]

Underwater Robot Water Polo Game Simulator 2D Class Library
UrwpgSimHelper..::..Min Method (Single, Single, Single, Single, Int32%)
UrwpgSimHelper Class See Also Send Feedback
求4个值的float序列的最小值并标出最小值的序号（0,1,2,3）

Namespace: URWPGSim2D.Common
Assembly: URWPGSim2D.Common (in URWPGSim2D.Common.dll) 版本: 1.0.11.316 (1.0.11.316)

Syntax

C#
public static float Min(
    float value1,
    float value2,
    float value3,
    float value4,
    ref int seq
)
Visual Basic
Public Shared Function Min ( _
    value1 As Single, _
    value2 As Single, _
    value3 As Single, _
    value4 As Single, _
    ByRef seq As Integer _
) As Single
Visual C++
public:
static float Min(
    float value1,
    float value2,
    float value3,
    float value4,
    int% seq
)

Parameters

value1
Type: System..::..Single
第0号float值
value2
Type: System..::..Single
第1号float值
value3
Type: System..::..Single
第2号float值
value4
Type: System..::..Single
第3号float值
seq
Type: System..::..Int32 %
最小值的序号（0,1,2,3）

Return Value

最小值

See Also

UrwpgSimHelper Class
Min Overload